summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPieter van den Abeele <pvdabeel@gentoo.org>2004-07-11 06:44:58 +0000
committerPieter van den Abeele <pvdabeel@gentoo.org>2004-07-11 06:44:58 +0000
commitc753183581e683b588cfe1c3b7e9b66680266480 (patch)
tree161c004c94f460a119cf1cd46ae1aa1ad6cdc92e
parentuse pdep, not rdep. (Manifest recommit) (diff)
downloadgentoo-2-c753183581e683b588cfe1c3b7e9b66680266480.tar.gz
gentoo-2-c753183581e683b588cfe1c3b7e9b66680266480.tar.bz2
gentoo-2-c753183581e683b588cfe1c3b7e9b66680266480.zip
I can get this to compile manually (described in the ebuild) but not using an ebuild. Autotools are evil.
-rw-r--r--net-libs/libwww/libwww-5.4.0-r2.ebuild23
1 files changed, 19 insertions, 4 deletions
diff --git a/net-libs/libwww/libwww-5.4.0-r2.ebuild b/net-libs/libwww/libwww-5.4.0-r2.ebuild
index bb8e0b4ecbaa..0db4483ff690 100644
--- a/net-libs/libwww/libwww-5.4.0-r2.ebuild
+++ b/net-libs/libwww/libwww-5.4.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libwww/libwww-5.4.0-r2.ebuild,v 1.17 2004/07/01 13:33:52 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libwww/libwww-5.4.0-r2.ebuild,v 1.18 2004/07/11 06:44:58 pvdabeel Exp $
inherit eutils
@@ -12,7 +12,7 @@ SRC_URI="http://www.w3.org/Library/Distribution/${MY_P}.tgz
LICENSE="W3C"
SLOT="0"
-KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64 s390 ppc64"
+KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64 s390 ppc64 ~macos"
IUSE="ssl mysql"
RDEPEND="dev-lang/perl
@@ -34,9 +34,23 @@ src_unpack() {
epatch ${FILESDIR}/${P}-automake-gentoo.diff # bug #41959
epatch ${FILESDIR}/${P}-disable-ndebug-gentoo.diff # bug #50483
- libtoolize -c -f || die "libtoolize failed"
+ # I can't get this part work correctly - stupid autotools
+ # The HAVE_APPKIT_APPKIT_H macro is automatically set to 1, but it shouldn't be because appkit is not
+ # what autotools think it is. I have tried everything from patching, to sed. Please help me out here
+
+ use macos && sed -e "s:#undef HAVE_APPKIT_APPKIT_H:#undef HAV_H:g" wwwconf.h.in > wwwconf.h.in
+
+ # The following works as expected
+
+ if use macos; then
+ glibtoolize -c -f || die "libtoolize failed"
+ else
+ libtoolize -c -f || die "libtoolize failed"
+ fi
+
aclocal || die "aclocal failed"
autoconf || die "autoconf failed"
+
}
src_compile() {
@@ -48,7 +62,8 @@ src_compile() {
--with-expat \
`use_with mysql` \
`use_with ssl` \
- || die
+ || die
+
emake || die
}