summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-11-26 17:12:53 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-11-26 17:12:53 +0000
commit1fb852255b8e276cf07c35fdca39f1c7fa7f138f (patch)
tree2a7399bcb020d847315d51faf5f14ec39d847c1a
parentPunt media-libs/gltt, bug 145969 (diff)
downloadgentoo-2-1fb852255b8e276cf07c35fdca39f1c7fa7f138f.tar.gz
gentoo-2-1fb852255b8e276cf07c35fdca39f1c7fa7f138f.tar.bz2
gentoo-2-1fb852255b8e276cf07c35fdca39f1c7fa7f138f.zip
Add patch to fix building with linux-headers-2.6.18, thanks to Shunichi Fuji in bug #156306; add missing dependencies over misc-fonts and unifont, also fix their path in the configuration file so that it does not try to load them from the outdated path for an old version of XFree86; use non-lazy bindings as the command is suid; add ~amd64 useflag.
(Portage version: 2.1.2_rc2-r2)
-rw-r--r--app-i18n/jfbterm/ChangeLog12
-rw-r--r--app-i18n/jfbterm/files/digest-jfbterm-0.4.7-r23
-rw-r--r--app-i18n/jfbterm/files/jfbterm-0.4.7-no-kernel-headers.patch17
-rw-r--r--app-i18n/jfbterm/jfbterm-0.4.7-r2.ebuild59
4 files changed, 90 insertions, 1 deletions
diff --git a/app-i18n/jfbterm/ChangeLog b/app-i18n/jfbterm/ChangeLog
index 1e641640480b..32208e9fab00 100644
--- a/app-i18n/jfbterm/ChangeLog
+++ b/app-i18n/jfbterm/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for app-i18n/jfbterm
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/jfbterm/ChangeLog,v 1.34 2006/10/14 09:31:33 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/jfbterm/ChangeLog,v 1.35 2006/11/26 17:12:53 flameeyes Exp $
+
+*jfbterm-0.4.7-r2 (26 Nov 2006)
+
+ 26 Nov 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/jfbterm-0.4.7-no-kernel-headers.patch, +jfbterm-0.4.7-r2.ebuild:
+ Add patch to fix building with linux-headers-2.6.18, thanks to Shunichi Fuji
+ in bug #156306; add missing dependencies over misc-fonts and unifont, also
+ fix their path in the configuration file so that it does not try to load
+ them from the outdated path for an old version of XFree86; use non-lazy
+ bindings as the command is suid; add ~amd64 useflag.
14 Oct 2006; Diego Pettenò <flameeyes@gentoo.org>
jfbterm-0.4.7-r1.ebuild:
diff --git a/app-i18n/jfbterm/files/digest-jfbterm-0.4.7-r2 b/app-i18n/jfbterm/files/digest-jfbterm-0.4.7-r2
new file mode 100644
index 000000000000..e9393b952732
--- /dev/null
+++ b/app-i18n/jfbterm/files/digest-jfbterm-0.4.7-r2
@@ -0,0 +1,3 @@
+MD5 cb0b869bd1c21f0dd224b7fc40517680 jfbterm-0.4.7.tar.gz 104592
+RMD160 814c9c78fd7da8d8a4747b2644f8007554e6679f jfbterm-0.4.7.tar.gz 104592
+SHA256 a18446040cfaadd51c1ce77bb06ba6860372a70a04e36962e2635253a1f693a3 jfbterm-0.4.7.tar.gz 104592
diff --git a/app-i18n/jfbterm/files/jfbterm-0.4.7-no-kernel-headers.patch b/app-i18n/jfbterm/files/jfbterm-0.4.7-no-kernel-headers.patch
new file mode 100644
index 000000000000..06c6e6033488
--- /dev/null
+++ b/app-i18n/jfbterm/files/jfbterm-0.4.7-no-kernel-headers.patch
@@ -0,0 +1,17 @@
+Remove usage of kernel headers, deprecated since linux-headers-2.6.18.
+Patch by Shunichi Fuji <palgowr@gmail.com>.
+
+See bug #156306
+
+--- jfbterm-0.4.7.orig/fbdpsp.c 2003-08-30 03:48:16.000000000 +0900
++++ jfbterm-0.4.7/fbdpsp.c 2006-11-27 01:22:20.000000000 +0900
+@@ -827,8 +827,7 @@
+
+ #ifdef JFB_VGA16FB
+
+-#include <asm/io.h>
+-#include <asm/system.h>
++#include <sys/io.h>
+
+ #define GRAPHICS_ADDR_REG 0x3ce /* Graphics address register. */
+ #define GRAPHICS_DATA_REG 0x3cf /* Graphics data register. */
diff --git a/app-i18n/jfbterm/jfbterm-0.4.7-r2.ebuild b/app-i18n/jfbterm/jfbterm-0.4.7-r2.ebuild
new file mode 100644
index 000000000000..aa75cc3e09b5
--- /dev/null
+++ b/app-i18n/jfbterm/jfbterm-0.4.7-r2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/jfbterm/jfbterm-0.4.7-r2.ebuild,v 1.1 2006/11/26 17:12:53 flameeyes Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit flag-o-matic eutils autotools
+
+DESCRIPTION="The J Framebuffer Terminal/Multilingual Enhancement with UTF-8 support"
+HOMEPAGE="http://jfbterm.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/${PN}/13501/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="media-fonts/unifont
+ media-fonts/font-misc-misc"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-sigchld-debian.patch"
+ epatch "${FILESDIR}/${P}-no-kernel-headers.patch"
+
+ eautoreconf
+
+ sed -i -e 's/a18/8x16/' \
+ -e 's:/usr/X11R6/lib/X11/fonts:/usr/share/fonts:' \
+ -e 's:/usr/share/fonts/misc/unifont:/usr/share/fonts/unifont/unifont:' \
+ jfbterm.conf.sample
+}
+
+src_compile() {
+ append-ldflags $(bindnow-flags)
+
+ econf \
+ $(use_enable debug) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodir /etc /usr/share/fonts/jfbterm
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+
+ dodir /usr/share/terminfo
+ tic terminfo.jfbterm -o"${D}"/usr/share/terminfo || die "tic failed"
+
+ mv "${D}"/etc/jfbterm.conf{.sample,}
+
+ doman jfbterm.1 jfbterm.conf.5
+
+ dodoc AUTHORS ChangeLog INSTALL* NEWS README*
+ dodoc jfbterm.conf.sample*
+}