summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2011-08-03 01:08:07 +0000
committerJim Ramsay <lack@gentoo.org>2011-08-03 01:08:07 +0000
commitc17fc495f5f07e2891c015a585dae7a51fc47ff9 (patch)
tree76886c392c00c6252540f8d71c2d23ad18870f29
parentVersion bump: 7.3.266 is released (diff)
downloadgentoo-2-c17fc495f5f07e2891c015a585dae7a51fc47ff9.tar.gz
gentoo-2-c17fc495f5f07e2891c015a585dae7a51fc47ff9.tar.bz2
gentoo-2-c17fc495f5f07e2891c015a585dae7a51fc47ff9.zip
Version bump: 7.3.266 is released
(Portage version: 2.1.9.49/cvs/Linux i686)
-rw-r--r--app-editors/gvim/ChangeLog7
-rw-r--r--app-editors/gvim/gvim-7.3.266.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/app-editors/gvim/ChangeLog b/app-editors/gvim/ChangeLog
index f1526ca3b46b..6bea997effca 100644
--- a/app-editors/gvim/ChangeLog
+++ b/app-editors/gvim/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/gvim
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/ChangeLog,v 1.353 2011/07/17 22:03:38 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/ChangeLog,v 1.354 2011/08/03 01:08:07 lack Exp $
+
+*gvim-7.3.266 (02 Aug 2011)
+
+ 02 Aug 2011; Jim Ramsay <lack@gentoo.org> +gvim-7.3.266.ebuild:
+ Version bump: 7.3.266 is released
17 Jul 2011; Mark Loeser <halcy0n@gentoo.org> gvim-7.3.189.ebuild:
Stable for ppc64; bug #371977
diff --git a/app-editors/gvim/gvim-7.3.266.ebuild b/app-editors/gvim/gvim-7.3.266.ebuild
new file mode 100644
index 000000000000..e1e4c684fcf4
--- /dev/null
+++ b/app-editors/gvim/gvim-7.3.266.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/gvim-7.3.266.ebuild,v 1.1 2011/08/03 01:08:07 lack Exp $
+
+EAPI=3
+VIM_VERSION="7.3"
+inherit vim
+
+VIM_ORG_PATCHES="vim-patches-${PV}.patch.bz2"
+GVIMRC_FILE_SUFFIX="-r1"
+GVIM_DESKTOP_SUFFIX="-r2"
+
+SRC_URI="ftp://ftp.vim.org/pub/vim/unix/vim-${VIM_VERSION}.tar.bz2
+ http://dev.gentoo.org/~lack/vim/${VIM_ORG_PATCHES}"
+
+S="${WORKDIR}/vim${VIM_VERSION/.}"
+DESCRIPTION="GUI version of the Vim text editor"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+src_prepare() {
+ vim_src_prepare
+
+ epatch "${FILESDIR}"/${PN}-7.1.285-darwin-x11link.patch
+ if [[ ${CHOST} == *-interix* ]]; then
+ epatch "${FILESDIR}"/${PN}-7.1-interix-link.patch
+ epatch "${FILESDIR}"/${PN}-7.1.319-interix-cflags.patch
+ fi
+}