summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2008-09-02 04:16:44 +0000
committerWilliam Hubbs <williamh@gentoo.org>2008-09-02 04:16:44 +0000
commit9b360e5dde495e52210c309a54e333f932903136 (patch)
treee8efcab013133f23a5a2a20b971cd207ca843d6d /app-accessibility/espeakup
parentStable for HPPA (bug #235926). (diff)
downloadgentoo-2-9b360e5dde495e52210c309a54e333f932903136.tar.gz
gentoo-2-9b360e5dde495e52210c309a54e333f932903136.tar.bz2
gentoo-2-9b360e5dde495e52210c309a54e333f932903136.zip
Initial commit.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo-r1 i686)
Diffstat (limited to 'app-accessibility/espeakup')
-rw-r--r--app-accessibility/espeakup/ChangeLog10
-rw-r--r--app-accessibility/espeakup/Manifest5
-rw-r--r--app-accessibility/espeakup/espeakup-0.2.ebuild34
-rw-r--r--app-accessibility/espeakup/files/espeakup.rc24
-rw-r--r--app-accessibility/espeakup/metadata.xml12
5 files changed, 85 insertions, 0 deletions
diff --git a/app-accessibility/espeakup/ChangeLog b/app-accessibility/espeakup/ChangeLog
new file mode 100644
index 000000000000..53775d7c7fdf
--- /dev/null
+++ b/app-accessibility/espeakup/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-accessibility/espeakup
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeakup/ChangeLog,v 1.1 2008/09/02 04:16:43 williamh Exp $
+
+*espeakup-0.2 (02 Sep 2008)
+
+ 02 Sep 2008; William Hubbs <williamh@gentoo.org> +files/espeakup.rc,
+ +metadata.xml, +espeakup-0.2.ebuild:
+ Initial commit.
+
diff --git a/app-accessibility/espeakup/Manifest b/app-accessibility/espeakup/Manifest
new file mode 100644
index 000000000000..fd50414528f4
--- /dev/null
+++ b/app-accessibility/espeakup/Manifest
@@ -0,0 +1,5 @@
+AUX espeakup.rc 347 RMD160 4e6844ebcbcf7c96fa544421308c353ce7fe6831 SHA1 ee2f2dbebfd1976f4e0996cbfd1db96ee241dd9b SHA256 00a72ff962b58407fb5f6bc9b998ba2a9f433e0ec5ed1af0f1802e0e2cc7a3bf
+DIST espeakup-0.2.tar.bz2 15907 RMD160 e9277b2e1a90be13d0ba41d426c9bc9376d85db7 SHA1 90223e15c13c0fe88cf6461829ca2ab49cb3145d SHA256 2ad7d279f4bf50b9a13b142aa4c0e9794a9e77206433d4fa6943e89b923a9709
+EBUILD espeakup-0.2.ebuild 840 RMD160 8482b49428f364608467a06544315cf3343bdc39 SHA1 351dd1d37de873dc0de4731123d895c89715522b SHA256 57b341a4a751009a4729a2e1ff9ccacb7a58b5dc91d82f724bebbaa6a5ed82db
+MISC ChangeLog 285 RMD160 1f8d6fc3874dbabfbc6f884e829042d07a31c6ea SHA1 23f60d15ecc23a16e657de2f684c9c08a3094b03 SHA256 ab2b0913fcd8149300740d30f6f8a7273b8fee0058b188069511a594a69a0548
+MISC metadata.xml 379 RMD160 da030cc3f768bd3756b9f602ac8f694d392eb84c SHA1 1f772643fe71cd3d2c01fdaef115fcc76bd8fe3c SHA256 730c8985450ad52a4d2f4f57884dc8973705daf107fb3bcdf433e0039f4f20d9
diff --git a/app-accessibility/espeakup/espeakup-0.2.ebuild b/app-accessibility/espeakup/espeakup-0.2.ebuild
new file mode 100644
index 000000000000..c17b5e5fe1cb
--- /dev/null
+++ b/app-accessibility/espeakup/espeakup-0.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeakup/espeakup-0.2.ebuild,v 1.1 2008/09/02 04:16:43 williamh Exp $
+
+DESCRIPTION="espeakup is a small lightweight connector for espeak and speakup"
+HOMEPAGE="http://www.linux-speakup.org"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="app-accessibility/espeak"
+RDEPEND="${DEPEND}
+ app-accessibility/speakup"
+
+src_compile() {
+ emake || die "Compile failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed."
+ dodoc README ToDo
+ newinitd "${FILESDIR}"/espeakup.rc espeakup
+}
+
+pkg_postinst() {
+ elog "To get espeakup to start automatically, it is currently recommended"
+ echo "that you add it to the default run level, by giving the following"
+ elog "command as root."
+ elog
+ elog "rc-update add espeakup default"
+}
diff --git a/app-accessibility/espeakup/files/espeakup.rc b/app-accessibility/espeakup/files/espeakup.rc
new file mode 100644
index 000000000000..890c1eb289e6
--- /dev/null
+++ b/app-accessibility/espeakup/files/espeakup.rc
@@ -0,0 +1,24 @@
+#!/sbin/runscript
+
+depend() {
+ after modules
+ use alsasound pulseaudio
+}
+
+start() {
+ ebegin "Starting espeakup"
+ start-stop-daemon --start --exec /usr/bin/espeakup
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping espeakup"
+ start-stop-daemon --stop --pidfile /var/run/espeakup.pid
+ eend $?
+}
+
+restart() {
+ svc_stop || exit 1
+ sleep 2
+ svc_start || exit 1
+}
diff --git a/app-accessibility/espeakup/metadata.xml b/app-accessibility/espeakup/metadata.xml
new file mode 100644
index 000000000000..484f3c3991ed
--- /dev/null
+++ b/app-accessibility/espeakup/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>accessibility</herd>
+<maintainer>
+ <email>williamh@gentoo.org</email>
+</maintainer>
+<longdescription>
+Espeakup is a small lightweight connector which makes it possible for
+speakup to use espeak as its synthesizer.
+</longdescription>
+</pkgmetadata>