summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-27 21:36:10 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-27 21:36:10 +0000
commitfcd4e3196ad6068c071a95c05a5e06b052edc9c9 (patch)
tree5b2fb4da36c723b1dcafb5140a73fcd24e3e4854 /app-crypt
parent~amd64 (Manifest recommit) (diff)
downloadgentoo-2-fcd4e3196ad6068c071a95c05a5e06b052edc9c9.tar.gz
gentoo-2-fcd4e3196ad6068c071a95c05a5e06b052edc9c9.tar.bz2
gentoo-2-fcd4e3196ad6068c071a95c05a5e06b052edc9c9.zip
touch the libc
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/johntheripper/johntheripper-1.6-r3.ebuild9
-rw-r--r--app-crypt/johntheripper/johntheripper-1.6.37-r1.ebuild8
-rw-r--r--app-crypt/keynote/keynote-2.3.ebuild17
-rw-r--r--app-crypt/mhash/mhash-0.8.18-r1.ebuild4
-rw-r--r--app-crypt/mhash/mhash-0.9.1.ebuild4
-rw-r--r--app-crypt/mit-krb5/mit-krb5-1.3.1-r1.ebuild8
-rw-r--r--app-crypt/mit-krb5/mit-krb5-1.3.1.ebuild8
-rw-r--r--app-crypt/mit-krb5/mit-krb5-1.3.3-r1.ebuild6
-rw-r--r--app-crypt/mit-krb5/mit-krb5-1.3.3.ebuild6
-rw-r--r--app-crypt/outguess/outguess-0.2.ebuild15
-rw-r--r--app-crypt/pgpdump/pgpdump-0.19.ebuild4
-rw-r--r--app-crypt/pgpdump/pgpdump-0.20.ebuild4
-rw-r--r--app-crypt/pgpdump/pgpdump-0.21.ebuild6
-rw-r--r--app-crypt/shash/shash-0.2.6.ebuild5
14 files changed, 43 insertions, 61 deletions
diff --git a/app-crypt/johntheripper/johntheripper-1.6-r3.ebuild b/app-crypt/johntheripper/johntheripper-1.6-r3.ebuild
index 26e708979967..17644403df32 100644
--- a/app-crypt/johntheripper/johntheripper-1.6-r3.ebuild
+++ b/app-crypt/johntheripper/johntheripper-1.6-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/johntheripper/johntheripper-1.6-r3.ebuild,v 1.3 2004/06/24 21:33:25 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/johntheripper/johntheripper-1.6-r3.ebuild,v 1.4 2004/06/27 21:31:47 vapier Exp $
inherit eutils flag-o-matic
@@ -23,15 +23,14 @@ SRC_URI="http://www.openwall.com/john/dl/${MY_P}.tar.gz
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~x86 ~sparc ~ppc ~alpha ~mips ~hppa"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~hppa"
IUSE="mmx ntlm skey mysql"
-RDEPEND="virtual/glibc
+RDEPEND="virtual/libc
skey? ( app-admin/skey )
kerberos? ( dev-libs/openssl )"
-
DEPEND="${RDEPEND}
sys-devel/binutils
sys-devel/gcc"
diff --git a/app-crypt/johntheripper/johntheripper-1.6.37-r1.ebuild b/app-crypt/johntheripper/johntheripper-1.6.37-r1.ebuild
index 7fed553b3325..b9591793b760 100644
--- a/app-crypt/johntheripper/johntheripper-1.6.37-r1.ebuild
+++ b/app-crypt/johntheripper/johntheripper-1.6.37-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/johntheripper/johntheripper-1.6.37-r1.ebuild,v 1.3 2004/06/24 21:33:25 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/johntheripper/johntheripper-1.6.37-r1.ebuild,v 1.4 2004/06/27 21:31:47 vapier Exp $
inherit eutils flag-o-matic
@@ -22,15 +22,13 @@ SRC_URI="http://www.openwall.com/john/b/${MY_P}.tar.gz
#
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~x86 ~sparc ~ppc ~alpha"
#KEYWORDS removed until "generic" target is fixed - "~mips ~hppa"
IUSE="mmx ntlm skey mysql kerberos"
-# use debug && RESTRICT="${RESTRICT} nostrip"
-
-RDEPEND="virtual/glibc
+RDEPEND="virtual/libc
skey? ( app-admin/skey )
kerberos? ( dev-libs/openssl )"
diff --git a/app-crypt/keynote/keynote-2.3.ebuild b/app-crypt/keynote/keynote-2.3.ebuild
index a8935fd9df74..e5fa2efc6569 100644
--- a/app-crypt/keynote/keynote-2.3.ebuild
+++ b/app-crypt/keynote/keynote-2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/keynote/keynote-2.3.ebuild,v 1.5 2004/06/24 21:33:45 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/keynote/keynote-2.3.ebuild,v 1.6 2004/06/27 21:32:11 vapier Exp $
DESCRIPTION="The KeyNote Trust-Management System"
HOMEPAGE="http://www1.cs.columbia.edu/~angelos/keynote.html"
@@ -11,34 +11,27 @@ SLOT="0"
KEYWORDS="x86"
IUSE="ssl"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
ssl? ( dev-libs/openssl )"
src_compile() {
-
econf || die
if use ssl; then
make || die
else
make nocrypto || die
fi
-
}
src_install() {
+ dobin keynote || die
- dobin keynote
-
- doman man/keynote.1
- doman man/keynote.3
- doman man/keynote.4
- doman man/keynote.5
+ doman man/keynote.[1345]
dolib.a libkeynote.a
insinto /usr/include
doins keynote.h
- dodoc README HOWTO.add.crypto TODO LICENSE
-
+ dodoc README HOWTO.add.crypto TODO
}
diff --git a/app-crypt/mhash/mhash-0.8.18-r1.ebuild b/app-crypt/mhash/mhash-0.8.18-r1.ebuild
index a155f0f56ece..990ef9cd6cab 100644
--- a/app-crypt/mhash/mhash-0.8.18-r1.ebuild
+++ b/app-crypt/mhash/mhash-0.8.18-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/mhash/mhash-0.8.18-r1.ebuild,v 1.10 2004/06/24 21:34:48 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/mhash/mhash-0.8.18-r1.ebuild,v 1.11 2004/06/27 21:33:02 vapier Exp $
DESCRIPTION="library providing a uniform interface to a large number of hash algorithms"
HOMEPAGE="http://mhash.sourceforge.net/"
@@ -11,7 +11,7 @@ SLOT="0"
KEYWORDS="x86 ppc sparc alpha hppa amd64 ia64 s390"
IUSE=""
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
RDEPEND=""
src_compile() {
diff --git a/app-crypt/mhash/mhash-0.9.1.ebuild b/app-crypt/mhash/mhash-0.9.1.ebuild
index 6f421d5ba8e2..0336b8ee8363 100644
--- a/app-crypt/mhash/mhash-0.9.1.ebuild
+++ b/app-crypt/mhash/mhash-0.9.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/mhash/mhash-0.9.1.ebuild,v 1.4 2004/06/24 21:34:48 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/mhash/mhash-0.9.1.ebuild,v 1.5 2004/06/27 21:33:02 vapier Exp $
DESCRIPTION="library providing a uniform interface to a large number of hash algorithms"
HOMEPAGE="http://mhash.sourceforge.net/"
@@ -11,7 +11,7 @@ SLOT="0"
KEYWORDS="x86 ppc sparc alpha arm hppa amd64 ia64 s390"
IUSE=""
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
RDEPEND=""
src_compile() {
diff --git a/app-crypt/mit-krb5/mit-krb5-1.3.1-r1.ebuild b/app-crypt/mit-krb5/mit-krb5-1.3.1-r1.ebuild
index eb91692f51fe..9cf5b109f64f 100644
--- a/app-crypt/mit-krb5/mit-krb5-1.3.1-r1.ebuild
+++ b/app-crypt/mit-krb5/mit-krb5-1.3.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/mit-krb5/mit-krb5-1.3.1-r1.ebuild,v 1.2 2004/06/24 21:35:05 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/mit-krb5/mit-krb5-1.3.1-r1.ebuild,v 1.3 2004/06/27 21:33:36 vapier Exp $
inherit eutils gnuconfig
@@ -15,13 +15,11 @@ SLOT="0"
KEYWORDS="x86 sparc ppc alpha hppa ia64 amd64 mips"
IUSE="krb4 static"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
sys-devel/autoconf
!virtual/krb5"
-
-RDEPEND="virtual/glibc
+RDEPEND="virtual/libc
!virtual/krb5"
-
PROVIDE="virtual/krb5"
src_unpack() {
diff --git a/app-crypt/mit-krb5/mit-krb5-1.3.1.ebuild b/app-crypt/mit-krb5/mit-krb5-1.3.1.ebuild
index ef9e78eb249e..a2ab9b680255 100644
--- a/app-crypt/mit-krb5/mit-krb5-1.3.1.ebuild
+++ b/app-crypt/mit-krb5/mit-krb5-1.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/mit-krb5/mit-krb5-1.3.1.ebuild,v 1.13 2004/06/24 21:35:05 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/mit-krb5/mit-krb5-1.3.1.ebuild,v 1.14 2004/06/27 21:33:36 vapier Exp $
inherit eutils gnuconfig
@@ -15,11 +15,9 @@ SLOT="0"
KEYWORDS="x86 sparc ppc alpha hppa ia64 amd64 mips s390"
IUSE="krb4 static"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
sys-devel/autoconf"
-
-RDEPEND="virtual/glibc"
-
+RDEPEND="virtual/libc"
PROVIDE="virtual/krb5"
src_unpack() {
diff --git a/app-crypt/mit-krb5/mit-krb5-1.3.3-r1.ebuild b/app-crypt/mit-krb5/mit-krb5-1.3.3-r1.ebuild
index d96fcc1f1db5..950669c0bfe6 100644
--- a/app-crypt/mit-krb5/mit-krb5-1.3.3-r1.ebuild
+++ b/app-crypt/mit-krb5/mit-krb5-1.3.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/mit-krb5/mit-krb5-1.3.3-r1.ebuild,v 1.7 2004/06/26 00:13:10 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/mit-krb5/mit-krb5-1.3.3-r1.ebuild,v 1.8 2004/06/27 21:33:36 vapier Exp $
inherit eutils
@@ -16,10 +16,10 @@ KEYWORDS="~x86 ~ppc sparc mips alpha arm hppa ~amd64 ~ia64 ~ppc64 ~s390"
IUSE="krb4 static"
RESTRICT="nomirror"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
sys-devel/autoconf
!virtual/krb5"
-RDEPEND="virtual/glibc
+RDEPEND="virtual/libc
!virtual/krb5"
PROVIDE="virtual/krb5"
diff --git a/app-crypt/mit-krb5/mit-krb5-1.3.3.ebuild b/app-crypt/mit-krb5/mit-krb5-1.3.3.ebuild
index fc36eae2b7b7..036535a3f54c 100644
--- a/app-crypt/mit-krb5/mit-krb5-1.3.3.ebuild
+++ b/app-crypt/mit-krb5/mit-krb5-1.3.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/mit-krb5/mit-krb5-1.3.3.ebuild,v 1.5 2004/06/24 21:35:05 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/mit-krb5/mit-krb5-1.3.3.ebuild,v 1.6 2004/06/27 21:33:36 vapier Exp $
inherit eutils
@@ -16,10 +16,10 @@ KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha arm ~hppa ~amd64 ~ia64 s390 ppc64"
IUSE="krb4 static"
RESTRICT="nomirror"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
sys-devel/autoconf
!virtual/krb5"
-RDEPEND="virtual/glibc
+RDEPEND="virtual/libc
!virtual/krb5"
PROVIDE="virtual/krb5"
diff --git a/app-crypt/outguess/outguess-0.2.ebuild b/app-crypt/outguess/outguess-0.2.ebuild
index 91f713a1d726..5d23db87fd6a 100644
--- a/app-crypt/outguess/outguess-0.2.ebuild
+++ b/app-crypt/outguess/outguess-0.2.ebuild
@@ -1,24 +1,21 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/outguess/outguess-0.2.ebuild,v 1.3 2004/06/24 21:35:52 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/outguess/outguess-0.2.ebuild,v 1.4 2004/06/27 21:34:15 vapier Exp $
-DESCRIPTION="A universal tool for inserting steganographic information into other data."
+DESCRIPTION="A universal tool for inserting steganographic information into other data"
HOMEPAGE="http://www.outguess.org/"
SRC_URI="http://packetstormsecurity.nl/crypt/stego/outguess-0.2.tar.gz"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="x86"
IUSE=""
-DEPEND="virtual/glibc"
-S=${WORKDIR}/${PN}
+DEPEND="virtual/libc"
-src_compile() {
- econf || die "./configure failed"
- emake || die "make failed"
-}
+S=${WORKDIR}/${PN}
src_install() {
dobin outguess || die "installation failed"
- doman outguess.1 || die "installation failed"
+ doman outguess.1
}
diff --git a/app-crypt/pgpdump/pgpdump-0.19.ebuild b/app-crypt/pgpdump/pgpdump-0.19.ebuild
index 632698a884df..c40fba5881de 100644
--- a/app-crypt/pgpdump/pgpdump-0.19.ebuild
+++ b/app-crypt/pgpdump/pgpdump-0.19.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/pgpdump/pgpdump-0.19.ebuild,v 1.5 2004/06/24 21:36:33 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pgpdump/pgpdump-0.19.ebuild,v 1.6 2004/06/27 21:34:58 vapier Exp $
DESCRIPTION="A PGP packet visualizer"
HOMEPAGE="http://pgp.iijlab.net/pgpdump.html"
@@ -11,7 +11,7 @@ SLOT="0"
KEYWORDS="x86"
IUSE=""
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
src_compile() {
econf || die
diff --git a/app-crypt/pgpdump/pgpdump-0.20.ebuild b/app-crypt/pgpdump/pgpdump-0.20.ebuild
index 2fd605c04004..2e954d944821 100644
--- a/app-crypt/pgpdump/pgpdump-0.20.ebuild
+++ b/app-crypt/pgpdump/pgpdump-0.20.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/pgpdump/pgpdump-0.20.ebuild,v 1.3 2004/06/24 21:36:33 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pgpdump/pgpdump-0.20.ebuild,v 1.4 2004/06/27 21:34:58 vapier Exp $
DESCRIPTION="A PGP packet visualizer"
HOMEPAGE="http://pgp.iijlab.net/pgpdump.html"
@@ -11,7 +11,7 @@ SLOT="0"
KEYWORDS="~x86 ~amd64"
IUSE=""
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
app-arch/bzip2"
src_compile() {
diff --git a/app-crypt/pgpdump/pgpdump-0.21.ebuild b/app-crypt/pgpdump/pgpdump-0.21.ebuild
index 5306191edafd..d922fc753730 100644
--- a/app-crypt/pgpdump/pgpdump-0.21.ebuild
+++ b/app-crypt/pgpdump/pgpdump-0.21.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/pgpdump/pgpdump-0.21.ebuild,v 1.3 2004/06/24 21:36:33 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pgpdump/pgpdump-0.21.ebuild,v 1.4 2004/06/27 21:34:58 vapier Exp $
DESCRIPTION="A PGP packet visualizer"
HOMEPAGE="http://pgp.iijlab.net/pgpdump.html"
@@ -8,10 +8,10 @@ SRC_URI="ftp://pgp.iijlab.net/pub/pgp/tools/${P}.tar.gz"
LICENSE="as-is"
SLOT="0"
-KEYWORDS="~x86 ~amd64 ~ppc ~sparc"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64"
IUSE=""
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
app-arch/bzip2"
src_compile() {
diff --git a/app-crypt/shash/shash-0.2.6.ebuild b/app-crypt/shash/shash-0.2.6.ebuild
index 43499157267b..856e04d06fcc 100644
--- a/app-crypt/shash/shash-0.2.6.ebuild
+++ b/app-crypt/shash/shash-0.2.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/shash/shash-0.2.6.ebuild,v 1.4 2004/06/24 21:38:01 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/shash/shash-0.2.6.ebuild,v 1.5 2004/06/27 21:36:10 vapier Exp $
DESCRIPTION="Generate or check digests or MACs of files"
HOMEPAGE="http://mcrypt.hellug.gr/shash/"
@@ -11,9 +11,8 @@ SLOT="0"
KEYWORDS="x86"
IUSE="static"
-RDEPEND="virtual/glibc
+RDEPEND="virtual/libc
>=app-crypt/mhash-0.8.18-r1"
-
DEPEND="${RDEPEND}
sys-devel/libtool
sys-devel/automake