summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2010-03-11 17:14:00 +0000
committerLance Albertson <ramereth@gentoo.org>2010-03-11 17:14:00 +0000
commit5658692166d8e918e0ce19a691f23a52e594728a (patch)
tree0d4ec548db9efdb73e078ae0f7cf6d224ef1b392 /app-emulation/ganeti-htools
parentMarking libiodbc-3.52.7 ppc for bug 286525 (diff)
downloadgentoo-2-5658692166d8e918e0ce19a691f23a52e594728a.tar.gz
gentoo-2-5658692166d8e918e0ce19a691f23a52e594728a.tar.bz2
gentoo-2-5658692166d8e918e0ce19a691f23a52e594728a.zip
Initial ebuild for ganeti-htools
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/ganeti-htools')
-rw-r--r--app-emulation/ganeti-htools/ChangeLog10
-rw-r--r--app-emulation/ganeti-htools/ganeti-htools-0.2.4.ebuild37
-rw-r--r--app-emulation/ganeti-htools/metadata.xml25
3 files changed, 72 insertions, 0 deletions
diff --git a/app-emulation/ganeti-htools/ChangeLog b/app-emulation/ganeti-htools/ChangeLog
new file mode 100644
index 000000000000..64dc7ba23dea
--- /dev/null
+++ b/app-emulation/ganeti-htools/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-emulation/ganeti-htools
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti-htools/ChangeLog,v 1.1 2010/03/11 17:14:00 ramereth Exp $
+
+*ganeti-htools-0.2.4 (11 Mar 2010)
+
+ 11 Mar 2010; Lance Albertson <ramereth@gentoo.org>
+ +ganeti-htools-0.2.4.ebuild, +metadata.xml:
+ Initial ebuild
+
diff --git a/app-emulation/ganeti-htools/ganeti-htools-0.2.4.ebuild b/app-emulation/ganeti-htools/ganeti-htools-0.2.4.ebuild
new file mode 100644
index 000000000000..567492f3ec34
--- /dev/null
+++ b/app-emulation/ganeti-htools/ganeti-htools-0.2.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti-htools/ganeti-htools-0.2.4.ebuild,v 1.1 2010/03/11 17:14:00 ramereth Exp $
+
+EAPI="2"
+
+inherit multilib
+
+DESCRIPTION="Cluster tools for fixing common allocation problems on Ganeti 2.0
+clusters."
+HOMEPAGE="http://code.google.com/p/ganeti/"
+SRC_URI="http://ganeti.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-lang/ghc
+ dev-haskell/json
+ dev-haskell/curl
+ dev-haskell/network"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # htools does not currently compile cleanly with ghc-6.12+, so remove this
+ # for now
+ sed -i -e "s:-Werror ::" Makefile
+}
+
+src_install() {
+ dosbin hspace hscan hbal
+ exeinto /usr/$(get_libdir)/ganeti/iallocators
+ doexe hail
+ doman *.1
+ dodoc README NEWS AUTHORS
+}
diff --git a/app-emulation/ganeti-htools/metadata.xml b/app-emulation/ganeti-htools/metadata.xml
new file mode 100644
index 000000000000..1f2b3ed14d10
--- /dev/null
+++ b/app-emulation/ganeti-htools/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>virtualization</herd>
+ <maintainer>
+ <email>ramereth@gentoo.org</email>
+ <name>Lance Albertson</name>
+ </maintainer>
+ <longdescription lang="en">
+ These are some simple cluster tools for fixing common allocation
+ problems on Ganeti 2.0 clusters.
+
+ Note that these tools are most useful for bigger cluster sizes
+ (e.g. more than five or ten machines); at lower sizes, the computations
+ they do can also be done manually.
+
+ Most of the tools revolve around the concept of keeping the cluster N+1
+ compliant: this means that in case of failure of any node, the instances
+ affected can be failed over (via ``gnt-node failover`` or ``gnt-instance
+ failover``) to their secondary node, and there is enough memory reserved
+ for this operation without needing to shutdown other instances or
+ rebalance the cluster.
+ </longdescription>
+</pkgmetadata>
+