summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2010-07-07 18:01:38 +0000
committerDoug Goldstein <cardoe@gentoo.org>2010-07-07 18:01:38 +0000
commita10ea893e6edf8bc26e10e5f8edaed4266feca52 (patch)
treed52350364287a313832f7cf24636e89c2a314891 /app-emulation
parentFix postinst message about reloading dbus as per bug 322805 (diff)
downloadgentoo-2-a10ea893e6edf8bc26e10e5f8edaed4266feca52.tar.gz
gentoo-2-a10ea893e6edf8bc26e10e5f8edaed4266feca52.tar.bz2
gentoo-2-a10ea893e6edf8bc26e10e5f8edaed4266feca52.zip
Bump for upstream bug fixes
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/kvm-kmod/ChangeLog9
-rw-r--r--app-emulation/kvm-kmod/kvm-kmod-2.6.32.16.ebuild66
-rw-r--r--app-emulation/kvm-kmod/kvm-kmod-2.6.34.1.ebuild (renamed from app-emulation/kvm-kmod/kvm-kmod-2.6.32.7.ebuild)2
3 files changed, 75 insertions, 2 deletions
diff --git a/app-emulation/kvm-kmod/ChangeLog b/app-emulation/kvm-kmod/ChangeLog
index 025f831efc99..694f2b7a6f52 100644
--- a/app-emulation/kvm-kmod/ChangeLog
+++ b/app-emulation/kvm-kmod/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/kvm-kmod
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/kvm-kmod/ChangeLog,v 1.11 2010/05/26 17:43:03 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/kvm-kmod/ChangeLog,v 1.12 2010/07/07 18:01:38 cardoe Exp $
+
+*kvm-kmod-2.6.34.1 (07 Jul 2010)
+*kvm-kmod-2.6.32.16 (07 Jul 2010)
+
+ 07 Jul 2010; Doug Goldstein <cardoe@gentoo.org> -kvm-kmod-2.6.32.7.ebuild,
+ +kvm-kmod-2.6.32.16.ebuild, +kvm-kmod-2.6.34.1.ebuild:
+ Bump for upstream bug fixes
*kvm-kmod-2.6.34 (26 May 2010)
diff --git a/app-emulation/kvm-kmod/kvm-kmod-2.6.32.16.ebuild b/app-emulation/kvm-kmod/kvm-kmod-2.6.32.16.ebuild
new file mode 100644
index 000000000000..812e94e27fdf
--- /dev/null
+++ b/app-emulation/kvm-kmod/kvm-kmod-2.6.32.16.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/kvm-kmod/kvm-kmod-2.6.32.16.ebuild,v 1.1 2010/07/07 18:01:38 cardoe Exp $
+
+EAPI="2"
+
+inherit eutils linux-mod
+
+SRC_URI="mirror://sourceforge/kvm/${P}.tar.bz2"
+
+DESCRIPTION="Kernel-based Virtual Machine kernel modules"
+HOMEPAGE="http://www.linux-kvm.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ if ! linux_chkconfig_present KVM; then
+ eerror "KVM now needs CONFIG_KVM built into your kernel, even"
+ eerror "if you're using the external modules from this package."
+ eerror "Please enable KVM support in your kernel, found at:"
+ eerror
+ eerror " Virtualization"
+ eerror " Kernel-based Virtual Machine (KVM) support"
+ eerror
+ die "KVM support not detected!"
+ fi
+ BUILD_TARGETS="all"
+ MODULE_NAMES="kvm(kernel/arch/x86/kvm/:${S}:${S}/x86)"
+ MODULE_NAMES="${MODULE_NAMES} kvm-intel(kernel/arch/x86/kvm/:${S}:${S}/x86)"
+ MODULE_NAMES="${MODULE_NAMES} kvm-amd(kernel/arch/x86/kvm/:${S}:${S}/x86)"
+ linux-mod_pkg_setup
+}
+
+src_configure() {
+ local conf_opts
+
+ conf_opts="--kerneldir=$KV_DIR"
+
+ if has_multilib_profile && [[ "${DEFAULT_ABI}" == "x86" ]] ; then
+ conf_opts="$conf_opts --arch=x86"
+ fi
+
+ ./configure ${conf_opts} || die "configure failed"
+}
+
+src_compile() {
+ linux-mod_src_compile
+}
+
+src_install() {
+ linux-mod_src_install
+}
+
+pkg_preinst() {
+ find /lib/modules/${KV_FULL} -name 'kvm*.ko' -type f -delete
+
+ linux-mod_pkg_preinst
+}
diff --git a/app-emulation/kvm-kmod/kvm-kmod-2.6.32.7.ebuild b/app-emulation/kvm-kmod/kvm-kmod-2.6.34.1.ebuild
index 67f20ff5d911..5a57adec85f9 100644
--- a/app-emulation/kvm-kmod/kvm-kmod-2.6.32.7.ebuild
+++ b/app-emulation/kvm-kmod/kvm-kmod-2.6.34.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/kvm-kmod/kvm-kmod-2.6.32.7.ebuild,v 1.1 2010/02/01 08:38:00 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/kvm-kmod/kvm-kmod-2.6.34.1.ebuild,v 1.1 2010/07/07 18:01:38 cardoe Exp $
EAPI="2"