summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-03-02 05:58:01 +0000
committerTim Harder <radhermit@gentoo.org>2012-03-02 05:58:01 +0000
commit4d7c9420788b439aa1755902d70c2f6f67864fc7 (patch)
treecb477839f651194959fdbb18bde81eb52d214453 /app-forensics
parentVersion bump (diff)
downloadgentoo-2-4d7c9420788b439aa1755902d70c2f6f67864fc7.tar.gz
gentoo-2-4d7c9420788b439aa1755902d70c2f6f67864fc7.tar.bz2
gentoo-2-4d7c9420788b439aa1755902d70c2f6f67864fc7.zip
Remove old.
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/sleuthkit/ChangeLog8
-rw-r--r--app-forensics/sleuthkit/files/sleuthkit-fscheck.c_fix.patch105
-rw-r--r--app-forensics/sleuthkit/files/sleuthkit-makefiles_fix.patch92
-rw-r--r--app-forensics/sleuthkit/metadata.xml4
-rw-r--r--app-forensics/sleuthkit/sleuthkit-2.09.ebuild62
-rw-r--r--app-forensics/sleuthkit/sleuthkit-3.0.0-r1.ebuild38
-rw-r--r--app-forensics/sleuthkit/sleuthkit-3.1.0.ebuild38
7 files changed, 7 insertions, 340 deletions
diff --git a/app-forensics/sleuthkit/ChangeLog b/app-forensics/sleuthkit/ChangeLog
index a177a9037f85..48270fcf5f53 100644
--- a/app-forensics/sleuthkit/ChangeLog
+++ b/app-forensics/sleuthkit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-forensics/sleuthkit
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/sleuthkit/ChangeLog,v 1.55 2012/03/01 23:31:01 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/sleuthkit/ChangeLog,v 1.56 2012/03/02 05:58:01 radhermit Exp $
+
+ 02 Mar 2012; Tim Harder <radhermit@gentoo.org> -sleuthkit-2.09.ebuild,
+ -sleuthkit-3.0.0-r1.ebuild, -sleuthkit-3.1.0.ebuild,
+ -files/sleuthkit-fscheck.c_fix.patch, -files/sleuthkit-makefiles_fix.patch,
+ metadata.xml:
+ Remove old.
01 Mar 2012; Brent Baude <ranger@gentoo.org> sleuthkit-3.2.1.ebuild:
Marking sleuthkit-3.2.1 ppc stable for bug 374321
diff --git a/app-forensics/sleuthkit/files/sleuthkit-fscheck.c_fix.patch b/app-forensics/sleuthkit/files/sleuthkit-fscheck.c_fix.patch
deleted file mode 100644
index d0d65b594584..000000000000
--- a/app-forensics/sleuthkit/files/sleuthkit-fscheck.c_fix.patch
+++ /dev/null
@@ -1,105 +0,0 @@
-diff -uNr -r sleuthkit-2.08-orig/src/fstools/fscheck.c sleuthkit-2.08/src/fstools/fscheck.c
---- sleuthkit-2.08-orig/src/fstools/fscheck.c 2007-03-13 21:05:37.000000000 +0100
-+++ sleuthkit-2.08/src/fstools/fscheck.c 2007-04-11 18:03:00.000000000 +0200
-@@ -11,8 +11,10 @@
- ** This software is distributed under the Common Public License 1.0
- **
- */
-+#include <locale.h>
- #include "fs_tools.h"
-
-+static TSK_TCHAR *progname;
-
- static void
- usage()
-@@ -36,58 +38,71 @@
- int
- main(int argc, char **argv)
- {
-- char *fstype = NULL;
-+ TSK_TCHAR *fstype = NULL;
- int ch;
-- FS_INFO *fs;
-- char *imgtype = NULL, *imgoff = NULL;
-- IMG_INFO *img;
-+ TSK_FS_INFO *fs;
-+ TSK_TCHAR *imgtype = NULL;
-+ SSIZE_T imgoff = 0;
-+ TSK_IMG_INFO *img;
-
- progname = argv[0];
-+ setlocale(LC_ALL, "");
-
-- while ((ch = getopt(argc, argv, "f:i:o:vV")) > 0) {
-+ while ((ch = getopt(argc, argv, _TSK_T("f:i:o:vV"))) > 0) {
- switch (ch) {
-- case '?':
-+ case _TSK_T('?'):
- default:
-- fprintf(stderr, "Invalid argument: %s\n", argv[optind]);
-+ fprintf(stderr, _TSK_T("Invalid argument: %s\n"), argv[optind]);
- usage();
-
-- case 'f':
-+ case _TSK_T('f'):
- fstype = optarg;
-+ if (TSTRCMP(fstype, _TSK_T("list")) == 0) {
-+ tsk_fs_print_types(stderr);
-+ exit(1);
-+ }
- break;
-
-- case 'i':
-+ case _TSK_T('i'):
- imgtype = optarg;
-+ if (TSTRCMP(imgtype, _TSK_T("list")) == 0) {
-+ tsk_img_print_types(stderr);
-+ exit(1);
-+ }
- break;
-
-- case 'o':
-- imgoff = optarg;
-+ case _TSK_T('o'):
-+ if ((imgoff = tsk_parse_offset(optarg)) == -1) {
-+ tsk_error_print(stderr);
-+ exit(1);
-+ }
- break;
-
-- case 'v':
-- verbose++;
-+ case _TSK_T('v'):
-+ tsk_verbose++;
- break;
-
-- case 'V':
-- print_version(stdout);
-+ case _TSK_T('V'):
-+ tsk_print_version(stdout);
- exit(0);
- }
- }
-
- /* We need at least one more argument */
- if (optind >= argc) {
-- fprintf(stderr, "Missing image name\n");
-+ tsk_fprintf(stderr, "Missing image name\n");
- usage();
- }
-
- img =
-- img_open(imgtype, imgoff, argc - optind,
-- (const char **) &argv[optind]);
-+ tsk_img_open(imgtype, argc - optind,
-+ (const TSK_TCHAR **) &argv[optind]);
- if (img == NULL) {
- tsk_error_print(stderr);
- exit(1);
- }
-
-- if (fs = fs_open(img, fstype)) {
-+ if (fs = tsk_fs_open(img, imgoff, fstype)) {
- if (tsk_errno == TSK_ERR_FS_UNSUPTYPE)
- tsk_print_types(stderr);
-
diff --git a/app-forensics/sleuthkit/files/sleuthkit-makefiles_fix.patch b/app-forensics/sleuthkit/files/sleuthkit-makefiles_fix.patch
deleted file mode 100644
index 5aa8a834133c..000000000000
--- a/app-forensics/sleuthkit/files/sleuthkit-makefiles_fix.patch
+++ /dev/null
@@ -1,92 +0,0 @@
-diff -uNr -r sleuthkit-2.08-orig/src/disktools/Makefile sleuthkit-2.08/src/disktools/Makefile
---- sleuthkit-2.08-orig/src/disktools/Makefile 2006-07-20 23:06:18.000000000 +0200
-+++ sleuthkit-2.08/src/disktools/Makefile 2007-04-11 17:07:09.982355393 +0200
-@@ -6,12 +6,19 @@
- BIN = ../../bin
- PROGS = $(BIN)/disk_stat $(BIN)/disk_sreset
- CFLAGS = $(DEFS) $(INCL) $(OPT) $(DEBUG) -I. -I ../auxtools/ $(XFLAGS)
-+
-+LIBOBJ = disk_stat.o disk_sreset.o ide.o
- LIBS = -L../../lib -ltsk
-+LIB = ../../lib/libtsk.a
-
- defs:
- @CC="$(CC)" sh ../makedefs $(MAKE)
-
--all: $(PROGS)
-+all: lib $(PROGS)
-+
-+lib: $(LIBOBJ)
-+ $(AR) $(LIB) $?
-+ $(RANLIB) $(LIB)
-
- $(BIN)/disk_stat: disk_stat.o ide.o
- $(CC) $(CFLAGS) -o $@ disk_stat.o ide.o $(LIBS)
-diff -uNr -r sleuthkit-2.08-orig/src/fstools/Makefile sleuthkit-2.08/src/fstools/Makefile
---- sleuthkit-2.08-orig/src/fstools/Makefile 2007-02-22 06:47:12.000000000 +0100
-+++ sleuthkit-2.08/src/fstools/Makefile 2007-04-11 17:16:39.145986814 +0200
-@@ -9,12 +9,12 @@
- INCL = -I../auxtools -I../imgtools
- CFLAGS = $(DEFS) $(INCL) $(OPT) $(DEBUG)
- LIBOBJ = fs_inode.o fs_io.o fs_open.o \
-- fs_dent.o fs_types.o fs_data.o fs_load.o \
-+ fs_dent.o fs_types.o fs_data.o fs_load.o fsstat.o fscheck.o \
- ffs.o ffs_dent.o ext2fs.o ext2fs_dent.o ext2fs_journal.o \
- fatfs.o fatfs_dent.o ntfs.o ntfs_dent.o swapfs.o rawfs.o \
-- dcalc_lib.o dcat_lib.o dls_lib.o dstat_lib.o ffind_lib.o \
-- fls_lib.o icat_lib.o ifind_lib.o ils_lib.o \
-- iso9660.o iso9660_dent.o \
-+ dcalc.o dcalc_lib.o dcat.o dcat_lib.o dls.o dls_lib.o dstat.o dstat_lib.o ffind_lib.o \
-+ fls.o fls_lib.o icat.o icat_lib.o ifind.o ifind_lib.o ils.o ils_lib.o istat.o \
-+ iso9660.o iso9660_dent.o jls.o jcat.o \
- hfs.o hfs_dent.o hfs_journal.o
- LIBS = -L../../lib -ltsk -lz -lcrypto
-
-diff -uNr -r sleuthkit-2.08-orig/src/hashtools/Makefile sleuthkit-2.08/src/hashtools/Makefile
---- sleuthkit-2.08-orig/src/hashtools/Makefile 2007-03-27 20:49:46.000000000 +0200
-+++ sleuthkit-2.08/src/hashtools/Makefile 2007-04-11 17:10:10.286508943 +0200
-@@ -7,7 +7,7 @@
- PROGS = $(BIN)/hfind
- CFLAGS = $(DEFS) $(INCL) $(OPT) $(DEBUG) -I. -I../auxtools $(XFLAGS)
-
--LIBOBJ = tm_lookup.o nsrl_index.o md5sum_index.o hk_index.o idxonly_index.o
-+LIBOBJ = tm_lookup.o nsrl_index.o md5sum_index.o hk_index.o idxonly_index.o hfind.o
- LIB = ../../lib/libtsk.a
-
- defs:
-diff -uNr -r sleuthkit-2.08-orig/src/imgtools/Makefile sleuthkit-2.08/src/imgtools/Makefile
---- sleuthkit-2.08-orig/src/imgtools/Makefile 2006-08-23 16:17:53.000000000 +0200
-+++ sleuthkit-2.08/src/imgtools/Makefile 2007-04-11 17:09:22.977220557 +0200
-@@ -7,7 +7,7 @@
- DEBUG = -g
- INCL = -I../auxtools -I../afflib/lib -I../libewf/src/
- CFLAGS = $(DEFS) $(INCL) $(OPT) $(DEBUG)
--LIBOBJ = img_open.o img_types.o raw.o split.o aff.o ewf.o
-+LIBOBJ = img_open.o img_types.o raw.o split.o aff.o ewf.o img_stat.o img_cat.o
- LIBS = -L../../lib -ltsk -lz -lcrypto
- LIB = ../../lib/libtsk.a
- BIN_DIR = ../../bin
-diff -uNr -r sleuthkit-2.08-orig/src/mmtools/Makefile sleuthkit-2.08/src/mmtools/Makefile
---- sleuthkit-2.08-orig/src/mmtools/Makefile 2007-04-04 20:48:46.000000000 +0200
-+++ sleuthkit-2.08/src/mmtools/Makefile 2007-04-11 17:08:56.842299225 +0200
-@@ -7,7 +7,7 @@
- DEBUG = -g
- INCL = -I../auxtools -I../imgtools
- CFLAGS = $(DEFS) $(INCL) $(OPT) $(DEBUG)
--LIBOBJ = mm_part.o mm_open.o mm_io.o mm_types.o dos.o mac.o bsd.o sun.o gpt.o
-+LIBOBJ = mm_part.o mm_open.o mm_io.o mm_types.o dos.o mac.o bsd.o sun.o gpt.o mmls.o mmstat.o
- LIBS = -L../../lib -ltsk -lz -lcrypto
- LIB = ../../lib/libtsk.a
- BIN_DIR = ../../bin
-diff -uNr -r sleuthkit-2.08-orig/src/srchtools/Makefile sleuthkit-2.08/src/srchtools/Makefile
---- sleuthkit-2.08-orig/src/srchtools/Makefile 2006-07-20 23:06:18.000000000 +0200
-+++ sleuthkit-2.08/src/srchtools/Makefile 2007-04-11 17:07:09.986355838 +0200
-@@ -7,7 +7,7 @@
- PROGS = $(BIN)/srch_strings $(BIN)/sigfind
- CFLAGS = $(DEFS) $(INCL) $(OPT) $(DEBUG) -I. -I ../auxtools $(XFLAGS)
-
--LIBOBJ = srch_strings.o
-+LIBOBJ = srch_strings.o sigfind.o
- LIBS = -L../../lib -ltsk
- LIB = ../../lib/libtsk.a
-
diff --git a/app-forensics/sleuthkit/metadata.xml b/app-forensics/sleuthkit/metadata.xml
index ac225733d13a..4ceb7cb89fae 100644
--- a/app-forensics/sleuthkit/metadata.xml
+++ b/app-forensics/sleuthkit/metadata.xml
@@ -2,11 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>forensics</herd>
-<maintainer>
- <email>forensics@gentoo.org</email>
-</maintainer>
<use>
- <flag name='dbtool'>Add patch for dbtool interface from PyFlag</flag>
<flag name='aff'>Enable extra aff formats</flag>
<flag name='ewf'>Enable libewf support</flag>
</use>
diff --git a/app-forensics/sleuthkit/sleuthkit-2.09.ebuild b/app-forensics/sleuthkit/sleuthkit-2.09.ebuild
deleted file mode 100644
index 17ed2d9d52eb..000000000000
--- a/app-forensics/sleuthkit/sleuthkit-2.09.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/sleuthkit/sleuthkit-2.09.ebuild,v 1.8 2011/07/24 18:22:23 armin76 Exp $
-
-inherit toolchain-funcs eutils
-
-DESCRIPTION="A collection of file system and media management forensic analysis tools"
-HOMEPAGE="http://www.sleuthkit.org/sleuthkit/"
-SRC_URI="mirror://sourceforge/sleuthkit/${P}.tar.gz
- dbtool? ( mirror://gentoo/${P}_dbtool.patch.bz2 ) "
-
-LICENSE="GPL-2 IBM"
-SLOT="0"
-KEYWORDS="amd64 hppa ppc x86"
-IUSE="dbtool"
-
-RDEPEND="dev-perl/DateManip"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- use dbtool && epatch "${WORKDIR}/${P}_dbtool.patch"
- epatch "${FILESDIR}/${PN}-makefiles_fix.patch"
- epatch "${FILESDIR}/${PN}-fscheck.c_fix.patch"
- sed -i '63,69d' src/timeline/config-perl || die "sed config-perl failed"
- sed -i 's:`cd ../..; pwd`:/usr:' src/sorter/install \
- || die "sed install failed"
-}
-
-src_compile() {
- export CC="$(tc-getCC)" OPT="${CFLAGS}"
- # Targets: this is so it doesn't remake sys-apps/file
- # -j1: it really doesn't compile well with -j2 or more,
- # even after having fixed the Makefiles... :(
- env -u CFLAGS \
- emake -j1 -e bin no-perl sorter mactime || die "make failed"
-}
-
-src_install() {
- dobin bin/* || die "dobin failed"
- if has_version 'sys-apps/dstat' ; then
- mv ${D}/usr/bin/dstat ${D}/usr/bin/dstat-dsk
- echo
- ewarn "You are installing sleuthkit while you have sys-apps/dstat"
- ewarn "already installed."
- ewarn "app-forensics/sleuthkit provides /usr/bin/dstat which is a tool"
- ewarn "that displays details of a data structure, while sys-apps/dstat"
- ewarn "provides /usr/bin/dstat as a system statistics tool."
- echo
- ewarn "The Sleuth Kit dstat binary has been renamed to"
- ewarn "/usr/bin/dstat-tsk (see bug 131268). This may cause trouble with"
- ewarn "applications using sleuthkit such as Autopsy. You may prefer"
- ewarn "to unmerge sys-apps/dstat and re-emerge app-forensics/sleuthkit."
- echo
- fi
- dodoc docs/*.txt
- docinto api-doc
- dohtml docs/api-doc/*
- insinto /usr/share/sorter
- doins share/sorter/*
- doman man/man1/*
-}
diff --git a/app-forensics/sleuthkit/sleuthkit-3.0.0-r1.ebuild b/app-forensics/sleuthkit/sleuthkit-3.0.0-r1.ebuild
deleted file mode 100644
index c55ad7a20457..000000000000
--- a/app-forensics/sleuthkit/sleuthkit-3.0.0-r1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/sleuthkit/sleuthkit-3.0.0-r1.ebuild,v 1.6 2011/07/24 18:22:23 armin76 Exp $
-
-inherit eutils flag-o-matic autotools
-
-SLOT=0
-
-DESCRIPTION="A collection of file system and media management forensic analysis tools"
-HOMEPAGE="http://www.sleuthkit.org/sleuthkit/"
-SRC_URI="mirror://sourceforge/sleuthkit/${P}.tar.gz"
-
-LICENSE="GPL-2 IBM"
-KEYWORDS="~amd64 ~hppa ~ppc ~x86"
-
-DEPEND="ewf? ( app-forensics/libewf )
- aff? ( app-forensics/afflib )"
-RDEPEND="${DEPEND}
- dev-perl/DateManip"
-
-IUSE="aff ewf"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # AC_FUNC_REALLOC in configure.ac that hasn't been propagated
- eautoreconf
-}
-
-src_compile() {
- econf || die "configure failed"
- emake || die "make failed"
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
- dodoc docs/*.txt README.txt CHANGES.txt TODO.txt
-}
diff --git a/app-forensics/sleuthkit/sleuthkit-3.1.0.ebuild b/app-forensics/sleuthkit/sleuthkit-3.1.0.ebuild
deleted file mode 100644
index 7446682941ab..000000000000
--- a/app-forensics/sleuthkit/sleuthkit-3.1.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/sleuthkit/sleuthkit-3.1.0.ebuild,v 1.3 2011/07/24 18:22:23 armin76 Exp $
-
-inherit eutils flag-o-matic autotools
-
-SLOT=0
-
-DESCRIPTION="A collection of file system and media management forensic analysis tools"
-HOMEPAGE="http://www.sleuthkit.org/sleuthkit/"
-SRC_URI="mirror://sourceforge/sleuthkit/${P}.tar.gz"
-
-LICENSE="GPL-2 IBM"
-KEYWORDS="~amd64 ~hppa ~ppc ~x86"
-
-DEPEND="ewf? ( app-forensics/libewf )
- aff? ( app-forensics/afflib )"
-RDEPEND="${DEPEND}
- dev-perl/DateManip"
-
-IUSE="aff ewf"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # AC_FUNC_REALLOC in configure.ac that hasn't been propagated
- eautoreconf
-}
-
-src_compile() {
- econf || die "configure failed"
- emake || die "make failed"
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
- dodoc docs/*.txt README.txt CHANGES.txt TODO.txt
-}