summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-01-31 07:44:30 +0000
committerJustin Lecher <jlec@gentoo.org>2011-01-31 07:44:30 +0000
commit2d06485855a42f538ee49fc28fce151cf4adc5ec (patch)
treef0a8f09c39df662318e05b5481f1825531c9bb02 /app-office/texmaker
parentRemove old version. (diff)
downloadgentoo-2-2d06485855a42f538ee49fc28fce151cf4adc5ec.tar.gz
gentoo-2-2d06485855a42f538ee49fc28fce151cf4adc5ec.tar.bz2
gentoo-2-2d06485855a42f538ee49fc28fce151cf4adc5ec.zip
Version Bump
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'app-office/texmaker')
-rw-r--r--app-office/texmaker/ChangeLog8
-rw-r--r--app-office/texmaker/files/texmaker-2.21-hunspell.patch124
-rw-r--r--app-office/texmaker/texmaker-2.21.ebuild62
3 files changed, 193 insertions, 1 deletions
diff --git a/app-office/texmaker/ChangeLog b/app-office/texmaker/ChangeLog
index 610a288eaf6c..c0e1576f1725 100644
--- a/app-office/texmaker/ChangeLog
+++ b/app-office/texmaker/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/texmaker
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/ChangeLog,v 1.74 2011/01/26 11:18:28 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/ChangeLog,v 1.75 2011/01/31 07:44:30 jlec Exp $
+
+*texmaker-2.21 (31 Jan 2011)
+
+ 31 Jan 2011; Justin Lecher <jlec@gentoo.org> +texmaker-2.21.ebuild,
+ +files/texmaker-2.21-hunspell.patch:
+ Version Bump
*texmaker-2.20 (26 Jan 2011)
diff --git a/app-office/texmaker/files/texmaker-2.21-hunspell.patch b/app-office/texmaker/files/texmaker-2.21-hunspell.patch
new file mode 100644
index 000000000000..0e115e4890e4
--- /dev/null
+++ b/app-office/texmaker/files/texmaker-2.21-hunspell.patch
@@ -0,0 +1,124 @@
+diff --git a/latexeditor.h b/latexeditor.h
+index d339f7b..32a7f0e 100644
+--- a/latexeditor.h
++++ b/latexeditor.h
+@@ -22,7 +22,7 @@
+
+ #include "latexhighlighter.h"
+ #include "parenmatcher.h"
+-#include "hunspell/hunspell.hxx"
++#include <hunspell.hxx>
+
+ //class QCompleter;
+ //class ParenMatcher;
+diff --git a/latexeditorview.h b/latexeditorview.h
+index 5635464..8fb37cb 100644
+--- a/latexeditorview.h
++++ b/latexeditorview.h
+@@ -18,7 +18,7 @@
+ #include "latexeditor.h"
+ #include "linenumberwidget.h"
+ #include "findwidget.h"
+-#include "hunspell/hunspell.hxx"
++#include <hunspell.hxx>
+
+ class LatexEditorView : public QWidget {
+ Q_OBJECT
+diff --git a/latexhighlighter.h b/latexhighlighter.h
+index 453bab7..c0b9fde 100644
+--- a/latexhighlighter.h
++++ b/latexhighlighter.h
+@@ -19,7 +19,7 @@
+ #include <QTextCharFormat>
+ #include <QColor>
+ #include <QTextBlockUserData>
+-#include "hunspell/hunspell.hxx"
++#include <hunspell.hxx>
+
+ class QTextDocument;
+
+diff --git a/spellerdialog.h b/spellerdialog.h
+index 88e1c93..2622834 100644
+--- a/spellerdialog.h
++++ b/spellerdialog.h
+@@ -13,7 +13,7 @@
+
+ #include "ui_spellerdialog.h"
+ #include "latexeditor.h"
+-#include "hunspell/hunspell.hxx"
++#include <hunspell.hxx>
+
+ #include <QTextCursor>
+
+diff --git a/texmaker.h b/texmaker.h
+index a959fe8..551fe20 100644
+--- a/texmaker.h
++++ b/texmaker.h
+@@ -43,7 +43,7 @@
+ #include "logeditor.h"
+ #include "gotolinedialog.h"
+ #include "replacedialog.h"
+-#include "hunspell/hunspell.hxx"
++#include <hunspell.hxx>
+ #include "browser.h"
+ #include "pdfviewer.h"
+
+diff --git a/texmaker.pro b/texmaker.pro
+index f36cf16..dbd73b8 100755
+--- a/texmaker.pro
++++ b/texmaker.pro
+@@ -4,7 +4,8 @@ TARGET = texmaker
+ QT += network \
+ xml \
+ webkit
+-CONFIG += qt warn_off release
++CONFIG += qt warn_off release link_pkgconfig
++PKGCONFIG = hunspell
+ TEXMAKERVERSION=2.2.1
+ DEFINES += TEXMAKERVERSION=\\\"$${TEXMAKERVERSION}\\\"
+ DEFINES += HAVE_SPLASH
+@@ -54,25 +55,6 @@ HEADERS += texmaker.h \
+ userquickdialog.h \
+ synctex_parser.h \
+ synctex_parser_utils.h \
+- hunspell/affentry.hxx \
+- hunspell/affixmgr.hxx \
+- hunspell/atypes.hxx \
+- hunspell/baseaffix.hxx \
+- hunspell/csutil.hxx \
+- hunspell/dictmgr.hxx \
+- hunspell/hashmgr.hxx \
+- hunspell/htypes.hxx \
+- hunspell/hunspell.hxx \
+- hunspell/hunspell.h \
+- hunspell/langnum.hxx \
+- hunspell/license.hunspell \
+- hunspell/phonet.hxx \
+- hunspell/suggestmgr.hxx \
+- hunspell/license.myspell \
+- hunspell/filemgr.hxx \
+- hunspell/hunzip.hxx \
+- hunspell/replist.hxx \
+- hunspell/w_char.hxx \
+ singleapp/qtlocalpeer.h \
+ singleapp/qtlockedfile.h \
+ singleapp/qtsingleapplication.h \
+@@ -121,18 +103,6 @@ SOURCES += main.cpp \
+ userquickdialog.cpp \
+ synctex_parser.c \
+ synctex_parser_utils.c \
+- hunspell/affentry.cxx \
+- hunspell/affixmgr.cxx \
+- hunspell/csutil.cxx \
+- hunspell/dictmgr.cxx \
+- hunspell/hashmgr.cxx \
+- hunspell/hunspell.cxx \
+- hunspell/phonet.cxx \
+- hunspell/suggestmgr.cxx \
+- hunspell/utf_info.cxx \
+- hunspell/filemgr.cxx \
+- hunspell/replist.cxx \
+- hunspell/hunzip.cxx \
+ singleapp/qtlocalpeer.cpp \
+ singleapp/qtlockedfile.cpp \
+ singleapp/qtsingleapplication.cpp \
diff --git a/app-office/texmaker/texmaker-2.21.ebuild b/app-office/texmaker/texmaker-2.21.ebuild
new file mode 100644
index 000000000000..ced36c9a33c0
--- /dev/null
+++ b/app-office/texmaker/texmaker-2.21.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/texmaker-2.21.ebuild,v 1.1 2011/01/31 07:44:30 jlec Exp $
+
+EAPI="3"
+
+inherit base qt4-r2 versionator
+
+# The upstream version numbering is bad, so we have to remove a dot in the
+# minor version number
+MAJOR="$(get_major_version)"
+MINOR_1="$(($(get_version_component_range 2)/10))"
+MINOR_2="$(($(get_version_component_range 2)%10))"
+if [ ${MINOR_2} -eq "0" ] ; then
+ MY_P="${PN}-${MAJOR}.${MINOR_1}"
+else
+ MY_P="${PN}-${MAJOR}.${MINOR_1}.${MINOR_2}"
+fi
+
+DESCRIPTION="A nice LaTeX-IDE"
+HOMEPAGE="http://www.xm1math.net/texmaker/"
+SRC_URI="http://www.xm1math.net/texmaker/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+COMMON_DEPEND="
+ app-text/poppler[qt4]
+ x11-libs/libX11
+ x11-libs/libXext
+ >=x11-libs/qt-gui-4.6.1:4
+ >=x11-libs/qt-core-4.6.1:4
+ >=x11-libs/qt-webkit-4.6.1:4
+ >=app-text/hunspell-1.2.4"
+RDEPEND="${COMMON_DEPEND}
+ virtual/latex-base
+ app-text/psutils
+ app-text/ghostscript-gpl
+ media-libs/netpbm"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${P}-hunspell.patch" )
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "make install failed"
+
+ insinto /usr/share/pixmaps/texmaker
+ doins utilities/texmaker*.png || die "doins failed."
+ doins utilities/texmaker.svg || die "doins failed."
+
+ dodoc utilities/AUTHORS utilities/CHANGELOG.txt || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog "A user manual with many screenshots is available at:"
+ elog "/usr/share/${PN}/usermanual_en.html"
+}