summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2014-02-18 12:14:42 +0000
committerSergey Popov <pinkbyte@gentoo.org>2014-02-18 12:14:42 +0000
commitda1dd94ab5f22235c788a47a2dd064918c4dfd3f (patch)
treebb3342b94842cf7ea89826ced9318fb570778dda /dev-cpp
parentsci-physics/lammps-20140212: Simplify USE flag logic. (diff)
downloadgentoo-2-da1dd94ab5f22235c788a47a2dd064918c4dfd3f.tar.gz
gentoo-2-da1dd94ab5f22235c788a47a2dd064918c4dfd3f.tar.bz2
gentoo-2-da1dd94ab5f22235c788a47a2dd064918c4dfd3f.zip
Version bump, wrt bug #500140. EAPI 5, migrate to autotools-utils and python-any-r1 eclasses
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/ctemplate/ChangeLog8
-rw-r--r--dev-cpp/ctemplate/ctemplate-2.2_p129.ebuild69
2 files changed, 76 insertions, 1 deletions
diff --git a/dev-cpp/ctemplate/ChangeLog b/dev-cpp/ctemplate/ChangeLog
index f6516f8b7cdb..9faa32dc1824 100644
--- a/dev-cpp/ctemplate/ChangeLog
+++ b/dev-cpp/ctemplate/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/ctemplate
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ctemplate/ChangeLog,v 1.28 2014/02/18 12:11:32 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ctemplate/ChangeLog,v 1.29 2014/02/18 12:14:42 pinkbyte Exp $
+
+*ctemplate-2.2_p129 (18 Feb 2014)
+
+ 18 Feb 2014; Sergey Popov <pinkbyte@gentoo.org> +ctemplate-2.2_p129.ebuild:
+ Version bump, wrt bug #500140. EAPI 5, migrate to autotools-utils and
+ python-any-r1 eclasses
18 Feb 2014; Sergey Popov <pinkbyte@gentoo.org> -ctemplate-1.0.ebuild,
-files/ctemplate-1.0-gcc-4.7.patch, -ctemplate-2.0.ebuild:
diff --git a/dev-cpp/ctemplate/ctemplate-2.2_p129.ebuild b/dev-cpp/ctemplate/ctemplate-2.2_p129.ebuild
new file mode 100644
index 000000000000..d062f51bd12a
--- /dev/null
+++ b/dev-cpp/ctemplate/ctemplate-2.2_p129.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ctemplate/ctemplate-2.2_p129.ebuild,v 1.1 2014/02/18 12:14:42 pinkbyte Exp $
+
+EAPI="5"
+
+AM_OPTS="--force-missing"
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+PYTHON_COMPAT=( python2_7 )
+inherit autotools-utils elisp-common python-any-r1
+
+DESCRIPTION="A simple but powerful template language for C++"
+HOMEPAGE="http://code.google.com/p/ctemplate/"
+SRC_URI="http://dev.gentoo.org/~pinkbyte/distfiles/snapshots/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc emacs vim-syntax static-libs test"
+
+DEPEND="test? ( ${PYTHON_DEPS} )"
+RDEPEND="vim-syntax? ( >=app-editors/vim-core-7 )
+ emacs? ( virtual/emacs )"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+SITEFILE="70ctemplate-gentoo.el"
+
+# Some tests are broken in 2.2_p129
+RESTRICT="test"
+
+src_compile() {
+ autotools-utils_src_compile
+
+ if use emacs ; then
+ elisp-compile contrib/tpl-mode.el || die "elisp-compile failed"
+ fi
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ # Installs just every piece
+ rm -rf "${ED}/usr/share/doc"
+
+ use doc && dohtml doc/*
+
+ if use vim-syntax ; then
+ cd "${S}/contrib"
+ sh highlighting.vim || die "unpacking vim scripts failed"
+ insinto /usr/share/vim/vimfiles
+ doins -r .vim/*
+ fi
+
+ if use emacs ; then
+ cd "${S}/contrib"
+ elisp-install ${PN} tpl-mode.el tpl-mode.elc || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}