summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-11-10 11:21:56 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-11-10 11:21:56 +0000
commit77b73e8dbbe778f0ba110c1c17cec31c9d0b62f9 (patch)
tree15a3b3743bc1a97ca2d70f3357d2126c9ccc73b8 /dev-db/unixODBC
parentnew version (diff)
downloadgentoo-2-77b73e8dbbe778f0ba110c1c17cec31c9d0b62f9.tar.gz
gentoo-2-77b73e8dbbe778f0ba110c1c17cec31c9d0b62f9.tar.bz2
gentoo-2-77b73e8dbbe778f0ba110c1c17cec31c9d0b62f9.zip
A=-fix
Diffstat (limited to 'dev-db/unixODBC')
-rw-r--r--dev-db/unixODBC/unixODBC-2.0.6.ebuild53
-rw-r--r--dev-db/unixODBC/unixODBC-2.0.8.ebuild48
2 files changed, 52 insertions, 49 deletions
diff --git a/dev-db/unixODBC/unixODBC-2.0.6.ebuild b/dev-db/unixODBC/unixODBC-2.0.6.ebuild
index 2b222ab7e40d..1592281fbd46 100644
--- a/dev-db/unixODBC/unixODBC-2.0.6.ebuild
+++ b/dev-db/unixODBC/unixODBC-2.0.6.ebuild
@@ -1,12 +1,11 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Your Name <your email>
-# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.0.6.ebuild,v 1.1 2001/04/22 20:10:39 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.0.6.ebuild,v 1.2 2001/11/10 11:21:56 hallski Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="ODBC Interface for Linux"
-SRC_URI="http://www.unixodbc.org/${A}"
+SRC_URI="http://www.unixodbc.org/${P}.tar.gz"
HOMEPAGE="http://www.unixodbc.org"
DEPEND="virtual/glibc
@@ -15,33 +14,35 @@ DEPEND="virtual/glibc
qt? ( >=x11-libs/qt-x11-2.3.0 )"
src_unpack() {
-
- unpack ${A}
- cd ${S}
- cp Makefile.in Makefile.orig
- sed -e "s:touch :touch \${DESTDIR}/:" Makefile.orig > Makefile.in
-
+ unpack ${A}
+ cd ${S}
+ cp Makefile.in Makefile.orig
+ sed -e "s:touch :touch \${DESTDIR}/:" Makefile.orig > Makefile.in
}
-src_compile() {
- local myconf
- if [ "`use qt`" ]
- then
- myconf="--enable-gui=yes"
- else
- myconf="--enable-gui=no"
- fi
- try ./configure --prefix=/usr --sysconfdir=/etc/unixODBC --host=${CHOST} ${myconf}
-
- try make
+src_compile() {
+ local myconf
+
+ if [ "`use qt`" ]
+ then
+ myconf="--enable-gui=yes"
+ else
+ myconf="--enable-gui=no"
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc/unixODBC \
+ ${myconf} || die
+
+ make || die
}
src_install () {
+ make DESTDIR=${D} install || die
- try make DESTDIR=${D} install
- dodoc AUTHORS COPYING ChangeLog NEWS README*
- cp -a doc ${D}/usr/share/doc/${PF}/html
- find ${D}/usr/share/doc/${PF}/html -name "Makefile*" -exec rm {} \;
- prepalldocs
+ dodoc AUTHORS COPYING ChangeLog NEWS README*
+ cp -a doc ${D}/usr/share/doc/${PF}/html
+ find ${D}/usr/share/doc/${PF}/html -name "Makefile*" -exec rm {} \;
+ prepalldocs
}
-
diff --git a/dev-db/unixODBC/unixODBC-2.0.8.ebuild b/dev-db/unixODBC/unixODBC-2.0.8.ebuild
index cc5309c95ca0..b2d93f4c7e42 100644
--- a/dev-db/unixODBC/unixODBC-2.0.8.ebuild
+++ b/dev-db/unixODBC/unixODBC-2.0.8.ebuild
@@ -1,12 +1,11 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Your Name <your email>
-# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.0.8.ebuild,v 1.1 2001/07/01 21:56:57 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.0.8.ebuild,v 1.2 2001/11/10 11:21:56 hallski Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="ODBC Interface for Linux"
-SRC_URI="http://www.unixodbc.org/${A}"
+SRC_URI="http://www.unixodbc.org/${P}.tar.gz"
HOMEPAGE="http://www.unixodbc.org"
DEPEND="virtual/glibc
@@ -15,32 +14,35 @@ DEPEND="virtual/glibc
qt? ( >=x11-libs/qt-x11-2.3.0 )"
src_unpack() {
-
- unpack ${A}
- cd ${S}
- cp Makefile.in Makefile.orig
- sed -e "s:touch :touch \${DESTDIR}/:" Makefile.orig > Makefile.in
-
+ unpack ${A}
+ cd ${S}
+ cp Makefile.in Makefile.orig
+ sed -e "s:touch :touch \${DESTDIR}/:" Makefile.orig > Makefile.in
}
+
src_compile() {
- local myconf
- if [ "`use qt`" ]
- then
- myconf="--enable-gui=yes"
- else
- myconf="--enable-gui=no"
- fi
- try ./configure --prefix=/usr --sysconfdir=/etc/unixODBC --host=${CHOST} ${myconf}
+ local myconf
+
+ if [ "`use qt`" ]
+ then
+ myconf="--enable-gui=yes"
+ else
+ myconf="--enable-gui=no"
+ fi
- try make
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc/unixODBC \
+ ${myconf} || die
+ make || die
}
src_install () {
+ make DESTDIR=${D} install || die
- try make DESTDIR=${D} install
- dodoc AUTHORS COPYING ChangeLog NEWS README*
- cp -a doc ${D}/usr/share/doc/${PF}/html
- find ${D}/usr/share/doc/${PF}/html -name "Makefile*" -exec rm {} \;
- prepalldocs
+ dodoc AUTHORS COPYING ChangeLog NEWS README*
+ cp -a doc ${D}/usr/share/doc/${PF}/html
+ find ${D}/usr/share/doc/${PF}/html -name "Makefile*" -exec rm {} \;
+ prepalldocs
}