summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-12-06 14:12:01 +0000
committerPacho Ramos <pacho@gentoo.org>2010-12-06 14:12:01 +0000
commit496827e3f2acb5838acd69575745aa35b3ed56e8 (patch)
tree8bdc7b64d7a604216ab27c92d1643b631108d367 /dev-dotnet
parentVersion bump (diff)
downloadgentoo-2-496827e3f2acb5838acd69575745aa35b3ed56e8.tar.gz
gentoo-2-496827e3f2acb5838acd69575745aa35b3ed56e8.tar.bz2
gentoo-2-496827e3f2acb5838acd69575745aa35b3ed56e8.zip
Version bump
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/ikvm-bin/ChangeLog25
-rw-r--r--dev-dotnet/ikvm-bin/ikvm-bin-0.44.0.6.ebuild46
2 files changed, 70 insertions, 1 deletions
diff --git a/dev-dotnet/ikvm-bin/ChangeLog b/dev-dotnet/ikvm-bin/ChangeLog
index 775ccdb8c2bf..87ae24e523dc 100644
--- a/dev-dotnet/ikvm-bin/ChangeLog
+++ b/dev-dotnet/ikvm-bin/ChangeLog
@@ -1,6 +1,29 @@
# ChangeLog for dev-dotnet/ikvm-bin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/ikvm-bin/ChangeLog,v 1.13 2010/09/23 22:16:40 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/ikvm-bin/ChangeLog,v 1.14 2010/12/06 14:12:01 pacho Exp $
+
+*ikvm-bin-0.44.0.6 (06 Dec 2010)
+
+ 06 Dec 2010; Pacho Ramos <pacho@gentoo.org> +ikvm-bin-0.44.0.6.ebuild:
+ Version bump:
+ - Backported various build system improvements.
+ - Backported IKVM.Reflection ILGenerator exception table sorting bug fix
+ (when running on Mono).
+ - Backported Mono 2.8 mcs build workarounds.
+ - Backported support for boolean, byte, char and short non-final static field
+ constant attributes.
+ - Backported core assembly detection fix.
+ - Backported fix to make sure that ikvmc (and ikvmstub) can find assemblies
+ that are part of a multi assembly (shared class loader) group (if the
+ assembly is in the same directory as the main assembly of the group).
+ - Backported fix for regression in stack trace printing of .NET (not
+ remapped) exceptions introduced in 0.44. The .NET stack trace should not be
+ included in the message.
+ - Backported fix for ikvmc sometimes incorrectly handling
+ InternalsVisibleToAttributes in multi assembly builds.
+ - Backported fix for regression introduced with fault handlers. Exception
+ handlers inside fault handlers could be ignored.
+ - Backported fix for #3086040. Volatile stores require a memory barrier.
23 Sep 2010; Markos Chandras <hwoarang@gentoo.org>
ikvm-bin-0.42.0.6.ebuild:
diff --git a/dev-dotnet/ikvm-bin/ikvm-bin-0.44.0.6.ebuild b/dev-dotnet/ikvm-bin/ikvm-bin-0.44.0.6.ebuild
new file mode 100644
index 000000000000..a55a72d2efff
--- /dev/null
+++ b/dev-dotnet/ikvm-bin/ikvm-bin-0.44.0.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/ikvm-bin/ikvm-bin-0.44.0.6.ebuild,v 1.1 2010/12/06 14:12:01 pacho Exp $
+
+inherit eutils mono multilib
+
+MY_P=${P/-bin/}
+MY_PN=${PN/-bin/}
+
+DESCRIPTION="Java VM for .NET"
+HOMEPAGE="http://www.ikvm.net/ http://weblog.ikvm.net/"
+SRC_URI="http://www.frijters.net/${MY_PN}bin-${PV}.zip"
+LICENSE="as-is"
+
+SLOT="0"
+S=${WORKDIR}/${MY_P}
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/mono-1.1
+ !dev-dotnet/ikvm
+ app-arch/unzip"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ insinto /usr/$(get_libdir)/${MY_PN}
+ doins bin/* || die "doins failed"
+
+ for exe in ikvm ikvmc ikvmstub;
+ do
+ make_wrapper ${exe} "mono /usr/$(get_libdir)/${MY_PN}/${exe}.exe" || die
+ done
+
+ dodir /usr/$(get_libdir)/pkgconfig
+ sed -e "s:@VERSION@:${PV}:" \
+ -e "s:@LIBDIR@:$(get_libdir):" \
+ "${FILESDIR}"/ikvm-0.36.0.5.pc.in > "${D}"/usr/$(get_libdir)/pkgconfig/${MY_PN}.pc \
+ || die "sed failed"
+
+ for dll in bin/IKVM*.dll
+ do
+ gacutil -i ${dll} -root "${D}"/usr/$(get_libdir) \
+ -gacdir /usr/$(get_libdir) -package ${dll} || die
+ done
+}