summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-03-10 17:42:44 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-03-10 17:42:44 +0000
commit366579f990a34436d0c46bcef0ca8e657f8f097b (patch)
tree8a878990fc5aac5b68cf46f2b423d05f6ae7cd17 /dev-haskell/texmath
parentVersion bump. (diff)
downloadgentoo-2-366579f990a34436d0c46bcef0ca8e657f8f097b.tar.gz
gentoo-2-366579f990a34436d0c46bcef0ca8e657f8f097b.tar.bz2
gentoo-2-366579f990a34436d0c46bcef0ca8e657f8f097b.zip
Version bump.
(Portage version: 2.2.0_alpha90_p1/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/texmath')
-rw-r--r--dev-haskell/texmath/ChangeLog9
-rw-r--r--dev-haskell/texmath/texmath-0.6.0.3.ebuild45
2 files changed, 52 insertions, 2 deletions
diff --git a/dev-haskell/texmath/ChangeLog b/dev-haskell/texmath/ChangeLog
index 54306fba4088..ad383a1c81de 100644
--- a/dev-haskell/texmath/ChangeLog
+++ b/dev-haskell/texmath/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/texmath
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/texmath/ChangeLog,v 1.1 2011/04/23 16:27:48 slyfox Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/texmath/ChangeLog,v 1.2 2012/03/10 17:42:44 slyfox Exp $
+
+*texmath-0.6.0.3 (10 Mar 2012)
+
+ 10 Mar 2012; Sergei Trofimovich <slyfox@gentoo.org> +texmath-0.6.0.3.ebuild:
+ Version bump.
*texmath-0.5.0.1 (23 Apr 2011)
diff --git a/dev-haskell/texmath/texmath-0.6.0.3.ebuild b/dev-haskell/texmath/texmath-0.6.0.3.ebuild
new file mode 100644
index 000000000000..aeeb3de5aa4c
--- /dev/null
+++ b/dev-haskell/texmath/texmath-0.6.0.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/texmath/texmath-0.6.0.3.ebuild,v 1.1 2012/03/10 17:42:44 slyfox Exp $
+
+# ebuild generated by hackport 0.2.13
+
+EAPI="4"
+
+CABAL_FEATURES="bin lib profile haddock hscolour hoogle"
+inherit haskell-cabal
+
+DESCRIPTION="Conversion of LaTeX math formulas to MathML or OMML."
+HOMEPAGE="http://github.com/jgm/texmath"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cgi test"
+
+RDEPEND=">=dev-haskell/parsec-2[profile?]
+ dev-haskell/syb[profile?]
+ >=dev-haskell/xml-1.3.12[profile?]
+ >=dev-lang/ghc-6.8.2
+ cgi? ( dev-haskell/json[profile?]
+ dev-haskell/cgi[profile?]
+ dev-haskell/utf8-string[profile?]
+ )
+ "
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+src_configure() {
+ cabal_src_configure \
+ $(cabal_flag cgi) \
+ $(cabal_flag test)
+}
+
+src_install() {
+ cabal_src_install
+
+ # remove test and it's data
+ rm -f "${ED}/usr/bin/texmath" 2> /dev/null
+ rm -rf "${ED}/usr/share/${P}"/ghc-*/tests 2> /dev/null
+}