summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTodd Berman <tberman@gentoo.org>2003-05-14 03:41:58 +0000
committerTodd Berman <tberman@gentoo.org>2003-05-14 03:41:58 +0000
commit58ebd5bb0de7363fd33a0e6683a6991be9a28a79 (patch)
tree545df1cbc4590bfa60148d1754afba1638d83e34 /dev-java/jython/jython-2.1-r1.ebuild
parentClosing bug #20562. (diff)
downloadgentoo-2-58ebd5bb0de7363fd33a0e6683a6991be9a28a79.tar.gz
gentoo-2-58ebd5bb0de7363fd33a0e6683a6991be9a28a79.tar.bz2
gentoo-2-58ebd5bb0de7363fd33a0e6683a6991be9a28a79.zip
Closing bug #20562.
Diffstat (limited to 'dev-java/jython/jython-2.1-r1.ebuild')
-rw-r--r--dev-java/jython/jython-2.1-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-java/jython/jython-2.1-r1.ebuild b/dev-java/jython/jython-2.1-r1.ebuild
new file mode 100644
index 000000000000..a04e249f81d3
--- /dev/null
+++ b/dev-java/jython/jython-2.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jython/jython-2.1-r1.ebuild,v 1.1 2003/05/14 03:41:53 tberman Exp $
+
+DESCRIPTION="Java Python implementation"
+
+# Homepage, not used by Portage directly but handy for developer reference
+HOMEPAGE="http://www.jython.org"
+MY_PV="21"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-${MY_PV}.class"
+LICENSE="JPython"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.2"
+
+src_unpack() {
+ addwrite .hotspot
+ cd ${DISTDIR}
+ java ${PN}-${MY_PV} -o ${S}/ demo lib source
+
+}
+
+src_install() {
+ dojar jython.jar
+ dodoc README.txt NEWS ACKNOWLEDGMENTS LICENSE.txt
+ dohtml -A .css .jpg .gif -r Doc
+ dobin ${FILESDIR}/jython
+ dobin ${FILESDIR}/jythonc
+ mkdir -p ${D}/var/jython/
+ chmod a+w ${D}/var/jython/
+ cp -R ${S}/Tools ${D}/var/jython/
+ cp -R ${S}/Lib ${D}/var/jython/
+}