summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-07-17 17:21:15 +0000
committerMike Frysinger <vapier@gentoo.org>2003-07-17 17:21:15 +0000
commitaa92b129a9fd3ac11a51668a52d2254b43172e34 (patch)
tree973fe3a77a7fd3c28b14e8f47e4ffab238c40c27 /dev-lang/cm3/cm3-5.2.6.ebuild
parentversion bump (diff)
downloadgentoo-2-aa92b129a9fd3ac11a51668a52d2254b43172e34.tar.gz
gentoo-2-aa92b129a9fd3ac11a51668a52d2254b43172e34.tar.bz2
gentoo-2-aa92b129a9fd3ac11a51668a52d2254b43172e34.zip
remove extra stuff
Diffstat (limited to 'dev-lang/cm3/cm3-5.2.6.ebuild')
-rw-r--r--dev-lang/cm3/cm3-5.2.6.ebuild67
1 files changed, 1 insertions, 66 deletions
diff --git a/dev-lang/cm3/cm3-5.2.6.ebuild b/dev-lang/cm3/cm3-5.2.6.ebuild
index 7c96b107d668..a45611f78064 100644
--- a/dev-lang/cm3/cm3-5.2.6.ebuild
+++ b/dev-lang/cm3/cm3-5.2.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/cm3/cm3-5.2.6.ebuild,v 1.1 2003/07/17 17:19:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/cm3/cm3-5.2.6.ebuild,v 1.2 2003/07/17 17:21:15 vapier Exp $
DESCRIPTION="Critical Mass Modula-3 compiler"
HOMEPAGE="http://www.elegosoft.com/cm3/"
@@ -56,69 +56,4 @@ src_install() {
insinto /etc/env.d
doins ${FILESDIR}/05cm3
- return 0
-
- # old code left in so i can save it in cvs if i need it in the future ...
- local pkgs=""
- grep P= do-cm3-base.sh > my-base-pkgs ; echo 'echo $P' >> my-base-pkgs
- grep P= do-cm3-core.sh > my-core-pkgs ; echo 'echo $P' >> my-core-pkgs
- pkgs="$(export TARGET=${TARGET}; source my-base-pkgs ; source my-core-pkgs )"
- dodir /usr/lib/cm3/pkg
- for p in ${pkgs} ; do
- pdir=`find ${S} -type d -name ${p} -maxdepth 2 -mindepth 2`
- pkg=`basename ${p}`
- [ -e ${D}/usr/lib/cm3/pkg/${pkg} ] && continue
-
- # install by hand ...
- #cp -rf ${pdir} ${D}/usr/lib/cm3/pkg/${pkg}
- #cd ${D}/usr/lib/cm3/pkg/${pkg}/${TARGET}
- #rm *.{i,m}o .M3SHIP
- #cd ${D}/usr/lib/cm3/pkg/${pkg}/src
- #find -type f \
- # ! -name '*.i3' -a \
- # ! -name '*.m3' -a \
- # ! -name '*.ig' -a \
- # ! -name '*.mg' -a \
- # ! -name '*.c' -a \
- # ! -name '*.h' -a \
- # ! -name '*.tmpl' \
- # -exec rm '{}' \;
-
- # translate m3ship file into portage
- cd ${pdir}/${TARGET}
- echo "=== package ${pdir} ===" # mimic cm3 output
- my_m3ship
- echo " ==> ${pdir} done"
- echo
- done
-}
-
-my_m3ship() {
- [ ! -e .M3SHIP ] && echo "package was built with overrides, not shipping." && return 0
- local act
- local src
- local dst
- local perms
- local l
- while read LINE ; do
- # each line has the format:
- # action("source file", "dest file", "permissions")
- # unless of course the action doesnt need the extra params (i.e. make_dir)
- # we translate it into 'action sourcefile destfile permissions'
- l=$(echo ${LINE} | sed -e 's:[" )]::g' -e 's:[(,]: :g')
- set -- ${l}
- act=${1}
- src=${2}
- dst=${3}
- perms=${4}
- case ${act} in
- install_file) insinto ${dst}
- doins ${src}
- fperms ${perms} ${dst}/$(basename ${src});;
- make_dir) dodir ${src};;
- link_file) dosym ${src} ${dst};;
- *) die "unknown M3SHIP action ${act}";;
- esac
- debug-print ACT: ${act} SRC: ${src} DST: ${dst} PERMS: ${perms}
- done < .M3SHIP
}