summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-01-05 11:22:16 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-01-05 11:22:16 +0000
commit642f6aae2bfd0049bbfe203e9dabbe0a6d1c72b9 (patch)
treee4415219f7956816a93afd7761bc3e974c3cac3b /dev-libs/libmcrypt
parentAdded initial release (diff)
downloadgentoo-2-642f6aae2bfd0049bbfe203e9dabbe0a6d1c72b9.tar.gz
gentoo-2-642f6aae2bfd0049bbfe203e9dabbe0a6d1c72b9.tar.bz2
gentoo-2-642f6aae2bfd0049bbfe203e9dabbe0a6d1c72b9.zip
Securitybump
Diffstat (limited to 'dev-libs/libmcrypt')
-rw-r--r--dev-libs/libmcrypt/ChangeLog9
-rw-r--r--dev-libs/libmcrypt/files/digest-libmcrypt-2.5.51
-rw-r--r--dev-libs/libmcrypt/libmcrypt-2.5.5.ebuild65
3 files changed, 73 insertions, 2 deletions
diff --git a/dev-libs/libmcrypt/ChangeLog b/dev-libs/libmcrypt/ChangeLog
index 98b53bbad582..4e89d7f3ea6b 100644
--- a/dev-libs/libmcrypt/ChangeLog
+++ b/dev-libs/libmcrypt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libmcrypt
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmcrypt/ChangeLog,v 1.11 2002/12/13 10:56:29 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmcrypt/ChangeLog,v 1.12 2003/01/05 11:22:16 aliz Exp $
+
+*libmcrypt-2.5.5 (05 Jan 2003)
+
+ 05 Jan 2003; Daniel Ahlberg <aliz@gentoo.org> :
+ Security update.
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
@@ -47,7 +52,7 @@
5 May 2002: Martin Schlemmer <azarah@gentoo.org> libmcrypt-2.4.19-r1.ebuild :
- Resolve bug #2276. Add $Header: /var/cvsroot/gentoo-x86/dev-libs/libmcrypt/ChangeLog,v 1.11 2002/12/13 10:56:29 blizzy Exp $.
+ Resolve bug #2276. Add $Header: /var/cvsroot/gentoo-x86/dev-libs/libmcrypt/ChangeLog,v 1.12 2003/01/05 11:22:16 aliz Exp $.
*libmcrypt-2.4.19 (1 Feb 2002)
diff --git a/dev-libs/libmcrypt/files/digest-libmcrypt-2.5.5 b/dev-libs/libmcrypt/files/digest-libmcrypt-2.5.5
new file mode 100644
index 000000000000..e70f4eddabfc
--- /dev/null
+++ b/dev-libs/libmcrypt/files/digest-libmcrypt-2.5.5
@@ -0,0 +1 @@
+MD5 c5b0d48ddd62a9b8ae7cd9944f3deaba libmcrypt-2.5.5.tar.gz 638380
diff --git a/dev-libs/libmcrypt/libmcrypt-2.5.5.ebuild b/dev-libs/libmcrypt/libmcrypt-2.5.5.ebuild
new file mode 100644
index 000000000000..2ed9db87e6ea
--- /dev/null
+++ b/dev-libs/libmcrypt/libmcrypt-2.5.5.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmcrypt/libmcrypt-2.5.5.ebuild,v 1.1 2003/01/05 11:22:16 aliz Exp $
+
+inherit libtool
+
+S=${WORKDIR}/${P}
+DESCRIPTION="libmcrypt is a library that provides uniform interface to access several encryption algorithms."
+SRC_URI="ftp://mcrypt.hellug.gr/pub/mcrypt/libmcrypt/${P}.tar.gz"
+HOMEPAGE="http://mcrypt.hellug.gr/"
+
+DEPEND=">=sys-devel/automake-1.6.1
+ >=sys-devel/libtool-1.4.1-r8"
+IUSE=""
+SLOT="0"
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="x86 sparc ~ppc"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ # This is also fixes for bug #3940. The included libltdl gives some
+ # errors during ./configure
+ rm -rf ${S}/libltdl
+ rm -f ${S}/config.{guess,status,sub}
+ libtoolize --ltdl --copy --force
+
+ # Try to fix some wierd build problems. See bug #3940.
+ echo ">>> Reconfiguring package..."
+ export WANT_AUTOMAKE_1_6=1
+ export WANT_AUTOCONF_2_5=1
+ autoreconf --force --install --symlink &>${T}/autoreconf.log || ( \
+ echo "DEBUG: working directory is: `pwd`" >>${T}/autoreconf.log
+ eerror "Reonfigure failed, please attatch the contents of:"
+ eerror
+ eerror " ${T}/autoreconf.log"
+ eerror
+ eerror "in your bugreport."
+ # we need an error here, else the ebuild do not die
+ exit 1
+ ) || die "running autoreconf failed"
+}
+
+src_compile() {
+ # Doesn't work with --host bug #3517
+ econf --disable-posix-threads || die
+
+ # PHP manual states to disable posix threads, no further explanation
+ # given, but i'll stick with it :)
+ # (Source: http://www.php.net/manual/en/ref.mcrypt.php)
+
+ emake || die
+}
+
+src_install () {
+
+ dodir /usr/{bin,include,lib}
+
+ einstall || die
+
+ dodoc AUTHORS COPYING COPYING.LIB INSTALL NEWS README THANKS TODO
+ dodoc doc/README.* doc/example.c
+}