summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPanagiotis Christopoulos <pchrist@gentoo.org>2012-12-04 00:00:48 +0000
committerPanagiotis Christopoulos <pchrist@gentoo.org>2012-12-04 00:00:48 +0000
commit4c32947cef5f0e233d7ff568ab4678ceea56cf75 (patch)
tree679befa3a2f13341cbab21667fe9fe1ae341dcb5 /dev-lisp/clisp
parentVersion bump. (diff)
downloadgentoo-2-4c32947cef5f0e233d7ff568ab4678ceea56cf75.tar.gz
gentoo-2-4c32947cef5f0e233d7ff568ab4678ceea56cf75.tar.bz2
gentoo-2-4c32947cef5f0e233d7ff568ab4678ceea56cf75.zip
minor patch to 2.48-r2, fixes bug #425748 , thanks to Alexey Kretov (domini at onego.ru)
(Portage version: 2.1.11.33/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-lisp/clisp')
-rw-r--r--dev-lisp/clisp/ChangeLog9
-rw-r--r--dev-lisp/clisp/clisp-2.48-r2.ebuild5
-rw-r--r--dev-lisp/clisp/files/clisp-2.48-bits_ipctypes_to_sys_ipc.patch12
3 files changed, 22 insertions, 4 deletions
diff --git a/dev-lisp/clisp/ChangeLog b/dev-lisp/clisp/ChangeLog
index a02c755eb295..02fb8490f286 100644
--- a/dev-lisp/clisp/ChangeLog
+++ b/dev-lisp/clisp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lisp/clisp
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/ChangeLog,v 1.104 2011/03/29 12:17:01 angelos Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/ChangeLog,v 1.105 2012/12/04 00:00:48 pchrist Exp $
+
+ 03 Dec 2012; Panagiotis Christopoulos <pchrist@gentoo.org>
+ clisp-2.48-r2.ebuild, +files/clisp-2.48-bits_ipctypes_to_sys_ipc.patch:
+ minor patch to 2.48-r2, fixes bug #425748 , thanks to Alexey Kretov (domini
+ at onego.ru)
29 Mar 2011; Christoph Mende <angelos@gentoo.org> clisp-2.47-r1.ebuild,
clisp-2.48-r1.ebuild, clisp-2.48-r2.ebuild:
diff --git a/dev-lisp/clisp/clisp-2.48-r2.ebuild b/dev-lisp/clisp/clisp-2.48-r2.ebuild
index b6802b275519..d74fc8dd18e5 100644
--- a/dev-lisp/clisp/clisp-2.48-r2.ebuild
+++ b/dev-lisp/clisp/clisp-2.48-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.48-r2.ebuild,v 1.4 2011/03/29 12:17:01 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.48-r2.ebuild,v 1.5 2012/12/04 00:00:48 pchrist Exp $
EAPI="2"
@@ -57,6 +57,7 @@ src_prepare() {
if use alpha || use ia64; then
sed -i -e 's/-O2//g' src/makemake.in || die
fi
+ epatch "${FILESDIR}/${P}-bits_ipctypes_to_sys_ipc.patch"
}
src_configure() {
diff --git a/dev-lisp/clisp/files/clisp-2.48-bits_ipctypes_to_sys_ipc.patch b/dev-lisp/clisp/files/clisp-2.48-bits_ipctypes_to_sys_ipc.patch
new file mode 100644
index 000000000000..d6163022830d
--- /dev/null
+++ b/dev-lisp/clisp/files/clisp-2.48-bits_ipctypes_to_sys_ipc.patch
@@ -0,0 +1,12 @@
+diff -ru a/modules/bindings/glibc/linux.lisp b/modules/bindings/glibc/linux.lisp
+--- a/modules/bindings/glibc/linux.lisp 2008-10-10 16:15:49.000000000 +0300
++++ b/modules/bindings/glibc/linux.lisp 2012-12-04 01:01:35.000000000 +0200
+@@ -86,7 +86,7 @@
+
+ (def-c-type __key_t) ; int
+
+-(c-lines "#include <bits/ipctypes.h>~%")
++(c-lines "#include <sys/ipc.h>~%")
+ (def-c-type __ipc_pid_t) ; ushort
+
+ ; --------------------------- <sys/types.h> -----------------------------------