summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-01-03 19:33:58 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-01-03 19:33:58 +0000
commit4cb7dac53b94a1f15bd924a1e1b7ea704768433f (patch)
tree3bb953bd494be06ff5b319ce09f235624448809c /dev-ml/camlidl
parentVersion bump (diff)
downloadgentoo-2-4cb7dac53b94a1f15bd924a1e1b7ea704768433f.tar.gz
gentoo-2-4cb7dac53b94a1f15bd924a1e1b7ea704768433f.tar.bz2
gentoo-2-4cb7dac53b94a1f15bd924a1e1b7ea704768433f.zip
ocamlopt is required here, there is no option to disable it
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'dev-ml/camlidl')
-rw-r--r--dev-ml/camlidl/ChangeLog7
-rw-r--r--dev-ml/camlidl/camlidl-1.05.ebuild17
2 files changed, 19 insertions, 5 deletions
diff --git a/dev-ml/camlidl/ChangeLog b/dev-ml/camlidl/ChangeLog
index 450269ec7354..547c1a3bfe11 100644
--- a/dev-ml/camlidl/ChangeLog
+++ b/dev-ml/camlidl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ml/camlidl
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlidl/ChangeLog,v 1.2 2007/02/09 02:44:43 flameeyes Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlidl/ChangeLog,v 1.3 2008/01/03 19:33:58 aballier Exp $
+
+ 03 Jan 2008; Alexis Ballier <aballier@gentoo.org> camlidl-1.05.ebuild:
+ ocamlopt is required here, there is no option to disable it
09 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/dev-ml/camlidl/camlidl-1.05.ebuild b/dev-ml/camlidl/camlidl-1.05.ebuild
index e51f30a73c2c..da88e110ddb7 100644
--- a/dev-ml/camlidl/camlidl-1.05.ebuild
+++ b/dev-ml/camlidl/camlidl-1.05.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlidl/camlidl-1.05.ebuild,v 1.1 2004/09/25 20:15:43 mattam Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlidl/camlidl-1.05.ebuild,v 1.2 2008/01/03 19:33:58 aballier Exp $
+
+inherit eutils
DESCRIPTION="CamlIDL is a stub code generator for using C/C++ libraries from O'Caml"
HOMEPAGE="http://caml.inria.fr/camlidl/"
@@ -11,6 +13,15 @@ KEYWORDS="~x86 ~ppc ~amd64"
IUSE=""
DEPEND=">=dev-lang/ocaml-3.07"
+pkg_setup() {
+ if ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
+ eerror "${PN} needs to be built with native code support from ocaml"
+ eerror "You first need to have a native code ocaml compiler."
+ eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
+ die "Please install ocaml with ocamlopt useflag"
+ fi
+}
+
src_compile() {
# Use the UNIX makefile
libdir=`ocamlc -where`
@@ -33,7 +44,7 @@ src_install() {
dodir ${libdir}/caml
dodir /usr/bin
# Install
- emake BINDIR=${D}/usr/bin OCAMLLIB=${D}${libdir} install || die
+ emake BINDIR="${D}/usr/bin" OCAMLLIB="${D}${libdir}" install || die
# Documentation
dodoc README Changes