summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-11-15 12:11:09 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-11-15 12:11:09 +0000
commit733e7826a4a45e5524dfe8ec9cad0ea4429971b4 (patch)
tree5bb3c389301dee789c759f1f2630738136273cb1 /dev-ml/findlib
parentamd64/x86 stable, bug #230259 (diff)
downloadgentoo-2-733e7826a4a45e5524dfe8ec9cad0ea4429971b4.tar.gz
gentoo-2-733e7826a4a45e5524dfe8ec9cad0ea4429971b4.tar.bz2
gentoo-2-733e7826a4a45e5524dfe8ec9cad0ea4429971b4.zip
version bump and convert to eapi-2
(Portage version: 2.2_rc14/cvs/Linux 2.6.27.5 x86_64)
Diffstat (limited to 'dev-ml/findlib')
-rw-r--r--dev-ml/findlib/ChangeLog7
-rw-r--r--dev-ml/findlib/findlib-1.2.3.ebuild77
2 files changed, 83 insertions, 1 deletions
diff --git a/dev-ml/findlib/ChangeLog b/dev-ml/findlib/ChangeLog
index 0cc5139504b4..be60c8c9447e 100644
--- a/dev-ml/findlib/ChangeLog
+++ b/dev-ml/findlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/findlib
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/findlib/ChangeLog,v 1.47 2008/10/02 18:21:40 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/findlib/ChangeLog,v 1.48 2008/11/15 12:11:09 aballier Exp $
+
+*findlib-1.2.3 (15 Nov 2008)
+
+ 15 Nov 2008; Alexis Ballier <aballier@gentoo.org> +findlib-1.2.3.ebuild:
+ version bump and convert to eapi-2
02 Oct 2008; Alexis Ballier <aballier@gentoo.org> -findlib-1.2.1.ebuild:
remove old
diff --git a/dev-ml/findlib/findlib-1.2.3.ebuild b/dev-ml/findlib/findlib-1.2.3.ebuild
new file mode 100644
index 000000000000..d69f0d899401
--- /dev/null
+++ b/dev-ml/findlib/findlib-1.2.3.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/findlib/findlib-1.2.3.ebuild,v 1.1 2008/11/15 12:11:09 aballier Exp $
+
+EAPI=2
+
+inherit multilib
+
+
+RESTRICT="installsources"
+
+DESCRIPTION="OCaml tool to find/use non-standard packages."
+HOMEPAGE="http://projects.camlcity.org/projects/findlib.html"
+SRC_URI="http://download.camlcity.org/download/${P}.tar.gz"
+IUSE="doc +ocamlopt tk"
+
+LICENSE="MIT X11"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+DEPEND=">=dev-lang/ocaml-3.10[ocamlopt?,tk?]"
+
+ocamlfind_destdir="/usr/$(get_libdir)/ocaml/site-packages"
+stublibs="${ocamlfind_destdir}/stublibs"
+
+src_configure() {
+ local myconf
+ use tk && myconf="-with-toolbox"
+ ./configure -bindir /usr/bin -mandir /usr/share/man \
+ -sitelib ${ocamlfind_destdir} \
+ -config ${ocamlfind_destdir}/findlib/findlib.conf \
+ ${myconf} || die "configure failed"
+}
+
+src_compile() {
+ emake all || die
+ if use ocamlopt; then
+ emake opt || die # optimized code
+ else
+ # If using bytecode we dont want to strip the binary as it would remove the
+ # bytecode and only leave ocamlrun...
+ export STRIP_MASK="*/bin/*"
+ fi
+}
+
+src_install() {
+ dodir `ocamlc -where`
+
+ emake prefix="${D}" install || die
+
+ dodir "${stublibs}"
+
+ cd "${S}/doc"
+ dodoc QUICKSTART README DOCINFO
+ use doc && dohtml -r ref-html guide-html
+}
+
+check_stublibs() {
+ local ocaml_stdlib=`ocamlc -where`
+ local ldconf="${ocaml_stdlib}/ld.conf"
+
+ if [ ! -e ${ldconf} ]
+ then
+ echo "${ocaml_stdlib}" > ${ldconf}
+ echo "${ocaml_stdlib}/stublibs" >> ${ldconf}
+ fi
+
+ if [ -z `grep -e ${stublibs} ${ldconf}` ]
+ then
+ echo ${stublibs} >> ${ldconf}
+ fi
+}
+
+pkg_postinst() {
+ check_stublibs
+}