summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2013-03-01 12:21:36 +0000
committerOle Markus With <olemarkus@gentoo.org>2013-03-01 12:21:36 +0000
commit110015061da681215126a4440c3a0c01b24c5f60 (patch)
tree9a3dd821e0308a04d911becb298dc2d89ea0030e /dev-php/xcache
parentsci-mathematics/gsl-shell: Use pkg-config to detect gsl, libagg, freetype (#4... (diff)
downloadgentoo-2-110015061da681215126a4440c3a0c01b24c5f60.tar.gz
gentoo-2-110015061da681215126a4440c3a0c01b24c5f60.tar.bz2
gentoo-2-110015061da681215126a4440c3a0c01b24c5f60.zip
Version bump
(Portage version: 2.1.11.50/cvs/Linux x86_64, signed Manifest commit with key C4A92BF5)
Diffstat (limited to 'dev-php/xcache')
-rw-r--r--dev-php/xcache/ChangeLog10
-rw-r--r--dev-php/xcache/xcache-3.0.0.ebuild6
-rw-r--r--dev-php/xcache/xcache-3.0.1.ebuild55
3 files changed, 66 insertions, 5 deletions
diff --git a/dev-php/xcache/ChangeLog b/dev-php/xcache/ChangeLog
index a664b3361fd5..ffdbfbe21153 100644
--- a/dev-php/xcache/ChangeLog
+++ b/dev-php/xcache/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/xcache
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/xcache/ChangeLog,v 1.11 2012/11/16 10:05:13 olemarkus Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xcache/ChangeLog,v 1.12 2013/03/01 12:21:36 olemarkus Exp $
+
+*xcache-3.0.1 (01 Mar 2013)
+
+ 01 Mar 2013; Ole Markus With <olemarkus@gentoo.org> +xcache-3.0.1.ebuild,
+ xcache-3.0.0.ebuild:
+ Version bump
*xcache-3.0.0 (16 Nov 2012)
diff --git a/dev-php/xcache/xcache-3.0.0.ebuild b/dev-php/xcache/xcache-3.0.0.ebuild
index 4e6f6e006671..2b11e5311560 100644
--- a/dev-php/xcache/xcache-3.0.0.ebuild
+++ b/dev-php/xcache/xcache-3.0.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/xcache/xcache-3.0.0.ebuild,v 1.1 2012/11/16 10:05:13 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xcache/xcache-3.0.0.ebuild,v 1.2 2013/03/01 12:21:36 olemarkus Exp $
-EAPI="4"
+EAPI="5"
PHP_EXT_NAME="xcache"
PHP_EXT_INI="yes"
PHPSAPILIST="apache2 cgi fpm"
diff --git a/dev-php/xcache/xcache-3.0.1.ebuild b/dev-php/xcache/xcache-3.0.1.ebuild
new file mode 100644
index 000000000000..65eeda3ae1ac
--- /dev/null
+++ b/dev-php/xcache/xcache-3.0.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xcache/xcache-3.0.1.ebuild,v 1.1 2013/03/01 12:21:36 olemarkus Exp $
+
+EAPI="4"
+PHP_EXT_NAME="xcache"
+PHP_EXT_INI="yes"
+PHPSAPILIST="apache2 cgi fpm"
+
+USE_PHP="php5-3 php5-4"
+inherit php-ext-source-r2 confutils
+
+DESCRIPTION="A fast and stable PHP opcode cacher"
+HOMEPAGE="http://xcache.lighttpd.net/"
+SRC_URI="http://xcache.lighttpd.net/pub/Releases/${PV}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# make test would just run php's test and as such need the full php source
+RESTRICT="test"
+
+DEPEND="virtual/httpd-php
+!dev-php/eaccelerator !dev-php/pecl-apc"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+
+ my_conf="--enable-xcache=shared \
+ --enable-xcache-constant \
+ --enable-xcache-optimizer \
+ --enable-xcache-coverager \
+ --enable-xcache-assembler \
+ --enable-xcache-encoder \
+ --enable-xcache-decoder"
+
+ php-ext-source-r2_src_configure
+}
+
+src_install() {
+ php-ext-source-r2_src_install
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+
+ insinto "${PHP_EXT_SHARED_DIR}"
+ doins lib/Decompiler.class.php
+ insinto "${PHP_EXT_SHARED_DIR}"
+ doins -r htdocs
+}
+
+pkg_postinst() {
+ elog "lib/Decompiler.class.php, and the htdocs/ directory shipped with this"
+ elog "release were installed into ${PHP_EXT_SHARED_DIR}."
+}