summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2009-02-12 09:14:34 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2009-02-12 09:14:34 +0000
commit39c78b0d75432f37e3faf27fb8a26216b0b59376 (patch)
tree0104b1a7962c9f822fba35de7e904d618c30f05c /dev-python/mantissa
parentFix --as-needed bug #247496 (diff)
downloadgentoo-2-39c78b0d75432f37e3faf27fb8a26216b0b59376.tar.gz
gentoo-2-39c78b0d75432f37e3faf27fb8a26216b0b59376.tar.bz2
gentoo-2-39c78b0d75432f37e3faf27fb8a26216b0b59376.zip
now properly regenerating all plugin caches
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/mantissa')
-rw-r--r--dev-python/mantissa/ChangeLog6
-rw-r--r--dev-python/mantissa/mantissa-0.6.21.ebuild23
2 files changed, 27 insertions, 2 deletions
diff --git a/dev-python/mantissa/ChangeLog b/dev-python/mantissa/ChangeLog
index 17967f283ebb..5da9bd205b34 100644
--- a/dev-python/mantissa/ChangeLog
+++ b/dev-python/mantissa/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/mantissa
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mantissa/ChangeLog,v 1.11 2009/02/11 08:56:10 lordvan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mantissa/ChangeLog,v 1.12 2009/02/12 09:14:34 lordvan Exp $
+
+ 12 Feb 2009; Thomas Raschbacher <lordvan@gentoo.org>
+ mantissa-0.6.21.ebuild:
+ now properly regenerating all plugin caches
11 Feb 2009; Thomas Raschbacher <lordvan@gentoo.org>
mantissa-0.6.21.ebuild:
diff --git a/dev-python/mantissa/mantissa-0.6.21.ebuild b/dev-python/mantissa/mantissa-0.6.21.ebuild
index 93ef855dec21..2cb09b20826b 100644
--- a/dev-python/mantissa/mantissa-0.6.21.ebuild
+++ b/dev-python/mantissa/mantissa-0.6.21.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mantissa/mantissa-0.6.21.ebuild,v 1.3 2009/02/12 08:58:12 lordvan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mantissa/mantissa-0.6.21.ebuild,v 1.4 2009/02/12 09:14:34 lordvan Exp $
inherit twisted distutils eutils
@@ -45,10 +45,31 @@ src_install() {
unset PORTAGE_PLUGINCACHE_NOOP
}
+update_axiom_plugin_cache() {
+ einfo "Updating axiom plugin cache..."
+ python -c 'from twisted.plugin import IPlugin, getPlugIns;from axiom import plugins; list(getPlugIns(IPlugin, plugins))'
+}
+
+update_nevow_plugin_cache() {
+ einfo "Updating nevow plugin cache..."
+ python -c 'from twisted.plugin import IPlugin, getPlugIns;from nevow import plugins; list(getPlugIns(IPlugin, plugins))'
+}
+
+update_mantissa_plugin_cache() {
+ einfo "Updating mantissa plugin cache..."
+ python -c 'from twisted.plugin import IPlugin, getPlugIns;from xmantissa import plugins; list(getPlugIns(IPlugin, plugins))'
+}
+
pkg_postrm() {
twisted_pkg_postrm
+ update_axiom_plugin_cache
+ update_nevow_plugin_cache
+ update_mantissa_plugin_cache
}
pkg_postinst() {
twisted_pkg_postinst
+ update_axiom_plugin_cache
+ update_nevow_plugin_cache
+ update_mantissa_plugin_cache
}