summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2010-02-26 22:42:28 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2010-02-26 22:42:28 +0000
commit7e999576562d899d9c30661098f495c42e5c8cdc (patch)
treea6344ae59c46fe9b5575ea1bd28a83c907713b44 /dev-python/pyclutter
parentAppend -frounding-math wrt #307007, thanks to Kamil Kisiel for reporting. (diff)
downloadgentoo-2-7e999576562d899d9c30661098f495c42e5c8cdc.tar.gz
gentoo-2-7e999576562d899d9c30661098f495c42e5c8cdc.tar.bz2
gentoo-2-7e999576562d899d9c30661098f495c42e5c8cdc.zip
Add initial ebuild for pyclutter, python bindings for clutter
(Portage version: 2.1.7.17/cvs/Linux i686)
Diffstat (limited to 'dev-python/pyclutter')
-rw-r--r--dev-python/pyclutter/ChangeLog11
-rw-r--r--dev-python/pyclutter/files/pyclutter-fix-docs-install-data-hook.patch25
-rw-r--r--dev-python/pyclutter/metadata.xml5
-rw-r--r--dev-python/pyclutter/pyclutter-1.0.0.ebuild49
4 files changed, 90 insertions, 0 deletions
diff --git a/dev-python/pyclutter/ChangeLog b/dev-python/pyclutter/ChangeLog
new file mode 100644
index 000000000000..f6a3d9471d38
--- /dev/null
+++ b/dev-python/pyclutter/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-python/pyclutter
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyclutter/ChangeLog,v 1.1 2010/02/26 22:42:28 nirbheek Exp $
+
+*pyclutter-1.0.0 (26 Feb 2010)
+
+ 26 Feb 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
+ +pyclutter-1.0.0.ebuild,
+ +files/pyclutter-fix-docs-install-data-hook.patch, +metadata.xml:
+ Add initial ebuild for pyclutter, python bindings for clutter
+
diff --git a/dev-python/pyclutter/files/pyclutter-fix-docs-install-data-hook.patch b/dev-python/pyclutter/files/pyclutter-fix-docs-install-data-hook.patch
new file mode 100644
index 000000000000..3f3c5294b553
--- /dev/null
+++ b/dev-python/pyclutter/files/pyclutter-fix-docs-install-data-hook.patch
@@ -0,0 +1,25 @@
+Assumes $(PYGOBJECT_FIXXREF) is executable
+
+---
+--- docs/Makefile.am
++++ docs/Makefile.am
+@@ -82,7 +82,7 @@
+ fi
+
+ install-data-hook:
+- @$(PYGOBJECT_FIXXREF) -i $(PYGOBJECT_PYGDOCS) $(DESTDIR)$(TARGET_DIR)
++ python $(PYGOBJECT_FIXXREF) -i $(PYGOBJECT_PYGDOCS) $(DESTDIR)$(TARGET_DIR)
+
+ uninstall-local:
+ rm -rf $(DESTDIR)$(TARGET_DIR)/*
+--- docs/Makefile.in
++++ docs/Makefile.in
+@@ -82,7 +82,7 @@
+ fi
+
+ install-data-hook:
+- @$(PYGOBJECT_FIXXREF) -i $(PYGOBJECT_PYGDOCS) $(DESTDIR)$(TARGET_DIR)
++ python $(PYGOBJECT_FIXXREF) -i $(PYGOBJECT_PYGDOCS) $(DESTDIR)$(TARGET_DIR)
+
+ uninstall-local:
+ rm -rf $(DESTDIR)$(TARGET_DIR)/*
diff --git a/dev-python/pyclutter/metadata.xml b/dev-python/pyclutter/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/dev-python/pyclutter/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>
diff --git a/dev-python/pyclutter/pyclutter-1.0.0.ebuild b/dev-python/pyclutter/pyclutter-1.0.0.ebuild
new file mode 100644
index 000000000000..a45fc47eff8d
--- /dev/null
+++ b/dev-python/pyclutter/pyclutter-1.0.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyclutter/pyclutter-1.0.0.ebuild,v 1.1 2010/02/26 22:42:28 nirbheek Exp $
+
+EAPI="2"
+
+inherit eutils python clutter
+
+DESCRIPTION="Python bindings for Clutter"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+SLOT="1.0"
+RDEPEND=">=dev-lang/python-2.5
+ >=dev-python/pygtk-2.8.0
+ >=dev-python/pycairo-1.0.2
+ >=media-libs/clutter-1.0.0:${SLOT}"
+DEPEND="${RDEPEND}
+ doc? ( dev-libs/libxslt )"
+EXAMPLES="examples/{*.py,*.png}"
+
+# XXX: If eautoreconf, use AT_M4DIR=build/autotools
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-fix-docs-install-data-hook.patch"
+
+ ln -sf $(type -P true) py-compile
+}
+
+src_configure() {
+ local myconf="
+ $(use_enable doc docs)"
+
+ econf ${myconf}
+}
+
+src_install() {
+ # FIXME: Parallel make failure in emake install
+ MAKEOPTS="-j1" clutter_src_install
+}
+
+pkg_postinst() {
+ python_mod_optimize $(python_get_sitedir)/clutter/*
+ python_need_rebuild
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/lib*/python*/site-packages/clutter/*
+}