summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-10-19 11:41:44 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-10-19 11:41:44 +0000
commit752b2eab39f4c2756799b8dab9d1554c291b2e9b (patch)
tree76ddf7139aa34b4a6207d2d07ac01738168a9498 /dev-python/pygobject/pygobject-2.15.4.ebuild
parentFix tests and fix elementtree dependency. bug #242340. (diff)
downloadgentoo-2-752b2eab39f4c2756799b8dab9d1554c291b2e9b.tar.gz
gentoo-2-752b2eab39f4c2756799b8dab9d1554c291b2e9b.tar.bz2
gentoo-2-752b2eab39f4c2756799b8dab9d1554c291b2e9b.zip
New version for GNOME 2.24. New APIs have been wrapped (notably GIO) and codegen is now part of pygobject.
(Portage version: 2.2_rc12/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'dev-python/pygobject/pygobject-2.15.4.ebuild')
-rw-r--r--dev-python/pygobject/pygobject-2.15.4.ebuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/pygobject/pygobject-2.15.4.ebuild b/dev-python/pygobject/pygobject-2.15.4.ebuild
new file mode 100644
index 000000000000..461bff150ff1
--- /dev/null
+++ b/dev-python/pygobject/pygobject-2.15.4.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/pygobject-2.15.4.ebuild,v 1.1 2008/10/19 11:41:44 eva Exp $
+
+inherit autotools gnome2 python virtualx
+
+DESCRIPTION="GLib's GObject library bindings for Python"
+HOMEPAGE="http://www.pygtk.org/"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc examples libffi"
+
+RDEPEND=">=dev-lang/python-2.4.4-r5
+ >=dev-libs/glib-2.16
+ !<dev-python/pygtk-2.13"
+DEPEND="${RDEPEND}
+ doc? ( dev-libs/libxslt >=app-text/docbook-xsl-stylesheets-1.70.1 )
+ >=dev-util/pkgconfig-0.12.0"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ if use libffi && ! built_with_use sys-devel/gcc libffi; then
+ eerror "libffi support not found in sys-devel/gcc." && die
+ fi
+
+ G2CONF="${G2CONF} $(use_enable doc docs) $(use_with libffi)"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Fix FHS compliance, see upstream bug #535524
+ epatch "${FILESDIR}/${P}-fix-codegen-location.patch"
+
+ eautoreconf
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ Xemake check || die "tests failed"
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${P}
+ doins -r examples
+ fi
+
+ python_version
+ mv "${D}"/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py \
+ "${D}"/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py-2.0
+ mv "${D}"/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.pth \
+ "${D}"/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.pth-2.0
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0
+ alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py pygtk.py-[0-9].[0-9]
+ alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.pth pygtk.pth-[0-9].[0-9]
+ python_mod_compile /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup
+}