summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-06 23:10:18 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-06 23:10:18 +0000
commitc4b134481d0a6f030ce084b2c6a9c7f4929dfb1c (patch)
tree8cb6305788ab9cdbedfabf5d0155fc85df559a48 /dev-python/pyzmq
parentFix slot-deps on gtk+ and other libs (diff)
downloadgentoo-2-c4b134481d0a6f030ce084b2c6a9c7f4929dfb1c.tar.gz
gentoo-2-c4b134481d0a6f030ce084b2c6a9c7f4929dfb1c.tar.bz2
gentoo-2-c4b134481d0a6f030ce084b2c6a9c7f4929dfb1c.zip
Fix tests with Python 3.1.
(Portage version: 2.2.0_alpha26_p7/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pyzmq')
-rw-r--r--dev-python/pyzmq/ChangeLog6
-rw-r--r--dev-python/pyzmq/files/pyzmq-2.0.10.1-python-3.1.patch11
-rw-r--r--dev-python/pyzmq/pyzmq-2.0.10.1.ebuild3
3 files changed, 18 insertions, 2 deletions
diff --git a/dev-python/pyzmq/ChangeLog b/dev-python/pyzmq/ChangeLog
index 1f8ead8a78da..5814b2005cb5 100644
--- a/dev-python/pyzmq/ChangeLog
+++ b/dev-python/pyzmq/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pyzmq
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyzmq/ChangeLog,v 1.2 2011/03/06 23:05:54 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyzmq/ChangeLog,v 1.3 2011/03/06 23:10:18 arfrever Exp $
+
+ 06 Mar 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ pyzmq-2.0.10.1.ebuild, +files/pyzmq-2.0.10.1-python-3.1.patch:
+ Fix tests with Python 3.1.
06 Mar 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
pyzmq-2.0.10.1.ebuild, +files/pyzmq-2.0.10.1-python-2.7.patch:
diff --git a/dev-python/pyzmq/files/pyzmq-2.0.10.1-python-3.1.patch b/dev-python/pyzmq/files/pyzmq-2.0.10.1-python-3.1.patch
new file mode 100644
index 000000000000..3d56ab43e9e0
--- /dev/null
+++ b/dev-python/pyzmq/files/pyzmq-2.0.10.1-python-3.1.patch
@@ -0,0 +1,11 @@
+--- zmq/tests/test_message.py
++++ zmq/tests/test_message.py
+@@ -256,7 +256,7 @@
+ import numpy
+ except ImportError:
+ raise SkipTest("NumPy unavailable")
+- shapes = map(numpy.random.randint, [2]*5,[16]*5)
++ shapes = list(map(numpy.random.randint, [2]*5,[16]*5))
+ for i in range(1,len(shapes)+1):
+ shape = shapes[:i]
+ A = numpy.random.random(shape)
diff --git a/dev-python/pyzmq/pyzmq-2.0.10.1.ebuild b/dev-python/pyzmq/pyzmq-2.0.10.1.ebuild
index 1204be8fafee..d9ef50d94fa4 100644
--- a/dev-python/pyzmq/pyzmq-2.0.10.1.ebuild
+++ b/dev-python/pyzmq/pyzmq-2.0.10.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyzmq/pyzmq-2.0.10.1.ebuild,v 1.3 2011/03/06 23:05:54 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyzmq/pyzmq-2.0.10.1.ebuild,v 1.4 2011/03/06 23:10:18 arfrever Exp $
EAPI="3"
PYTHON_DEPEND="*:2.5"
@@ -31,6 +31,7 @@ src_prepare() {
distutils_src_prepare
epatch "${FILESDIR}/${P}-python-2.7.patch"
+ epatch "${FILESDIR}/${P}-python-3.1.patch"
}
src_compile() {