summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-12-17 06:33:10 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-12-17 06:33:10 +0000
commita7f3f03674c595974eb61ef874d507e8daadd032 (patch)
tree38769bd13ce1b625925976de345f44d757847189 /dev-python/weasyprint
parentBump (diff)
downloadgentoo-2-a7f3f03674c595974eb61ef874d507e8daadd032.tar.gz
gentoo-2-a7f3f03674c595974eb61ef874d507e8daadd032.tar.bz2
gentoo-2-a7f3f03674c595974eb61ef874d507e8daadd032.zip
Bump
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/weasyprint')
-rw-r--r--dev-python/weasyprint/ChangeLog7
-rw-r--r--dev-python/weasyprint/weasyprint-0.20.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-python/weasyprint/ChangeLog b/dev-python/weasyprint/ChangeLog
index dfcceab97a82..b3f63f103965 100644
--- a/dev-python/weasyprint/ChangeLog
+++ b/dev-python/weasyprint/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/weasyprint
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/weasyprint/ChangeLog,v 1.3 2013/09/19 11:07:43 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/weasyprint/ChangeLog,v 1.4 2013/12/17 06:33:10 patrick Exp $
+
+*weasyprint-0.20 (17 Dec 2013)
+
+ 17 Dec 2013; Patrick Lauer <patrick@gentoo.org> +weasyprint-0.20.ebuild:
+ Bump
19 Sep 2013; Sergey Popov <pinkbyte@gentoo.org> weasyprint-0.19.2.ebuild:
Fix HOMEPAGE
diff --git a/dev-python/weasyprint/weasyprint-0.20.ebuild b/dev-python/weasyprint/weasyprint-0.20.ebuild
new file mode 100644
index 000000000000..80d49d70ab38
--- /dev/null
+++ b/dev-python/weasyprint/weasyprint-0.20.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/weasyprint/weasyprint-0.20.ebuild,v 1.1 2013/12/17 06:33:10 patrick Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_2,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Visual rendering engine for HTML and CSS that can export to PDF."
+MY_PN="WeasyPrint"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+HOMEPAGE="http://weasyprint.org"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="x11-libs/cairo
+ x11-libs/pango
+ media-gfx/cairosvg
+ dev-python/cffi[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/cairocffi[${PYTHON_USEDEP}]
+ dev-python/tinycss[${PYTHON_USEDEP}]
+ dev-python/cssselect[${PYTHON_USEDEP}]
+ dev-python/pyphen[${PYTHON_USEDEP}]
+ "
+ # x11-libs/gdk-pixbuf # optional dep
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"