summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-05-03 08:03:02 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-05-03 08:03:02 +0000
commite1087db696e55614fcdd8d2b2786d7d0e86f7bfb (patch)
tree958fe2e2342a57e93e38abe2f98d92b502899433 /dev-python/wtf-peewee
parentVersion bump, add python3_4 support. (diff)
downloadgentoo-2-e1087db696e55614fcdd8d2b2786d7d0e86f7bfb.tar.gz
gentoo-2-e1087db696e55614fcdd8d2b2786d7d0e86f7bfb.tar.bz2
gentoo-2-e1087db696e55614fcdd8d2b2786d7d0e86f7bfb.zip
Bump
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/wtf-peewee')
-rw-r--r--dev-python/wtf-peewee/ChangeLog9
-rw-r--r--dev-python/wtf-peewee/wtf-peewee-0.2.0.ebuild28
2 files changed, 35 insertions, 2 deletions
diff --git a/dev-python/wtf-peewee/ChangeLog b/dev-python/wtf-peewee/ChangeLog
index 4deb42346431..2adb5a728d84 100644
--- a/dev-python/wtf-peewee/ChangeLog
+++ b/dev-python/wtf-peewee/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/wtf-peewee
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wtf-peewee/ChangeLog,v 1.3 2013/11/22 06:56:41 patrick Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wtf-peewee/ChangeLog,v 1.4 2014/05/03 08:03:02 patrick Exp $
+
+*wtf-peewee-0.2.0 (03 May 2014)
+
+ 03 May 2014; Patrick Lauer <patrick@gentoo.org> +wtf-peewee-0.2.0.ebuild:
+ Bump
*wtf-peewee-0.1.5 (22 Nov 2013)
diff --git a/dev-python/wtf-peewee/wtf-peewee-0.2.0.ebuild b/dev-python/wtf-peewee/wtf-peewee-0.2.0.ebuild
new file mode 100644
index 000000000000..841ebe61f7c5
--- /dev/null
+++ b/dev-python/wtf-peewee/wtf-peewee-0.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wtf-peewee/wtf-peewee-0.2.0.ebuild,v 1.1 2014/05/03 08:03:02 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+RESTRICT="test" # broken
+
+DESCRIPTION="Small python ORM"
+HOMEPAGE="https://github.com/coleifer/peewee/"
+SRC_URI="https://github.com/coleifer/${PN}/archive/${PV}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/peewee[${PYTHON_USEDEP}]
+ dev-python/wtforms[${PYTHON_USEDEP}]
+ "
+python_test() {
+ nosetests || die "Testing failed with ${EPYTHON}"
+}