summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-06-25 17:25:20 +0000
committerHans de Graaff <graaff@gentoo.org>2012-06-25 17:25:20 +0000
commit85985696793c70557370fa9f7848466eeaf1467d (patch)
treef1ff00d83f07fb6e4d5fab0a0314e2e8ac3c144b /dev-ruby/ruby-romkan
parentapp-text/searchmonkey: Fix for gcc-4.7, #423191 (diff)
downloadgentoo-2-85985696793c70557370fa9f7848466eeaf1467d.tar.gz
gentoo-2-85985696793c70557370fa9f7848466eeaf1467d.tar.bz2
gentoo-2-85985696793c70557370fa9f7848466eeaf1467d.zip
Add ruby19 with patch provided by Rafał Mużyło in bug 423445.
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/ruby-romkan')
-rw-r--r--dev-ruby/ruby-romkan/ChangeLog10
-rw-r--r--dev-ruby/ruby-romkan/files/ruby-romkan-ruby19.patch32
-rw-r--r--dev-ruby/ruby-romkan/ruby-romkan-0.4-r4.ebuild35
3 files changed, 75 insertions, 2 deletions
diff --git a/dev-ruby/ruby-romkan/ChangeLog b/dev-ruby/ruby-romkan/ChangeLog
index 41ac346ad44a..af3e470ef4b6 100644
--- a/dev-ruby/ruby-romkan/ChangeLog
+++ b/dev-ruby/ruby-romkan/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/ruby-romkan
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-romkan/ChangeLog,v 1.28 2011/10/12 17:00:36 matsuu Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-romkan/ChangeLog,v 1.29 2012/06/25 17:25:20 graaff Exp $
+
+*ruby-romkan-0.4-r4 (25 Jun 2012)
+
+ 25 Jun 2012; Hans de Graaff <graaff@gentoo.org>
+ +files/ruby-romkan-ruby19.patch, +ruby-romkan-0.4-r4.ebuild:
+ Add ruby19 with patch provided by Rafał Mużyło in bug 423445.
*ruby-romkan-0.4-r3 (12 Oct 2011)
diff --git a/dev-ruby/ruby-romkan/files/ruby-romkan-ruby19.patch b/dev-ruby/ruby-romkan/files/ruby-romkan-ruby19.patch
new file mode 100644
index 000000000000..4ae355749281
--- /dev/null
+++ b/dev-ruby/ruby-romkan/files/ruby-romkan-ruby19.patch
@@ -0,0 +1,32 @@
+--- romkan.rb 2002-02-12 02:45:16.000000000 +0100
++++ romkan.rb 2012-06-25 10:15:59.723542130 +0200
+@@ -1,3 +1,4 @@
++# -*- encoding:euc-jp -*-
+ #
+ # Ruby/Romkan - a Romaji <-> Kana conversion library for Ruby.
+ #
+@@ -209,13 +210,13 @@
+ HEPPAT = HEPBURN.sort {|a, b| b.length <=> a.length }.join "|"
+
+ TO_HEPBURN = (romrom = Hash.new
+- KUNREI.each_with_index {|x, i|
+- romrom[KUNREI[i]] = HEPBURN[i]}
++ KUNREI.each_with_index {|x, j|
++ romrom[KUNREI[j]] = HEPBURN[j]}
+ romrom)
+
+ TO_KUNREI = (romrom = Hash.new
+- HEPBURN.each_with_index {|x, i|
+- romrom[HEPBURN[i]] = KUNREI[i]}
++ HEPBURN.each_with_index {|x, j|
++ romrom[HEPBURN[j]] = KUNREI[j]}
+ romrom)
+
+ # FIXME: ad hod solution
+--- test.rb 2002-02-12 02:45:25.000000000 +0100
++++ test.rb 2012-06-25 10:13:51.832021574 +0200
+@@ -1,3 +1,4 @@
++# -*- encoding:euc-jp -*-
+ #
+ # ruby -Ke test.rb </dev/null && echo ok
+ #
diff --git a/dev-ruby/ruby-romkan/ruby-romkan-0.4-r4.ebuild b/dev-ruby/ruby-romkan/ruby-romkan-0.4-r4.ebuild
new file mode 100644
index 000000000000..cd584cf15d5c
--- /dev/null
+++ b/dev-ruby/ruby-romkan/ruby-romkan-0.4-r4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-romkan/ruby-romkan-0.4-r4.ebuild,v 1.1 2012/06/25 17:25:20 graaff Exp $
+
+EAPI="4"
+# ruby19 jruby
+USE_RUBY="ruby18 ruby19 ree18"
+
+inherit ruby-ng
+
+DESCRIPTION="A Romaji <-> Kana conversion library for Ruby"
+HOMEPAGE="http://0xcc.net/ruby-romkan/"
+SRC_URI="http://0xcc.net/ruby-romkan/${P}.tar.gz"
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+DOCS="ChangeLog *.rd"
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}/${PN}-ruby19.patch"
+}
+
+each_ruby_test() {
+ ${RUBY} -I. -Ke test.rb < /dev/null || die "test failed"
+}
+
+each_ruby_install() {
+ doruby romkan.rb
+}
+
+all_ruby_install() {
+ dodoc ${DOCS}
+}