summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-04-25 00:08:51 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-04-25 00:08:51 +0000
commitb0c1ffc0f77e3dfa1268bf046188d36115ff0fe8 (patch)
treef3b0b02367032f3510b5893da96a69074713ac35 /dev-ruby/ruby_parser
parentVersion bump. (diff)
downloadgentoo-2-b0c1ffc0f77e3dfa1268bf046188d36115ff0fe8.tar.gz
gentoo-2-b0c1ffc0f77e3dfa1268bf046188d36115ff0fe8.tar.bz2
gentoo-2-b0c1ffc0f77e3dfa1268bf046188d36115ff0fe8.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/ruby_parser')
-rw-r--r--dev-ruby/ruby_parser/ChangeLog7
-rw-r--r--dev-ruby/ruby_parser/ruby_parser-3.6.0.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-ruby/ruby_parser/ChangeLog b/dev-ruby/ruby_parser/ChangeLog
index 02a2f6d0ca42..e176f0856c2a 100644
--- a/dev-ruby/ruby_parser/ChangeLog
+++ b/dev-ruby/ruby_parser/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/ruby_parser
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby_parser/ChangeLog,v 1.59 2014/04/24 16:48:33 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby_parser/ChangeLog,v 1.60 2014/04/25 00:08:51 mrueg Exp $
+
+*ruby_parser-3.6.0 (25 Apr 2014)
+
+ 25 Apr 2014; Manuel Rüger <mrueg@gentoo.org> +ruby_parser-3.6.0.ebuild:
+ Version bump.
24 Apr 2014; Manuel Rüger <mrueg@gentoo.org> -ruby_parser-3.2.2-r1.ebuild:
Cleanup old.
diff --git a/dev-ruby/ruby_parser/ruby_parser-3.6.0.ebuild b/dev-ruby/ruby_parser/ruby_parser-3.6.0.ebuild
new file mode 100644
index 000000000000..460faf7a7010
--- /dev/null
+++ b/dev-ruby/ruby_parser/ruby_parser-3.6.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby_parser/ruby_parser-3.6.0.ebuild,v 1.1 2014/04/25 00:08:51 mrueg Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A ruby parser written in pure ruby."
+HOMEPAGE="https://github.com/seattlerb/ruby_parser"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/sexp_processor-4.1:4
+ !<dev-ruby/ruby_parser-2.3.1-r1"
+
+ruby_add_bdepend "doc? ( >=dev-ruby/hoe-2.9.1 )"
+ruby_add_bdepend "test? ( >=dev-ruby/minitest-4.3 )"
+
+all_ruby_prepare() {
+ # Remove reference to perforce method that is not in a released
+ # version of hoe-seattlerb.
+ #sed -i -e '/perforce/d' Rakefile || die
+ sed -i -e '/license/d' Rakefile || die
+ sed -i -e '/Hoe.plugin :isolate/ s:^:#:' Rakefile || die
+}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *jruby)
+ # Disable tests failing on jruby related to //n regexp
+ # https://github.com/seattlerb/ruby_parser/issues/117
+ rm test/test_ruby_parser.rb || die
+ ;;
+ esac
+}