summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-09-21 09:36:38 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-09-21 09:36:38 +0000
commitbe9e1f9c8dbe115a6055bcd002134cfa00bbcb61 (patch)
treef2addadc6dd86fadca4c6609272cdded0086aaf9 /dev-util/ltrace
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-be9e1f9c8dbe115a6055bcd002134cfa00bbcb61.tar.gz
gentoo-2-be9e1f9c8dbe115a6055bcd002134cfa00bbcb61.tar.bz2
gentoo-2-be9e1f9c8dbe115a6055bcd002134cfa00bbcb61.zip
Version bump
(Portage version: 2.2_rc8/cvs/Linux 2.6.25-gentoo-r7 i686)
Diffstat (limited to 'dev-util/ltrace')
-rw-r--r--dev-util/ltrace/ChangeLog7
-rw-r--r--dev-util/ltrace/ltrace-0.5.3.1.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-util/ltrace/ChangeLog b/dev-util/ltrace/ChangeLog
index eb3b5c417805..110235fce7fd 100644
--- a/dev-util/ltrace/ChangeLog
+++ b/dev-util/ltrace/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/ltrace
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ltrace/ChangeLog,v 1.47 2008/08/10 18:20:00 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ltrace/ChangeLog,v 1.48 2008/09/21 09:36:38 armin76 Exp $
+
+*ltrace-0.5.3.1 (21 Sep 2008)
+
+ 21 Sep 2008; Raúl Porcel <armin76@gentoo.org> +ltrace-0.5.3.1.ebuild:
+ Version bump
10 Aug 2008; Raúl Porcel <armin76@gentoo.org> ltrace-0.4-r1.ebuild,
ltrace-0.5.3.ebuild:
diff --git a/dev-util/ltrace/ltrace-0.5.3.1.ebuild b/dev-util/ltrace/ltrace-0.5.3.1.ebuild
new file mode 100644
index 000000000000..d983ce722062
--- /dev/null
+++ b/dev-util/ltrace/ltrace-0.5.3.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ltrace/ltrace-0.5.3.1.ebuild,v 1.1 2008/09/21 09:36:38 armin76 Exp $
+
+inherit eutils autotools
+
+MY_PV=${PV%.?.?}
+MY_P=${PN}_${MY_PV}
+DEB_P=${MY_P}-${PV##?.?.}
+
+DESCRIPTION="trace library calls made at runtime"
+HOMEPAGE="http://ltrace.alioth.debian.org/"
+SRC_URI="mirror://debian/pool/main/l/ltrace/${MY_P}.orig.tar.gz
+ mirror://debian/pool/main/l/ltrace/${DEB_P}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-libs/elfutils"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_unpack() {
+ unpack ${A}
+ epatch "${WORKDIR}"/${DEB_P}.diff
+ cd "${S}"
+ epatch "${FILESDIR}"/0.4-parallel-make.patch
+
+ epatch "${FILESDIR}"/${PN}-0.5.3-cross.patch
+ sed \
+ -e 's:uname -m:echo @HOST_CPU@:' \
+ sysdeps/linux-gnu/Makefile > sysdeps/linux-gnu/Makefile.in
+ epatch "${FILESDIR}"/${PN}-0.5.3-ppc.patch
+ eautoconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir=/usr/share/doc/${PF} install || die "make install failed"
+ prepalldocs
+}