summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeff Horelick <jdhore@gentoo.org>2012-07-21 06:35:44 +0000
committerJeff Horelick <jdhore@gentoo.org>2012-07-21 06:35:44 +0000
commitd68f6ea4cdcee4b2196f41fd399783fb5d8e580a (patch)
tree21cf6c72fae745f9a1289c9ba7f091133bf2cf09 /dev-util
parentRemove old version. (diff)
downloadgentoo-2-d68f6ea4cdcee4b2196f41fd399783fb5d8e580a.tar.gz
gentoo-2-d68f6ea4cdcee4b2196f41fd399783fb5d8e580a.tar.bz2
gentoo-2-d68f6ea4cdcee4b2196f41fd399783fb5d8e580a.zip
Add a patch to fix bug 426410 .
(Portage version: 2.2.0_alpha119/cvs/Linux i686)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/pkgconf/ChangeLog6
-rw-r--r--dev-util/pkgconf/files/pkgconf-0.8.1-newm4.patch66
-rw-r--r--dev-util/pkgconf/pkgconf-0.8.1.ebuild3
3 files changed, 73 insertions, 2 deletions
diff --git a/dev-util/pkgconf/ChangeLog b/dev-util/pkgconf/ChangeLog
index ccf7887b0f68..6787f7121832 100644
--- a/dev-util/pkgconf/ChangeLog
+++ b/dev-util/pkgconf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/pkgconf
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconf/ChangeLog,v 1.26 2012/07/21 03:56:04 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconf/ChangeLog,v 1.27 2012/07/21 06:35:44 jdhore Exp $
+
+ 21 Jul 2012; Jeff Horelick <jdhore@gentoo.org>
+ +files/pkgconf-0.8.1-newm4.patch, pkgconf-0.8.1.ebuild:
+ Add a patch to fix bug 426410 .
*pkgconf-0.8.1 (21 Jul 2012)
diff --git a/dev-util/pkgconf/files/pkgconf-0.8.1-newm4.patch b/dev-util/pkgconf/files/pkgconf-0.8.1-newm4.patch
new file mode 100644
index 000000000000..498850485d23
--- /dev/null
+++ b/dev-util/pkgconf/files/pkgconf-0.8.1-newm4.patch
@@ -0,0 +1,66 @@
+commit 840ecc846d1a168b475a31bb927b78c3677d565a
+Author: Dan Nicholson <dbn.lists@gmail.com>
+Date: Sat Jul 21 01:09:13 2012 -0500
+
+ Add autoconf macros to help packagers install .pc files
+
+ Some distros and users have unusual installation needs that don't
+ conform to the standard $libdir/pkgconfig and $datadir/pkgconfig
+ pathways. Help packagers support these users with the macros
+ PKG_INSTALLDIR and PKG_NOARCH_INSTALLDIR. These are simple macros that
+ provide the configure parameters --with-pkgconfigdir and
+ --with-noarch-pkgconfigdir to allow users to override the standard
+ locations.
+
+ Freedesktop #48743
+
+diff --git a/pkg.m4 b/pkg.m4
+index 4748f99..0354609 100644
+--- a/pkg.m4
++++ b/pkg.m4
+@@ -158,6 +158,45 @@ else
+ fi[]dnl
+ ])# PKG_CHECK_MODULES
+
++# PKG_INSTALLDIR(DIRECTORY)
++# -------------------------
++# Substitutes the variable pkgconfigdir as the location where a module
++# should install pkg-config .pc files. By default the directory is
++# $libdir/pkgconfig, but the default can be changed by passing
++# DIRECTORY. The user can override through the --with-pkgconfigdir
++# parameter.
++AC_DEFUN([PKG_INSTALLDIR],
++[m4_pushdef([pkg_default], [m4_default([$1], ['${libdir}/pkgconfig'])])
++m4_pushdef([pkg_description],
++ [pkg-config installation directory @<:@]pkg_default[@:>@])
++AC_ARG_WITH([pkgconfigdir],
++ [AS_HELP_STRING([--with-pkgconfigdir], pkg_description)],,
++ [with_pkgconfigdir=]pkg_default)
++AC_SUBST([pkgconfigdir], [$with_pkgconfigdir])
++m4_popdef([pkg_default])
++m4_popdef([pkg_description])
++]) dnl PKG_INSTALLDIR
++
++
++# PKG_NOARCH_INSTALLDIR(DIRECTORY)
++# -------------------------
++# Substitutes the variable noarch_pkgconfigdir as the location where a
++# module should install arch-independent pkg-config .pc files. By
++# default the directory is $datadir/pkgconfig, but the default can be
++# changed by passing DIRECTORY. The user can override through the
++# --with-noarch-pkgconfigdir parameter.
++AC_DEFUN([PKG_NOARCH_INSTALLDIR],
++[m4_pushdef([pkg_default], [m4_default([$1], ['${datadir}/pkgconfig'])])
++m4_pushdef([pkg_description],
++ [pkg-config arch-independent installation directory @<:@]pkg_default[@:>@])
++AC_ARG_WITH([noarch-pkgconfigdir],
++ [AS_HELP_STRING([--with-noarch-pkgconfigdir], pkg_description)],,
++ [with_noarch_pkgconfigdir=]pkg_default)
++AC_SUBST([noarch_pkgconfigdir], [$with_noarch_pkgconfigdir])
++m4_popdef([pkg_default])
++m4_popdef([pkg_description])
++]) dnl PKG_NOARCH_INSTALLDIR
++
+ # PKG_WITH_MODULES(VARIABLE-PREFIX, MODULES,
+ # [ACTION-IF-FOUND],[ACTION-IF-NOT-FOUND],
+ # [DESCRIPTION], [DEFAULT])
diff --git a/dev-util/pkgconf/pkgconf-0.8.1.ebuild b/dev-util/pkgconf/pkgconf-0.8.1.ebuild
index 7f6a2203a251..51f80f53b2d2 100644
--- a/dev-util/pkgconf/pkgconf-0.8.1.ebuild
+++ b/dev-util/pkgconf/pkgconf-0.8.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconf/pkgconf-0.8.1.ebuild,v 1.1 2012/07/21 03:56:04 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconf/pkgconf-0.8.1.ebuild,v 1.2 2012/07/21 06:35:44 jdhore Exp $
EAPI="4"
@@ -31,6 +31,7 @@ RDEPEND="${DEPEND}
)"
src_prepare() {
+ epatch "${FILESDIR}"/${P}-newm4.patch
[[ -e configure ]] || AT_M4DIR="m4" eautoreconf
}