summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-06-12 00:41:47 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-06-12 00:41:47 +0000
commitc2b2655d6ec9b4833f3cc6b43ed9f3225ab36176 (patch)
treef7d33573c62035b39a3cedc297f1234a54605b75 /eclass/gnome2.eclass
parentfixor (diff)
downloadgentoo-2-c2b2655d6ec9b4833f3cc6b43ed9f3225ab36176.tar.gz
gentoo-2-c2b2655d6ec9b4833f3cc6b43ed9f3225ab36176.tar.bz2
gentoo-2-c2b2655d6ec9b4833f3cc6b43ed9f3225ab36176.zip
remove scrollkeeper-update's completely in omf_fix. it should solve ALOT
of the sandbox scrollkeeper problems (hopefully!). also added sed-4 as dep.
Diffstat (limited to 'eclass/gnome2.eclass')
-rw-r--r--eclass/gnome2.eclass14
1 files changed, 10 insertions, 4 deletions
diff --git a/eclass/gnome2.eclass b/eclass/gnome2.eclass
index 0b098f89ba5d..8272fe6185b1 100644
--- a/eclass/gnome2.eclass
+++ b/eclass/gnome2.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/gnome2.eclass,v 1.33 2003/05/04 18:58:55 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/gnome2.eclass,v 1.34 2003/06/12 00:41:47 liquidx Exp $
#
# Authors:
# Bruce A. Locke <blocke@shivan.org>
@@ -22,6 +22,8 @@ USE_DESTDIR="" # use make DESTDIR=${D} install rather than einstall
[ -n "$DEBUG" -o -n "`use debug`" ] && G2CONF="${G2CONF} --enable-debug=yes"
+newdepend ">=sys-apps/sed-4"
+
gnome2_src_configure() {
elibtoolize ${ELTCONF}
# doc keyword for gtk-doc
@@ -100,14 +102,18 @@ gnome2_omf_fix() {
[ -f ${S}/omf-install/Makefile.in ] \
&& omf_makefiles="${omf_makefiles} ${S}/omf-install/Makefile.in"
+
+ # FIXME: does this really work? because omf.make only gets included
+ # when autoconf/automake is run. You should directly patch
+ # the Makefile.in's
+
[ -f ${S}/omf.make ] \
&& omf_makefiles="${omf_makefiles} ${S}/omf.make"
for omf in ${omf_makefiles}; do
omfbase=$(basename ${omf})
- einfo "Fixing OMF Makefile: ${omfbase}"
- sed -i -e 's:\(-scrollkeeper-update -p $(localstatedir)/scrollkeeper\)\([ \t\\]*\)$:\1 -o $(DESTDIR)$(omf_dest_dir)\2:' ${omf}
- sed -i -e 's:\(-scrollkeeper-update -p $(scrollkeeper_localstate_dir)\)\([ \t\\]*\)$:\1 -o $(DESTDIR)$(omf_dest_dir)\2:' ${omf}
+ einfo "Fixing OMF Makefile: ${omf#${S}/}"
+ sed -i -e 's:-scrollkeeper-update.*::' ${omf}
done
}