summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-01-04 12:06:28 +0000
committerDan Armak <danarmak@gentoo.org>2002-01-04 12:06:28 +0000
commite435f032128ba8614a7bfeb183466a773e72342e (patch)
tree3d4eda4c0e79441cbc5e43cf5f2000f81e7a476d /eclass/kde.eclass
parentfix for qt (diff)
downloadgentoo-2-e435f032128ba8614a7bfeb183466a773e72342e.tar.gz
gentoo-2-e435f032128ba8614a7bfeb183466a773e72342e.tar.bz2
gentoo-2-e435f032128ba8614a7bfeb183466a773e72342e.zip
merged virtual.eclass -> inherit.eclass. added || die to inherit(). added cvs snapshot support to
kde.eclass (runs make -f admin/Makefile.common where appropriate). misc small fixes.
Diffstat (limited to 'eclass/kde.eclass')
-rw-r--r--eclass/kde.eclass15
1 files changed, 13 insertions, 2 deletions
diff --git a/eclass/kde.eclass b/eclass/kde.eclass
index ff7ff1c38102..12122d742042 100644
--- a/eclass/kde.eclass
+++ b/eclass/kde.eclass
@@ -1,9 +1,9 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde.eclass,v 1.30 2002/01/03 20:31:10 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde.eclass,v 1.31 2002/01/04 12:06:28 danarmak Exp $
# The kde eclass is inherited by all kde-* eclasses. Few ebuilds inherit straight from here.
-inherit autoconf base || die
+inherit autoconf base
ECLASS=kde
DESCRIPTION="Based on the $ECLASS eclass"
@@ -28,6 +28,17 @@ kde_src_compile() {
configure)
debug-print-section configure
debug-print "$FUNCNAME::configure: myconf=$myconf"
+
+ # This can happen with e.g. a cvs snapshot
+ if [ ! -f "./configure" ]; then
+ for x in admin/Makefile.common; do
+ if [ -f "$x" ]; then
+ make -f $x # don't || die here!
+ fi
+ done
+ [ -f "./configure" ] || die
+ fi
+
export PATH="${KDEDIR}/bin:${PATH}"
./configure ${myconf} || die
;;