summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-08-15 17:41:03 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-08-15 17:41:03 +0000
commitd10fe8bf99007b8943c108f5b1a4c21fe7f0bb59 (patch)
tree6352336ebec01142c3b36e021dd3b8f37e0bb847 /games-emulation
parentIntroducing iprutils-2.2.0 ebuild (diff)
downloadgentoo-2-d10fe8bf99007b8943c108f5b1a4c21fe7f0bb59.tar.gz
gentoo-2-d10fe8bf99007b8943c108f5b1a4c21fe7f0bb59.tar.bz2
gentoo-2-d10fe8bf99007b8943c108f5b1a4c21fe7f0bb59.zip
add patch from Leonardo Boshell via bug #125861 to fix memory issue
(Portage version: 2.1.1_pre5-r1)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/zsnes/ChangeLog6
-rw-r--r--games-emulation/zsnes/files/zsnes-1.42-memfix.patch19
-rw-r--r--games-emulation/zsnes/zsnes-1.42.ebuild9
3 files changed, 29 insertions, 5 deletions
diff --git a/games-emulation/zsnes/ChangeLog b/games-emulation/zsnes/ChangeLog
index 906c8481d2ef..4fe1577cb3ce 100644
--- a/games-emulation/zsnes/ChangeLog
+++ b/games-emulation/zsnes/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/zsnes
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/zsnes/ChangeLog,v 1.21 2006/04/13 20:36:47 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/zsnes/ChangeLog,v 1.22 2006/08/15 17:41:03 mr_bones_ Exp $
+
+ 15 Aug 2006; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/zsnes-1.42-memfix.patch, zsnes-1.42.ebuild:
+ add patch from Leonardo Boshell via bug #125861 to fix memory issue
13 Apr 2006; Chris Gianelloni <wolf31o2@gentoo.org> zsnes-1.42.ebuild:
Moved games_pkg_setup to the beginning of pkg_setup.
diff --git a/games-emulation/zsnes/files/zsnes-1.42-memfix.patch b/games-emulation/zsnes/files/zsnes-1.42-memfix.patch
new file mode 100644
index 000000000000..a80ae3679984
--- /dev/null
+++ b/games-emulation/zsnes/files/zsnes-1.42-memfix.patch
@@ -0,0 +1,19 @@
+diff -NurdB zsnes_1_42/src/linux/zfilew.c zsnes_1_42-patched/src/linux/zfilew.c
+--- zsnes_1_42/src/linux/zfilew.c 2005-01-14 08:11:19.000000000 -0500
++++ zsnes_1_42-patched/src/linux/zfilew.c 2006-03-16 02:16:42.000000000 -0500
+@@ -476,9 +476,13 @@
+ {
+ homedir = (char *)malloc(ZCFG_DIR_LEN);
+ getcwd(homedir, ZCFG_DIR_LEN);
++ strcpy(zcfgdir, homedir);
++ free(homedir);
++ }
++ else
++ {
++ strcpy(zcfgdir, homedir);
+ }
+- strcpy(zcfgdir, homedir);
+- free(homedir);
+ strcat(zcfgdir, ZCFG_DIR);
+ tmp = opendir(zcfgdir);
+ if (tmp == NULL)
diff --git a/games-emulation/zsnes/zsnes-1.42.ebuild b/games-emulation/zsnes/zsnes-1.42.ebuild
index 4e64e501b7b7..167a405505c5 100644
--- a/games-emulation/zsnes/zsnes-1.42.ebuild
+++ b/games-emulation/zsnes/zsnes-1.42.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/zsnes/zsnes-1.42.ebuild,v 1.13 2006/06/20 19:17:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/zsnes/zsnes-1.42.ebuild,v 1.14 2006/08/15 17:41:03 mr_bones_ Exp $
-inherit eutils flag-o-matic multilib games
+inherit eutils autotools flag-o-matic multilib games
DESCRIPTION="SNES (Super Nintendo) emulator that uses x86 assembly"
HOMEPAGE="http://www.zsnes.com/ http://ipherswipsite.com/zsnes/"
@@ -30,8 +30,9 @@ src_unpack() {
cd "${S}"/src
cp "icons/48x48x32.png" "${T}/zsnes.png"
epatch "${FILESDIR}"/${PV}-configure.patch \
- "${FILESDIR}"/${P}-execStack.patch
- aclocal && autoconf || die "autotools failed"
+ "${FILESDIR}"/${P}-execStack.patch \
+ "${FILESDIR}"/${P}-memfix.patch
+ eautoreconf
}
src_compile() {