summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-06-29 16:41:17 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-06-29 16:41:17 +0000
commit18793bc336559d002e0f338ffce81f8db0409a81 (patch)
tree02c57689863e61ec98b7f2bfaec5ac7fc64674b0 /games-fps
parentadd icu use dep (bug #264971) (diff)
downloadgentoo-2-18793bc336559d002e0f338ffce81f8db0409a81.tar.gz
gentoo-2-18793bc336559d002e0f338ffce81f8db0409a81.tar.bz2
gentoo-2-18793bc336559d002e0f338ffce81f8db0409a81.zip
more quoting (bug #275839)
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/unreal-tournament/ChangeLog8
-rw-r--r--games-fps/unreal-tournament/unreal-tournament-451.ebuild54
2 files changed, 33 insertions, 29 deletions
diff --git a/games-fps/unreal-tournament/ChangeLog b/games-fps/unreal-tournament/ChangeLog
index b46a78ef9be4..062fbdd31250 100644
--- a/games-fps/unreal-tournament/ChangeLog
+++ b/games-fps/unreal-tournament/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-fps/unreal-tournament
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal-tournament/ChangeLog,v 1.18 2008/02/29 19:20:21 carlo Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal-tournament/ChangeLog,v 1.19 2009/06/29 16:41:17 mr_bones_ Exp $
+
+ 29 Jun 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ unreal-tournament-451.ebuild:
+ more quoting (bug #275839)
29 Feb 2008; Carsten Lohrke <carlo@gentoo.org>
unreal-tournament-451.ebuild:
diff --git a/games-fps/unreal-tournament/unreal-tournament-451.ebuild b/games-fps/unreal-tournament/unreal-tournament-451.ebuild
index d2bd9bd87296..587bcb730082 100644
--- a/games-fps/unreal-tournament/unreal-tournament-451.ebuild
+++ b/games-fps/unreal-tournament/unreal-tournament-451.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal-tournament/unreal-tournament-451.ebuild,v 1.25 2008/02/29 19:20:21 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal-tournament/unreal-tournament-451.ebuild,v 1.26 2009/06/29 16:41:17 mr_bones_ Exp $
inherit eutils games
@@ -40,33 +40,33 @@ src_unpack() {
src_install() {
local dir=${GAMES_PREFIX_OPT}/${PN}
local Ddir=${D}/${dir}
- dodir ${dir}
+ dodir "${dir}"
# Help, Logs, Music, Textures, Web
- cp -rf ${CDROM_ROOT}/{Help,Logs,Music,Textures,Web} ${Ddir}/ || die "copy Help, Logs, Music, Textures, Web"
- tar -zxf Credits.tar.gz -C ${Ddir} || die "extract credits texture"
+ cp -rf "${CDROM_ROOT}"/{Help,Logs,Music,Textures,Web} "${Ddir}/" || die "copy Help, Logs, Music, Textures, Web"
+ tar -zxf Credits.tar.gz -C "${Ddir}" || die "extract credits texture"
# NetGamesUSA.com
- tar -zxf NetGamesUSA.com.tar.gz -C ${Ddir}/ || die "extract NetGamesUSA.com"
+ tar -zxf NetGamesUSA.com.tar.gz -C "${Ddir}/" || die "extract NetGamesUSA.com"
# Sounds
- dodir ${dir}/Sounds
- cp -rf ${CDROM_ROOT}/Sounds/*.uax ${Ddir}/Sounds/ || die "copy Sounds"
+ dodir "${dir}"/Sounds
+ cp -rf "${CDROM_ROOT}"/Sounds/*.uax "${Ddir}"/Sounds/ || die "copy Sounds"
# System
if use 3dfx ; then
- tar -zxf Glide.ini.tar.gz -C ${Ddir} || die "install Glide ini"
+ tar -zxf Glide.ini.tar.gz -C "${Ddir}" || die "install Glide ini"
else
- tar -zxf OpenGL.ini.tar.gz -C ${Ddir} || die "install OpenGL ini"
+ tar -zxf OpenGL.ini.tar.gz -C "${Ddir}" || die "install OpenGL ini"
fi
- tar -zxf data.tar.gz -C ${Ddir} || die "extract System data"
- cp ${CDROM_ROOT}/System/*.u ${Ddir}/System/ || die "copy System data"
+ tar -zxf data.tar.gz -C "${Ddir}" || die "extract System data"
+ cp "${CDROM_ROOT}"/System/*.u "${Ddir}"/System/ || die "copy System data"
# the most important things, ucc & ut :)
- exeinto ${dir}
+ exeinto "${dir}"
doexe bin/x86/{ucc,ut} || die "install ucc/ut"
- dosed "s:\`FindPath \$0\`:${dir}:" ${dir}/ucc
+ dosed "s:\`FindPath \$0\`:${dir}:" "${dir}"/ucc
# install a few random files
- insinto ${dir}
+ insinto "${dir}"
doins README icon.{bmp,xpm} || die "installing random files"
# install a menu item (closes bug #27542)
@@ -76,34 +76,34 @@ src_install() {
# first apply any patch remaints loki has for us
cd setup.data
- ./bin/Linux/x86/loki_patch patch.dat ${Ddir} >& /dev/null
+ ./bin/Linux/x86/loki_patch patch.dat "${Ddir}" >& /dev/null
cd "${S}"
# finally, unleash the UTPG patch
- cp -rf UTPG/* ${Ddir}/
+ cp -rf UTPG/* "${Ddir}/"
# fix a small bug until next official release
- dosed "/^LoadClassMismatch/s:%s.%s:%s:" ${dir}/System/Core.int
+ dosed "/^LoadClassMismatch/s:%s.%s:%s:" "${dir}"/System/Core.int
# now we uncompress the maps (GOTY edition installs maps as .uz)
einfo "Uncompressing Maps ... this may take some time"
- dodir ${dir}/Maps
- cd ${Ddir}
+ dodir "${dir}"/Maps
+ cd "${Ddir}"
export HOME=${T}
export UT_DATA_PATH=${Ddir}/System
- for f in $(find ${CDROM_ROOT}/Maps/ -name '*.uz' -printf '%f ') ; do
- ./ucc decompress ${CDROM_ROOT}/Maps/${f} -nohomedir || die "uncompressing map ${f}"
- mv System/${f:0:${#f}-3} Maps/ || die "copy map ${f}"
+ for f in $(find "${CDROM_ROOT}"/Maps/ -name '*.uz' -printf '%f ') ; do
+ ./ucc decompress "${CDROM_ROOT}"/Maps/"${f}" -nohomedir || die "uncompressing map ${f}"
+ mv "System/${f:0:${#f}-3}" Maps/ || die "copy map ${f}"
done
- cp -rf ${CDROM_ROOT}/Maps/*.unr ${Ddir}/Maps/ # some cd's have uncompressed maps ??
+ cp -rf "${CDROM_ROOT}"/Maps/*.unr "${Ddir}"/Maps/ # some cd's have uncompressed maps ??
# now, since these files are coming off a cd, the times/sizes/md5sums wont
# be different ... that means portage will try to unmerge some files (!)
# we run touch on ${D} so as to make sure portage doesnt do any such thing
- find ${Ddir} -exec touch '{}' \;
+ find "${Ddir}" -exec touch '{}' +
# export some symlinks so ppl can run
- dodir ${GAMES_BINDIR}
- dosym ${dir}/ut ${GAMES_BINDIR}/ut
+ dodir "${GAMES_BINDIR}"
+ dosym "${dir}/ut" "${GAMES_BINDIR}/ut"
prepgamesdirs
}