summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-10-16 01:11:53 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-10-16 01:11:53 +0000
commit349f2146f476c5bb8d8207288aa5af2708b331e8 (patch)
tree30f04b088965384ae077de7e9ca8273a0097e041 /games-roguelike/scourge/scourge-0.6.ebuild
parentAdded ~sparc keyword for bug #67731. (Manifest recommit) (diff)
downloadgentoo-2-349f2146f476c5bb8d8207288aa5af2708b331e8.tar.gz
gentoo-2-349f2146f476c5bb8d8207288aa5af2708b331e8.tar.bz2
gentoo-2-349f2146f476c5bb8d8207288aa5af2708b331e8.zip
version bump (bug #66806) - ebuild submitted by Jamis Buck
Diffstat (limited to 'games-roguelike/scourge/scourge-0.6.ebuild')
-rw-r--r--games-roguelike/scourge/scourge-0.6.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/games-roguelike/scourge/scourge-0.6.ebuild b/games-roguelike/scourge/scourge-0.6.ebuild
new file mode 100644
index 000000000000..0ebebbd0b8c2
--- /dev/null
+++ b/games-roguelike/scourge/scourge-0.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/scourge/scourge-0.6.ebuild,v 1.1 2004/10/16 01:11:53 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="A rogue-like adventure game to eliminate pests"
+HOMEPAGE="http://scourge.sf.net"
+SRC_URI="mirror://sourceforge/scourge/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc amd64"
+IUSE=""
+
+DEPEND="virtual/x11
+ virtual/glut
+ virtual/opengl
+ >=media-libs/libsdl-1.2"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}/src"
+ sed -i \
+ -e "s:\"data/:\"${GAMES_DATADIR}/${PN}/data/:g" \
+ shapepalette.cpp text.cpp \
+ || die "sed failed"
+ find "${S}" -name .DS_Store -exec rm -f \{\} \;
+ find "${S}/data" -type f -exec chmod a-x \{\} \;
+}
+
+src_compile() {
+ egamesconf \
+ --with-data-dir="${GAMES_DATADIR}/${PN}/data" \
+ || die
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ dogamesbin src/scourge || die "dogamesbin failed"
+ dodir "${GAMES_DATADIR}/${PN}"
+ cp -r data/ "${D}${GAMES_DATADIR}/${PN}" || die "cp failed"
+ dodoc AUTHORS README || die "dodoc failed"
+ prepgamesdirs
+}