summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-10-15 08:28:29 +0000
committerPacho Ramos <pacho@gentoo.org>2014-10-15 08:28:29 +0000
commit1f5f51bd006721bf1eb2307fc5221fd2409cf8b1 (patch)
tree4a87f3b66167c91a65252eb893185f7e4cabc9ab /games-rpg
parentFix referencing old & broken init file (diff)
downloadgentoo-2-1f5f51bd006721bf1eb2307fc5221fd2409cf8b1.tar.gz
gentoo-2-1f5f51bd006721bf1eb2307fc5221fd2409cf8b1.tar.bz2
gentoo-2-1f5f51bd006721bf1eb2307fc5221fd2409cf8b1.zip
Support multilib providers for deps. Bump to EAPI=5.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/sacred-gold/ChangeLog7
-rw-r--r--games-rpg/sacred-gold/sacred-gold-1.0.01.ebuild31
-rw-r--r--games-rpg/sacred-gold/sacred-gold-1.0.ebuild25
3 files changed, 44 insertions, 19 deletions
diff --git a/games-rpg/sacred-gold/ChangeLog b/games-rpg/sacred-gold/ChangeLog
index ee5ae2f1e9ed..ea3606bcae01 100644
--- a/games-rpg/sacred-gold/ChangeLog
+++ b/games-rpg/sacred-gold/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-rpg/sacred-gold
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/sacred-gold/ChangeLog,v 1.6 2014/04/16 17:08:02 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/sacred-gold/ChangeLog,v 1.7 2014/10/15 08:28:29 pacho Exp $
+
+ 15 Oct 2014; Pacho Ramos <pacho@gentoo.org> sacred-gold-1.0.01.ebuild,
+ sacred-gold-1.0.ebuild:
+ Support multilib providers for deps. Bump to EAPI=5.
16 Apr 2014; Ulrich Müller <ulm@gentoo.org> sacred-gold-1.0.ebuild,
sacred-gold-1.0.01.ebuild:
@@ -26,4 +30,3 @@
29 Jul 2009; Denis Dupeyron <calchan@gentoo.org> +sacred-gold-1.0.ebuild:
Initial commit. Enjoy.
-
diff --git a/games-rpg/sacred-gold/sacred-gold-1.0.01.ebuild b/games-rpg/sacred-gold/sacred-gold-1.0.01.ebuild
index 93d9d0f9dba5..a2f2165bd204 100644
--- a/games-rpg/sacred-gold/sacred-gold-1.0.01.ebuild
+++ b/games-rpg/sacred-gold/sacred-gold-1.0.01.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/sacred-gold/sacred-gold-1.0.01.ebuild,v 1.4 2014/04/16 17:08:02 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/sacred-gold/sacred-gold-1.0.01.ebuild,v 1.5 2014/10/15 08:28:29 pacho Exp $
+
+EAPI=5
inherit versionator eutils cdrom unpacker games
@@ -17,11 +19,20 @@ KEYWORDS="-* ~amd64 ~x86"
IUSE=""
RESTRICT="mirror bindist strip"
-RDEPEND="virtual/opengl
- x86? ( x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXi )
- amd64? ( app-emulation/emul-linux-x86-xlibs )"
+RDEPEND="
+ || (
+ (
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ x11-libs/libXi[abi_x86_32(-)]
+ virtual/opengl[abi_x86_32(-)]
+ )
+ amd64? (
+ app-emulation/emul-linux-x86-opengl[-abi_x86_32(-)]
+ app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)]
+ )
+ )
+"
DEPEND=""
S=${WORKDIR}
@@ -35,12 +46,12 @@ src_unpack() {
cp -f "${CDROM_ROOT}"/README* . || die
cp -f "${CDROM_ROOT}"/manual.pdf . || die
- mkdir -p patch
- cd patch
+ mkdir -p "patch"
+ cd "patch"
unpack_makeself ${MY_P}-x86.run
bin/Linux/x86/loki_patch patch.dat "${S}" || die "loki_patch failed"
cd "${S}"
- rm -rf patch
+ rm -rf "patch"
mv lib/lib{1,2}/* lib
rmdir lib/lib{1,2}
@@ -53,7 +64,7 @@ src_install() {
mv * "${D}/${dir}" || die
games_make_wrapper ${PN} ./sacred "${dir}" "${dir}"/lib
- newicon "${CDROM_ROOT}"/.data/icon.xpm ${PN}.xpm || die
+ newicon "${CDROM_ROOT}"/.data/icon.xpm ${PN}.xpm
make_desktop_entry ${PN} "Sacred - Gold" ${PN}
prepgamesdirs
diff --git a/games-rpg/sacred-gold/sacred-gold-1.0.ebuild b/games-rpg/sacred-gold/sacred-gold-1.0.ebuild
index 2d9d9a32fcc5..09820c586c29 100644
--- a/games-rpg/sacred-gold/sacred-gold-1.0.ebuild
+++ b/games-rpg/sacred-gold/sacred-gold-1.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/sacred-gold/sacred-gold-1.0.ebuild,v 1.3 2014/04/16 17:08:02 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/sacred-gold/sacred-gold-1.0.ebuild,v 1.4 2014/10/15 08:28:29 pacho Exp $
+
+EAPI=5
inherit eutils cdrom games
@@ -14,11 +16,20 @@ KEYWORDS="-* ~amd64 ~x86"
IUSE=""
RESTRICT="bindist strip"
-RDEPEND="virtual/opengl
- x86? ( x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXi )
- amd64? ( app-emulation/emul-linux-x86-xlibs )"
+RDEPEND="
+ || (
+ (
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ x11-libs/libXi[abi_x86_32(-)]
+ virtual/opengl[abi_x86_32(-)]
+ )
+ amd64? (
+ app-emulation/emul-linux-x86-opengl[-abi_x86_32(-)]
+ app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)]
+ )
+ )
+"
DEPEND=""
S=${WORKDIR}
@@ -42,7 +53,7 @@ src_install() {
mv * "${D}/${dir}" || die
games_make_wrapper ${PN} ./sacred "${dir}" "${dir}"/lib
- newicon "${CDROM_ROOT}"/.data/icon.xpm ${PN}.xpm || die
+ newicon "${CDROM_ROOT}"/.data/icon.xpm ${PN}.xpm
make_desktop_entry ${PN} "Sacred - Gold" ${PN}
prepgamesdirs