summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-04-27 17:23:05 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2014-04-27 17:23:05 +0000
commit3c01750b70e28d8e2b549a8037cfcf4ef86286a3 (patch)
treed2cc1d6f119f90ce63578a24432d444354e52463 /gnome-extra/sushi
parentVersion bump for Gnome 3.12. (diff)
downloadgentoo-2-3c01750b70e28d8e2b549a8037cfcf4ef86286a3.tar.gz
gentoo-2-3c01750b70e28d8e2b549a8037cfcf4ef86286a3.tar.bz2
gentoo-2-3c01750b70e28d8e2b549a8037cfcf4ef86286a3.zip
Version bump for Gnome 3.12.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'gnome-extra/sushi')
-rw-r--r--gnome-extra/sushi/ChangeLog7
-rw-r--r--gnome-extra/sushi/sushi-3.12.0.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/gnome-extra/sushi/ChangeLog b/gnome-extra/sushi/ChangeLog
index 78feb7b7db43..307df99f294c 100644
--- a/gnome-extra/sushi/ChangeLog
+++ b/gnome-extra/sushi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-extra/sushi
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/sushi/ChangeLog,v 1.24 2014/04/18 10:58:55 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/sushi/ChangeLog,v 1.25 2014/04/27 17:23:05 eva Exp $
+
+*sushi-3.12.0 (27 Apr 2014)
+
+ 27 Apr 2014; Gilles Dartiguelongue <eva@gentoo.org> +sushi-3.12.0.ebuild:
+ Version bump for Gnome 3.12.
18 Apr 2014; Pacho Ramos <pacho@gentoo.org> -sushi-3.8.1.ebuild:
Drop old
diff --git a/gnome-extra/sushi/sushi-3.12.0.ebuild b/gnome-extra/sushi/sushi-3.12.0.ebuild
new file mode 100644
index 000000000000..e5327150a0f7
--- /dev/null
+++ b/gnome-extra/sushi/sushi-3.12.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/sushi/sushi-3.12.0.ebuild,v 1.1 2014/04/27 17:23:05 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="A quick previewer for Nautilus, the GNOME file manager"
+HOMEPAGE="http://git.gnome.org/browse/sushi"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="office"
+
+# Optional app-office/unoconv support (OOo to pdf)
+# freetype needed for font loader
+# libX11 needed for sushi_create_foreign_window()
+COMMON_DEPEND="
+ >=x11-libs/gdk-pixbuf-2.23[introspection]
+ >=dev-libs/gjs-1.40
+ >=dev-libs/glib-2.29.14:2
+ >=dev-libs/gobject-introspection-0.9.6
+ >=media-libs/clutter-1.11.4:1.0[introspection]
+ >=media-libs/clutter-gtk-1.0.1:1.0[introspection]
+ >=x11-libs/gtk+-3.4.0:3[introspection]
+
+ >=app-text/evince-3.0[introspection]
+ media-libs/freetype:2
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection]
+ media-libs/clutter-gst:2.0[introspection]
+ media-libs/musicbrainz:5
+ net-libs/webkit-gtk:3[introspection]
+ x11-libs/gtksourceview:3.0[introspection]
+ x11-libs/libX11
+
+ office? ( app-office/unoconv )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+"
+RDEPEND="${COMMON_DEPEND}
+ >=gnome-base/nautilus-3.1.90
+ x11-themes/gnome-icon-theme-symbolic
+"
+
+src_configure() {
+ gnome2_src_configure --disable-static
+}