summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2007-10-29 07:39:00 +0000
committerWulf Krueger <philantrop@gentoo.org>2007-10-29 07:39:00 +0000
commit439dadc2930c460b0491789667553a2ef053de57 (patch)
tree4c59ab04141301fdabb49668f4b2798edcc30a42 /kde-base/pykde/pykde-3.5.8.ebuild
parentFix for recent glib that changes the type of the gtype typedef (diff)
downloadgentoo-2-439dadc2930c460b0491789667553a2ef053de57.tar.gz
gentoo-2-439dadc2930c460b0491789667553a2ef053de57.tar.bz2
gentoo-2-439dadc2930c460b0491789667553a2ef053de57.zip
Added a patch for Python 2.5 compatibility and some other fixes.
(Portage version: 2.1.3.15)
Diffstat (limited to 'kde-base/pykde/pykde-3.5.8.ebuild')
-rw-r--r--kde-base/pykde/pykde-3.5.8.ebuild22
1 files changed, 17 insertions, 5 deletions
diff --git a/kde-base/pykde/pykde-3.5.8.ebuild b/kde-base/pykde/pykde-3.5.8.ebuild
index 406eea536b6c..5b234a1e725c 100644
--- a/kde-base/pykde/pykde-3.5.8.ebuild
+++ b/kde-base/pykde/pykde-3.5.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde/pykde-3.5.8.ebuild,v 1.2 2007/10/27 14:11:11 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde/pykde-3.5.8.ebuild,v 1.3 2007/10/29 07:38:59 philantrop Exp $
KMNAME=kdebindings
KMMODULE=python
@@ -17,14 +17,19 @@ LICENSE="GPL-2"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE="debug doc examples"
-DEPEND="~dev-python/sip-4.2.1
- ~dev-python/PyQt-3.14.1
- kde-base/kdelibs
- !dev-python/pykde"
+DEPEND=">=dev-python/sip-4.6
+ >=dev-python/PyQt-3.17.2
+ kde-base/kdelibs
+ || ( kde-base/kdebase kde-base/konsole )
+ !dev-python/pykde"
src_unpack() {
kde-meta_src_unpack
cd "${S}/python/pykde"
+ epatch "${FILESDIR}/${P}-python-2.5-compat.diff"
+
+ mkdir -p kparts
+ ln -s "${PREFIX}"/$(get_libdir)/kde3/libkonsolepart* ./kparts/
}
src_compile() {
@@ -44,6 +49,13 @@ src_compile() {
src_install() {
cd "${S}/python/pykde"
+ dodir "${PREFIX}"/$(get_libdir)
+ sed -i -e "s:/lib/:/$(get_libdir)/:g" Makefile
+
+ for X in dcop kdecore kdefx kdeui kio kresources kabc kutils kfile kparts khtml kspell kdeprint kmdi ; do
+ sed -i -e '/strip $(DESTDIR).*/d' ${X}/Makefile
+ done
+
make DESTDIR="${D}" install || die
find "${D}/usr/share/sip" -not -type d -not -iname *.sip -exec rm '{}' \;