summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-12-02 08:07:21 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-12-02 08:07:21 +0000
commit617fc7fb7a2021e747e475df1fae115f5b7ccb0f (patch)
tree3bb9b60caf2e0fc70d1d96bcf8ddad06276d44a2 /media-plugins/xmms-goom
parentversion bump (diff)
downloadgentoo-2-617fc7fb7a2021e747e475df1fae115f5b7ccb0f.tar.gz
gentoo-2-617fc7fb7a2021e747e475df1fae115f5b7ccb0f.tar.bz2
gentoo-2-617fc7fb7a2021e747e475df1fae115f5b7ccb0f.zip
new visualisation plugin
Diffstat (limited to 'media-plugins/xmms-goom')
-rw-r--r--media-plugins/xmms-goom/ChangeLog11
-rw-r--r--media-plugins/xmms-goom/files/digest-xmms-goom-1.10.01
-rw-r--r--media-plugins/xmms-goom/files/xmms-goom-1.10.0-libtool.patch12
-rw-r--r--media-plugins/xmms-goom/xmms-goom-1.10.0.ebuild42
4 files changed, 66 insertions, 0 deletions
diff --git a/media-plugins/xmms-goom/ChangeLog b/media-plugins/xmms-goom/ChangeLog
new file mode 100644
index 000000000000..e323041b571e
--- /dev/null
+++ b/media-plugins/xmms-goom/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for media-plugins/xmms-goom
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-goom/ChangeLog,v 1.1 2002/12/02 08:07:21 seemant Exp $
+
+*xmms-goom-1.10.0 (02 Dec 2002)
+
+ 02 Dec 2002; Seemant Kulleen <seemant@gentoo.org> xmms-goom-1.10.0.ebuild
+ files/xmms-goom-1.10.0-libtool.patch files/digest-xmms-goom-1.10.0 :
+
+ New "trippy" SDL based visualisation plugin for XMMS. Submitted by:
+ trauma@web.de (Thomas R. (TRauMa)) in bug #10968.
diff --git a/media-plugins/xmms-goom/files/digest-xmms-goom-1.10.0 b/media-plugins/xmms-goom/files/digest-xmms-goom-1.10.0
new file mode 100644
index 000000000000..7e0b74a66be8
--- /dev/null
+++ b/media-plugins/xmms-goom/files/digest-xmms-goom-1.10.0
@@ -0,0 +1 @@
+MD5 7a48ece9564a4ded125215a3cb5728fc goom-1.10.0.tgz 275658
diff --git a/media-plugins/xmms-goom/files/xmms-goom-1.10.0-libtool.patch b/media-plugins/xmms-goom/files/xmms-goom-1.10.0-libtool.patch
new file mode 100644
index 000000000000..89e05653472c
--- /dev/null
+++ b/media-plugins/xmms-goom/files/xmms-goom-1.10.0-libtool.patch
@@ -0,0 +1,12 @@
+372,376c372,376
+< if test "$LTCONFIG_VERSION" != "$VERSION"; then
+< echo "$modename: ltconfig version \`$LTCONFIG_VERSION' does not match $PROGRAM version \`$VERSION'" 1>&2
+< echo "Fatal configuration error. See the $PACKAGE docs for more information." 1>&2
+< exit 1
+< fi
+---
+> #if test "$LTCONFIG_VERSION" != "$VERSION"; then
+> # echo "$modename: ltconfig version \`$LTCONFIG_VERSION' does not match $PROGRAM version \`$VERSION'" 1>&2
+> # echo "Fatal configuration error. See the $PACKAGE docs for more information." 1>&2
+> # exit 1
+> #fi
diff --git a/media-plugins/xmms-goom/xmms-goom-1.10.0.ebuild b/media-plugins/xmms-goom/xmms-goom-1.10.0.ebuild
new file mode 100644
index 000000000000..0181daf5d35c
--- /dev/null
+++ b/media-plugins/xmms-goom/xmms-goom-1.10.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-goom/xmms-goom-1.10.0.ebuild,v 1.1 2002/12/02 08:07:21 seemant Exp $
+
+MY_P=${P/xmms-/}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Trippy Vis for XMMS using SDL."
+SRC_URI="http://unc.dl.sourceforge.net/sourceforge/goom/${MY_P}.tgz"
+HOMEPAGE="http://ios.free.fr/?page=projet&quoi=1&lg=AN"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~x86"
+
+DEPEND="media-sound/xmms
+ media-libs/libsdl
+ sys-apps/sh-utils"
+
+src_compile() {
+
+ # special script for Athlon/Duron users
+ if [ -n "`uname -p | grep Duron` || `uname -p | grep Athlon`" ]
+ then
+ einfo "Athlon/Duron prep"
+ ./athlon.sh
+ fi
+
+ econf
+ # patch out the version mismatch junk
+ patch libtool < ${FILESDIR}/${P}-libtool.patch || die
+ emake OPT="$CFLAGS" || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc INSTALL README AUTHORS NEWS KNOWNBUGS ChangeLog
+}
+
+
+src_postinst() {
+ einfo "Press TAB for Fullscreen, +/- for resolution."
+}