summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-12-12 09:22:39 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-12-12 09:22:39 +0000
commit410af7dee4c2406728c34c2491d1a004b81508ce (patch)
tree8f267eddc4f13d44acc43b47b16f28bd7d3edd26 /media-video/ffmpeg
parentMake 'vaapi' USE flag global as discussed in gentoo-dev maillist (diff)
downloadgentoo-2-410af7dee4c2406728c34c2491d1a004b81508ce.tar.gz
gentoo-2-410af7dee4c2406728c34c2491d1a004b81508ce.tar.bz2
gentoo-2-410af7dee4c2406728c34c2491d1a004b81508ce.zip
backport upstream patch to build with USE=samba, patch pointed out by jospezial in bug #531714
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-video/ffmpeg')
-rw-r--r--media-video/ffmpeg/ChangeLog7
-rw-r--r--media-video/ffmpeg/ffmpeg-2.5.ebuild3
-rw-r--r--media-video/ffmpeg/files/samba.patch26
3 files changed, 34 insertions, 2 deletions
diff --git a/media-video/ffmpeg/ChangeLog b/media-video/ffmpeg/ChangeLog
index ee58c372cb92..b273ebce5cfe 100644
--- a/media-video/ffmpeg/ChangeLog
+++ b/media-video/ffmpeg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/ffmpeg
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.812 2014/12/12 08:44:25 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.813 2014/12/12 09:22:39 aballier Exp $
+
+ 12 Dec 2014; Alexis Ballier <aballier@gentoo.org> ffmpeg-2.5.ebuild,
+ +files/samba.patch:
+ backport upstream patch to build with USE=samba, patch pointed out by
+ jospezial in bug #531714
*ffmpeg-2.2.11 (12 Dec 2014)
diff --git a/media-video/ffmpeg/ffmpeg-2.5.ebuild b/media-video/ffmpeg/ffmpeg-2.5.ebuild
index 9dcd41254d64..1ccbb4679e1e 100644
--- a/media-video/ffmpeg/ffmpeg-2.5.ebuild
+++ b/media-video/ffmpeg/ffmpeg-2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-2.5.ebuild,v 1.1 2014/12/04 09:03:51 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-2.5.ebuild,v 1.2 2014/12/12 09:22:39 aballier Exp $
EAPI="5"
@@ -193,6 +193,7 @@ src_prepare() {
if [[ "${PV%_p*}" != "${PV}" ]] ; then # Snapshot
export revision=git-N-${FFMPEG_REVISION}
fi
+ epatch "${FILESDIR}/samba.patch"
epatch_user
}
diff --git a/media-video/ffmpeg/files/samba.patch b/media-video/ffmpeg/files/samba.patch
new file mode 100644
index 000000000000..f8126a1307ce
--- /dev/null
+++ b/media-video/ffmpeg/files/samba.patch
@@ -0,0 +1,26 @@
+commit 754f4957d7a7e5be0df0e9de1d31aebeecdc4476
+Author: Moritz Barsnick <barsnick@gmx.net>
+Date: Mon Dec 8 16:08:20 2014 +0100
+
+ configure: use use_pkg_config() instead of check_pkg_config() for libsmbclient
+
+ This ensures that the CFLAGS and LDFLAGS are actually applied.
+ Fixes an incorrect change introduced with the clean-up in commit
+ cfcaf6b38e39ed6e788abb1a5a44f23660dce2f6.
+
+ Reviewed-by: Nicolas George <george@nsup.org>
+ Signed-off-by: Michael Niedermayer <michaelni@gmx.at>
+
+diff --git a/configure b/configure
+index 40d5428..0933210 100755
+--- a/configure
++++ b/configure
+@@ -4887,7 +4887,7 @@ enabled libquvi && require_pkg_config libquvi quvi/quvi.h quvi_init
+ enabled librtmp && require_pkg_config librtmp librtmp/rtmp.h RTMP_Socket
+ enabled libschroedinger && require_pkg_config schroedinger-1.0 schroedinger/schro.h schro_init
+ enabled libshine && require_pkg_config shine shine/layer3.h shine_encode_buffer
+-enabled libsmbclient && { check_pkg_config smbclient libsmbclient.h smbc_init ||
++enabled libsmbclient && { use_pkg_config smbclient libsmbclient.h smbc_init ||
+ require smbclient libsmbclient.h smbc_init -lsmbclient; }
+ enabled libsoxr && require libsoxr soxr.h soxr_create -lsoxr
+ enabled libssh && require_pkg_config libssh libssh/sftp.h sftp_init