summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-19 02:23:59 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-19 02:23:59 +0000
commit01ba51b126378518559db6a0188773d918036753 (patch)
tree17862a6c0bbedbffa4bf3957b7c826aa14d56eca /net-analyzer/net-snmp
parentUpdate fortify source handling, and enable cross-compiler warnings with syste... (diff)
downloadgentoo-2-01ba51b126378518559db6a0188773d918036753.tar.gz
gentoo-2-01ba51b126378518559db6a0188773d918036753.tar.bz2
gentoo-2-01ba51b126378518559db6a0188773d918036753.zip
Version bump; remove old. This version closes bug #209667 (disabled ucd-snmp compatibility); bug #328177 (lm_sensors 3 is supported by default now); #425990 (added GPL-2 to LICENSE); should close bug #351051 as well, for the most part; add new init scripts to use the new runscript features; restrict tests (tests that might or might not fail are useless); build in parallel (upstream fixed it); drop USE flags that added no dependencies.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/net-snmp')
-rw-r--r--net-analyzer/net-snmp/ChangeLog15
-rw-r--r--net-analyzer/net-snmp/files/snmpd.init.236
-rw-r--r--net-analyzer/net-snmp/files/snmptrapd.init.215
-rw-r--r--net-analyzer/net-snmp/metadata.xml20
-rw-r--r--net-analyzer/net-snmp/net-snmp-5.4.3-r1.ebuild217
-rw-r--r--net-analyzer/net-snmp/net-snmp-5.5.ebuild210
-rw-r--r--net-analyzer/net-snmp/net-snmp-5.7.2_rc1.ebuild (renamed from net-analyzer/net-snmp/net-snmp-5.6.1.ebuild)135
7 files changed, 132 insertions, 516 deletions
diff --git a/net-analyzer/net-snmp/ChangeLog b/net-analyzer/net-snmp/ChangeLog
index 3cee7357f495..0aa9faa0c24e 100644
--- a/net-analyzer/net-snmp/ChangeLog
+++ b/net-analyzer/net-snmp/ChangeLog
@@ -1,6 +1,19 @@
# ChangeLog for net-analyzer/net-snmp
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/ChangeLog,v 1.228 2012/08/03 11:51:41 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/ChangeLog,v 1.229 2012/08/19 02:23:59 flameeyes Exp $
+
+*net-snmp-5.7.2_rc1 (19 Aug 2012)
+
+ 19 Aug 2012; Diego E. Pettenò <flameeyes@gentoo.org> +files/snmpd.init.2,
+ +files/snmptrapd.init.2, +net-snmp-5.7.2_rc1.ebuild,
+ -net-snmp-5.4.3-r1.ebuild, -net-snmp-5.5.ebuild, -net-snmp-5.6.1.ebuild,
+ metadata.xml:
+ Version bump; remove old. This version closes bug #209667 (disabled ucd-snmp
+ compatibility); bug #328177 (lm_sensors 3 is supported by default now);
+ #425990 (added GPL-2 to LICENSE); should close bug #351051 as well, for the
+ most part; add new init scripts to use the new runscript features; restrict
+ tests (tests that might or might not fail are useless); build in parallel
+ (upstream fixed it); drop USE flags that added no dependencies.
03 Aug 2012; Jeroen Roovers <jer@gentoo.org> files/snmpd.init:
Fix bashishms by Outer Measure (bug #414703).
diff --git a/net-analyzer/net-snmp/files/snmpd.init.2 b/net-analyzer/net-snmp/files/snmpd.init.2
new file mode 100644
index 000000000000..8a8a9312c3fb
--- /dev/null
+++ b/net-analyzer/net-snmp/files/snmpd.init.2
@@ -0,0 +1,36 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/files/snmpd.init.2,v 1.1 2012/08/19 02:23:59 flameeyes Exp $
+
+SNMPD_PIDFILE="${SNMPD_PIDFILE:-/var/run/snmpd.pid}"
+
+extra_started_commands="reload"
+
+command="/usr/sbin/snmpd"
+command_args="-p ${SNMP_PIDFILE} $SNMPD_FLAGS}"
+pidfile="${SNMP_PIDFILE}"
+
+depend() {
+ use logger
+ need net
+}
+
+checkconfig() {
+ if [ ! -e /etc/snmp/snmpd.conf ] ; then
+ eerror "${SVCNAME} requires an /etc/snmp/snmpd.conf configuration file"
+ return 1
+ fi
+}
+
+start_pre() {
+ checkconfig || return 1
+}
+
+reload() {
+ checkconfig || return 1
+
+ ebegin "Reloading ${SVCNAME} configuration"
+ kill -HUP $(cat ${SNMPD_PIDFILE}) 2>&1 > /dev/null
+ eend $?
+}
diff --git a/net-analyzer/net-snmp/files/snmptrapd.init.2 b/net-analyzer/net-snmp/files/snmptrapd.init.2
new file mode 100644
index 000000000000..028ee0c2347d
--- /dev/null
+++ b/net-analyzer/net-snmp/files/snmptrapd.init.2
@@ -0,0 +1,15 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/files/snmptrapd.init.2,v 1.1 2012/08/19 02:23:59 flameeyes Exp $
+
+SNMPTRAPD_PIDFILE="${SNMPTRAPD_PIDFILE:-/var/run/snmptrapd.pid}"
+
+command="/usr/sbin/snmptrapd"
+command_args="-p ${SNMPTRAPD_PIDFILE} ${SNMPTRAPD_FLAGS}"
+pidfile="${SNMPTRAPD_PIDFILE}"
+
+depend() {
+ use logger
+ need net
+}
diff --git a/net-analyzer/net-snmp/metadata.xml b/net-analyzer/net-snmp/metadata.xml
index 71f5b981f990..a5c403f18f18 100644
--- a/net-analyzer/net-snmp/metadata.xml
+++ b/net-analyzer/net-snmp/metadata.xml
@@ -1,14 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>netmon</herd>
- <use>
- <flag name='diskio'>Enable the use of diskio mibs</flag>
- <flag name='elf'>Enable the use of elf utils to check uptime on some systems</flag>
- <flag name='extensible'>build deprecated extensible mib module (extend is successor)</flag>
- <flag name='mfd-rewrites'>Use MFD rewrites of mib modules where available</flag>
- <flag name='rpm'>Enable the rpm snmp probing</flag>
- <flag name='sendmail'>Enable sendmail statistics monitoring</flag>
- <flag name='smux'>Enable the smux MIBS module</flag>
- </use>
+ <herd>netmon</herd>
+ <use>
+ <flag name='diskio'>Enable the use of diskio mibs</flag>
+ <flag name='elf'>Enable the use of elf utils to check uptime on some systems</flag>
+ <flag name='extensible'>build deprecated extensible mib module (extend is successor)</flag>
+ <flag name='mfd-rewrites'>Use MFD rewrites of mib modules where available</flag>
+ <flag name='rpm'>Enable the rpm snmp probing</flag>
+ <flag name='sendmail'>Enable sendmail statistics monitoring</flag>
+ <flag name='smux'>Enable the smux MIBS module</flag>
+ </use>
</pkgmetadata>
diff --git a/net-analyzer/net-snmp/net-snmp-5.4.3-r1.ebuild b/net-analyzer/net-snmp/net-snmp-5.4.3-r1.ebuild
deleted file mode 100644
index 9af3a3ce6619..000000000000
--- a/net-analyzer/net-snmp/net-snmp-5.4.3-r1.ebuild
+++ /dev/null
@@ -1,217 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/net-snmp-5.4.3-r1.ebuild,v 1.1 2012/06/02 20:27:14 tove Exp $
-
-EAPI="3"
-PYTHON_DEPEND="python? 2"
-
-inherit fixheadtails flag-o-matic perl-module python autotools
-
-DESCRIPTION="Software for generating and retrieving SNMP data"
-HOMEPAGE="http://net-snmp.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="as-is BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="bzip2 diskio doc elf extensible ipv6 kernel_linux lm_sensors mfd-rewrites minimal perl python rpm selinux sendmail smux ssl tcpd X zlib"
-
-COMMON="ssl? ( >=dev-libs/openssl-0.9.6d )
- tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
- rpm? (
- app-arch/rpm
- dev-libs/popt
- app-arch/bzip2
- >=sys-libs/zlib-1.1.4
- )
- bzip2? ( app-arch/bzip2 )
- zlib? ( >=sys-libs/zlib-1.1.4 )
- elf? ( dev-libs/elfutils )
- lm_sensors? (
- kernel_linux? ( sys-apps/lm_sensors )
- )
- python? ( dev-python/setuptools )"
-
-RDEPEND="${COMMON}
- perl? (
- X? ( dev-perl/perl-tk )
- !minimal? ( dev-perl/TermReadKey )
- )
- selinux? ( sec-policy/selinux-snmp )"
-
-# Dependency on autoconf due to bug #225893
-DEPEND="${COMMON}
- >=sys-devel/autoconf-2.61-r2
- >=sys-apps/sed-4
- doc? ( app-doc/doxygen )"
-
-pkg_setup() {
- if use python; then
- python_set_active_version 2
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- # lm_sensors-3 support
- if use lm_sensors ; then
- epatch "${FILESDIR}"/${PN}-5.4.1-sensors3.patch \
- "${FILESDIR}"/${PN}-5.4.1-sensors3-version_detect.patch
- fi
-
- # fix access violation in make check
- sed -i -e 's/\(snmpd.*\)-Lf/\1-l/' testing/eval_tools.sh || \
- die "sed eval_tools.sh failed"
- # fix path in fixproc
- sed -i -e 's|\(database_file =.*\)/local\(.*\)$|\1\2|' local/fixproc || \
- die "sed fixproc failed"
-
- if use python ; then
- PYTHON_DIR="$(python_get_sitedir)"
- sed -i -e "s:\(install --basedir=\$\$dir\):\1 --root='${D}':" Makefile.in || \
- die "sed python failed"
- fi
-
- # snmpconf generates config files with proper selinux context
- use selinux && epatch "${FILESDIR}"/${PN}-5.1.2-snmpconf-selinux.patch
-
- # remove CFLAGS from net-snmp-config script (bug #257622):
- sed -i -e 's|@CFLAGS@||g' -e 's|@LDFLAGS@||g' \
- net-snmp-config.in || die "sedding CFLAGS/LDFLAGS failed"
-
- # Respect LDFLAGS
- sed -i Makefile.top \
- -e '/^LIB_LD_CMD/{s|$(CFLAGS)|& $(LDFLAGS)|g}' \
- || die "sed LDFLAGS failed"
-
- # Fix version number:
- sed -i -e "s:NetSnmpVersionInfo = \".*\":NetSnmpVersionInfo = \"${PV}\":" \
- snmplib/snmp_version.c || die "sedding version failed"
-
- eautoreconf
-
- ht_fix_all
-}
-
-src_configure() {
- strip-flags
-
- local mibs="host ucd-snmp/dlmod"
- use diskio && mibs="${mibs} ucd-snmp/diskio"
- use extensible && mibs="${mibs} ucd-snmp/extensible"
- use lm_sensors && mibs="${mibs} ucd-snmp/lmsensorsMib"
- use sendmail && mibs="${mibs} mibII/mta_sendmail"
- use smux && mibs="${mibs} smux"
-
- local myconf="$(use_enable ipv6) \
- $(use_enable mfd-rewrites) \
- $(use_enable perl embedded-perl) \
- $(use_enable !ssl internal-md5) \
- $(use_with elf) \
- $(use_with perl perl-modules INSTALLDIRS=vendor ) \
- $(use_with python python-modules) \
- $(use_with ssl openssl) \
- $(use_with tcpd libwrap)"
- if use rpm ; then
- myconf="${myconf} \
- --with-rpm \
- --with-bzip2 \
- --with-zlib"
- else
- myconf="${myconf} \
- --without-rpm \
- $(use_with bzip2) \
- $(use_with zlib)"
- fi
-
- econf \
- --with-install-prefix="${D}" \
- --with-sys-location="Unknown" \
- --with-sys-contact="root@Unknown" \
- --with-default-snmp-version="3" \
- --with-mib-modules="${mibs}" \
- --with-logfile="/var/log/net-snmpd.log" \
- --with-persistent-directory="/var/lib/net-snmp" \
- --enable-ucd-snmp-compatibility \
- --enable-shared \
- --with-ldflags="${LDFLAGS}" \
- --enable-as-needed \
- ${myconf}
-}
-
-src_compile() {
- emake -j1 OTHERLDFLAGS="${LDFLAGS}" || die "emake failed"
-
- if use doc ; then
- einfo "Building HTML Documentation"
- make docsdox || die "failed to build docs"
- fi
-}
-
-src_test() {
- cd testing
- if ! make test ; then
- echo
- einfo "Don't be alarmed if a few tests FAIL."
- einfo "This could happen for several reasons:"
- einfo " - You don't already have a working configuration."
- einfo " - Your ethernet interface isn't properly configured."
- echo
- fi
-}
-
-src_install () {
- # bug #317965
- emake -j1 DESTDIR="${D}" install || die "make install failed"
-
- if use perl ; then
- fixlocalpod
- use X || rm -f "${D}"/usr/bin/tkmib
- else
- rm -f "${D}"/usr/bin/mib2c "${D}"/usr/bin/snmpcheck "${D}"/usr/bin/tkmib
- fi
-
- dodoc AGENT.txt ChangeLog FAQ INSTALL NEWS PORTING README* TODO || die
- newdoc EXAMPLE.conf.def EXAMPLE.conf || die
-
- use doc && { dohtml docs/html/* || die ; }
-
- keepdir /etc/snmp /var/lib/net-snmp
-
- newinitd "${FILESDIR}"/snmpd.init snmpd || die
- newconfd "${FILESDIR}"/snmpd.conf snmpd || die
-
- newinitd "${FILESDIR}"/snmptrapd.init snmptrapd || die
- newconfd "${FILESDIR}"/snmptrapd.conf snmptrapd || die
-
- # Remove everything not required for an agent.
- # Keep only the snmpd, snmptrapd, MIBs, headers and libraries.
- if use minimal; then
- elog "USE='minimal' is set. Removing excess/non-minimal components."
- rm -rf
- "${D}"/usr/bin/{encode_keychange,snmp{get,getnext,set,usm,walk,bulkwalk,table,trap,bulkget,translate,status,delta,test,df,vacm,netstat,inform,snmpcheck}}
- rm -rf "${D}"/usr/share/snmp/snmpconf-data "${D}"/usr/share/snmp/*.conf
- rm -rf "${D}"/usr/bin/{fixproc,traptoemail} "${D}"/usr/bin/snmpc{heck,onf}
- find "${D}" -name '*.pl' -exec rm -f '{}' \;
- use ipv6 || rm -rf "${D}"/usr/share/snmp/mibs/IPV6*
- fi
-
- # bug 113788, install example config
- insinto /etc/snmp
- newins "${S}"/EXAMPLE.conf snmpd.conf.example || die
-}
-
-pkg_postinst() {
- if use python; then
- python_mod_optimize netsnmp
- fi
-
- elog "An example configuration file has been installed in"
- elog "/etc/snmp/snmpd.conf.example."
-}
-
-pkg_postrm() {
- if use python; then
- python_mod_cleanup netsnmp
- fi
-}
diff --git a/net-analyzer/net-snmp/net-snmp-5.5.ebuild b/net-analyzer/net-snmp/net-snmp-5.5.ebuild
deleted file mode 100644
index 2a2dc3655e93..000000000000
--- a/net-analyzer/net-snmp/net-snmp-5.5.ebuild
+++ /dev/null
@@ -1,210 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/net-snmp-5.5.ebuild,v 1.7 2012/06/02 20:27:14 tove Exp $
-
-EAPI="3"
-PYTHON_DEPEND="python? 2"
-
-inherit fixheadtails flag-o-matic perl-module python
-
-DESCRIPTION="Software for generating and retrieving SNMP data"
-HOMEPAGE="http://net-snmp.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="as-is BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="bzip2 diskio doc elf extensible ipv6 kernel_linux mfd-rewrites minimal perl python rpm selinux sendmail smux ssl tcpd X zlib"
-
-COMMON="ssl? ( >=dev-libs/openssl-0.9.6d )
- tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
- rpm? (
- app-arch/rpm
- dev-libs/popt
- app-arch/bzip2
- >=sys-libs/zlib-1.1.4
- )
- bzip2? ( app-arch/bzip2 )
- zlib? ( >=sys-libs/zlib-1.1.4 )
- elf? ( dev-libs/elfutils )
- python? ( dev-python/setuptools )"
-
-RDEPEND="${COMMON}
- perl? (
- X? ( dev-perl/perl-tk )
- !minimal? ( dev-perl/TermReadKey )
- )
- selinux? ( sec-policy/selinux-snmp )"
-
-# Dependency on autoconf due to bug #225893
-DEPEND="${COMMON}
- >=sys-devel/autoconf-2.61-r2
- >=sys-apps/sed-4
- doc? ( app-doc/doxygen )"
-
-pkg_setup() {
- if use python; then
- python_set_active_version 2
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- # fix access violation in make check
- sed -i \
- -e 's/\(snmpd.*\)-Lf/\1-l/' \
- testing/eval_tools.sh || die "sed eval_tools.sh failed"
- # fix path in fixproc
- sed -i \
- -e 's|\(database_file =.*\)/local\(.*\)$|\1\2|' \
- local/fixproc || die "sed fixproc failed"
-
- if use python ; then
- PYTHON_DIR="$(python_get_sitedir)"
- sed -i -e "s:\(install --basedir=\$\$dir\):\1 --root='${D}':" Makefile.in || \
- die "sed python failed"
- fi
-
- # snmpconf generates config files with proper selinux context
- use selinux && epatch "${FILESDIR}"/${PN}-5.1.2-snmpconf-selinux.patch
-
- # remove CFLAGS from net-snmp-config script (bug #257622):
- sed -i \
- -e 's|@CFLAGS@ ||g' \
- -e 's|@LDFLAGS@ ||g' \
- net-snmp-config.in || die "sedding CFLAGS failed"
-
- # Respect LDFLAGS
- sed -i Makefile.top \
- -e '/^LIB_LD_CMD/{s|$(CFLAGS)|& $(LDFLAGS)|g}' \
- || die "sed LDFLAGS failed"
-
- # Fix version number:
- sed -i \
- -e "s|PACKAGE_VERSION|\"${PV}\"|g" \
- snmplib/snmp_version.c || die "sedding version failed"
-
- ht_fix_all
-}
-
-src_configure() {
- strip-flags
-
- local mibs="host ucd-snmp/dlmod"
- use diskio && mibs="${mibs} ucd-snmp/diskio"
- use extensible && mibs="${mibs} ucd-snmp/extensible"
- use sendmail && mibs="${mibs} mibII/mta_sendmail"
- use smux && mibs="${mibs} smux"
-
- local myconf="$(use_enable ipv6) \
- $(use_enable mfd-rewrites) \
- $(use_enable perl embedded-perl) \
- $(use_enable !ssl internal-md5) \
- $(use_with elf) \
- $(use_with perl perl-modules INSTALLDIRS=vendor ) \
- $(use_with python python-modules) \
- $(use_with ssl openssl) \
- $(use_with tcpd libwrap)"
- if use rpm ; then
- myconf="${myconf} \
- --with-rpm \
- --with-bzip2 \
- --with-zlib"
- else
- myconf="${myconf} \
- --without-rpm \
- $(use_with bzip2) \
- $(use_with zlib)"
- fi
-
- econf \
- --with-install-prefix="${D}" \
- --with-sys-location="Unknown" \
- --with-sys-contact="root@Unknown" \
- --with-default-snmp-version="3" \
- --with-mib-modules="${mibs}" \
- --with-logfile="/var/log/net-snmpd.log" \
- --with-persistent-directory="/var/lib/net-snmp" \
- --enable-ucd-snmp-compatibility \
- --enable-shared \
- --with-ldflags="${LDFLAGS}" \
- --enable-as-needed \
- ${myconf}
-}
-
-src_compile() {
- emake -j1 OTHERLDFLAGS="${LDFLAGS}" || die "emake failed"
-
- if use doc ; then
- einfo "Building HTML Documentation"
- make docsdox || die "failed to build docs"
- fi
-}
-
-src_test() {
- cd testing
- if ! make test ; then
- echo
- einfo "Don't be alarmed if a few tests FAIL."
- einfo "This could happen for several reasons:"
- einfo " - You don't already have a working configuration."
- einfo " - Your ethernet interface isn't properly configured."
- echo
- fi
-}
-
-src_install () {
- # bug #317965
- emake -j1 DESTDIR="${D}" install || die "make install failed"
-
- if use perl ; then
- fixlocalpod
- use X || rm -f "${D}"/usr/bin/tkmib
- else
- rm -f "${D}"/usr/bin/mib2c "${D}"/usr/bin/snmpcheck "${D}"/usr/bin/tkmib
- fi
-
- dodoc AGENT.txt ChangeLog FAQ INSTALL NEWS PORTING README* TODO || die
- newdoc EXAMPLE.conf.def EXAMPLE.conf || die
-
- use doc && { dohtml docs/html/* || die ; }
-
- keepdir /etc/snmp /var/lib/net-snmp
-
- newinitd "${FILESDIR}"/snmpd.init snmpd || die
- newconfd "${FILESDIR}"/snmpd.conf snmpd || die
-
- newinitd "${FILESDIR}"/snmptrapd.init snmptrapd || die
- newconfd "${FILESDIR}"/snmptrapd.conf snmptrapd || die
-
- # Remove everything not required for an agent.
- # Keep only the snmpd, snmptrapd, MIBs, headers and libraries.
- if use minimal; then
- elog "USE='minimal' is set. Removing excess/non-minimal components."
- rm -rf
- "${D}"/usr/bin/{encode_keychange,snmp{get,getnext,set,usm,walk,bulkwalk,table,trap,bulkget,translate,status,delta,test,df,vacm,netstat,inform,snmpcheck}}
- rm -rf "${D}"/usr/share/snmp/snmpconf-data "${D}"/usr/share/snmp/*.conf
- rm -rf "${D}"/usr/bin/{fixproc,traptoemail} "${D}"/usr/bin/snmpc{heck,onf}
- find "${D}" -name '*.pl' -exec rm -f '{}' \;
- use ipv6 || rm -rf "${D}"/usr/share/snmp/mibs/IPV6*
- fi
-
- # bug 113788, install example config
- insinto /etc/snmp
- newins "${S}"/EXAMPLE.conf snmpd.conf.example || die
-}
-
-pkg_postinst() {
- if use python; then
- python_mod_optimize netsnmp
- fi
-
- elog "An example configuration file has been installed in"
- elog "/etc/snmp/snmpd.conf.example."
-}
-
-pkg_postrm() {
- if use python; then
- python_mod_cleanup netsnmp
- fi
-}
diff --git a/net-analyzer/net-snmp/net-snmp-5.6.1.ebuild b/net-analyzer/net-snmp/net-snmp-5.7.2_rc1.ebuild
index 31997a39d895..e2745773880e 100644
--- a/net-analyzer/net-snmp/net-snmp-5.6.1.ebuild
+++ b/net-analyzer/net-snmp/net-snmp-5.7.2_rc1.ebuild
@@ -1,40 +1,44 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/net-snmp-5.6.1.ebuild,v 1.3 2012/06/02 20:27:14 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/net-snmp-5.7.2_rc1.ebuild,v 1.1 2012/08/19 02:23:59 flameeyes Exp $
-EAPI="3"
+EAPI=4
PYTHON_DEPEND="python? 2"
-inherit fixheadtails flag-o-matic perl-module python
+inherit perl-module python
+
+MY_P="${P/_rc/.rc}"
DESCRIPTION="Software for generating and retrieving SNMP data"
HOMEPAGE="http://net-snmp.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-LICENSE="as-is BSD"
+# GPL-2 for the init scripts
+LICENSE="as-is BSD GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="bzip2 diskio doc elf extensible ipv6 kernel_linux mfd-rewrites minimal perl python rpm selinux sendmail smux ssl tcpd X zlib"
+IUSE="bzip2 doc elf ipv6 mfd-rewrites minimal perl python rpm selinux ssl tcpd X zlib lm_sensors"
COMMON="ssl? ( >=dev-libs/openssl-0.9.6d )
tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
rpm? (
app-arch/rpm
dev-libs/popt
- app-arch/bzip2
- >=sys-libs/zlib-1.1.4
)
bzip2? ( app-arch/bzip2 )
zlib? ( >=sys-libs/zlib-1.1.4 )
elf? ( dev-libs/elfutils )
- python? ( dev-python/setuptools )"
+ python? ( dev-python/setuptools )
+ sys-apps/pciutils
+ lm_sensors? ( sys-apps/lm_sensors )"
RDEPEND="${COMMON}
perl? (
X? ( dev-perl/perl-tk )
!minimal? ( dev-perl/TermReadKey )
)
- selinux? ( sec-policy/selinux-snmp )"
+ selinux? ( sec-policy/selinux-snmp )
+ sys-apps/openrc"
# Dependency on autoconf due to bug #225893
DEPEND="${COMMON}
@@ -42,6 +46,12 @@ DEPEND="${COMMON}
>=sys-apps/sed-4
doc? ( app-doc/doxygen )"
+REQUIRED_USE="rpm? ( bzip2 zlib )"
+
+RESTRICT=test
+
+S="${WORKDIR}/${MY_P}"
+
pkg_setup() {
if use python; then
python_set_active_version 2
@@ -54,6 +64,7 @@ src_prepare() {
sed -i \
-e 's/\(snmpd.*\)-Lf/\1-l/' \
testing/fulltests/support/simple_eval_tools.sh || die "sed eval_tools.sh failed"
+
# fix path in fixproc
sed -i \
-e 's|\(database_file =.*\)/local\(.*\)$|\1\2|' \
@@ -83,39 +94,12 @@ src_prepare() {
sed -i \
-e "s|PACKAGE_VERSION|\"${PV}\"|g" \
snmplib/snmp_version.c || die "sedding version failed"
-
- ht_fix_all
}
src_configure() {
- strip-flags
-
- local mibs="host ucd-snmp/dlmod"
- use diskio && mibs="${mibs} ucd-snmp/diskio"
- use extensible && mibs="${mibs} ucd-snmp/extensible"
- use sendmail && mibs="${mibs} mibII/mta_sendmail"
- use smux && mibs="${mibs} smux"
-
- local myconf="$(use_enable ipv6) \
- $(use_enable mfd-rewrites) \
- $(use_enable perl embedded-perl) \
- $(use_enable !ssl internal-md5) \
- $(use_with elf) \
- $(use_with perl perl-modules INSTALLDIRS=vendor ) \
- $(use_with python python-modules) \
- $(use_with ssl openssl) \
- $(use_with tcpd libwrap)"
- if use rpm ; then
- myconf="${myconf} \
- --with-rpm \
- --with-bzip2 \
- --with-zlib"
- else
- myconf="${myconf} \
- --without-rpm \
- $(use_with bzip2) \
- $(use_with zlib)"
- fi
+ # keep this in the same line, configure.ac arguments are passed down to config.h
+ local mibs="host ucd-snmp/dlmod ucd-snmp/diskio ucd-snmp/extensible mibII/mta_sendmail smux"
+ use lm_sensors && mibs="${mibs} ucd-snmp/lmsensorsMib"
econf \
--with-install-prefix="${D}" \
@@ -125,37 +109,35 @@ src_configure() {
--with-mib-modules="${mibs}" \
--with-logfile="/var/log/net-snmpd.log" \
--with-persistent-directory="/var/lib/net-snmp" \
- --enable-ucd-snmp-compatibility \
- --enable-shared \
+ --disable-ucd-snmp-compatibility \
+ --enable-shared --disable-static \
--with-ldflags="${LDFLAGS}" \
- --enable-as-needed \
- ${myconf}
+ $(use_enable ipv6) \
+ $(use_enable mfd-rewrites) \
+ $(use_enable perl embedded-perl) \
+ $(use_enable !ssl internal-md5) \
+ $(use_with elf) \
+ $(use_with perl perl-modules INSTALLDIRS=vendor) \
+ $(use_with python python-modules) \
+ $(use_with ssl openssl) \
+ $(use_with tcpd libwrap) \
+ $(use_with bzip2) \
+ $(use_with zlib) \
+ $(use_with rpm)
}
src_compile() {
- emake -j1 OTHERLDFLAGS="${LDFLAGS}" || die "emake failed"
+ emake OTHERLDFLAGS="${LDFLAGS}"
if use doc ; then
einfo "Building HTML Documentation"
- make docsdox || die "failed to build docs"
- fi
-}
-
-src_test() {
- cd testing
- if ! make test ; then
- echo
- einfo "Don't be alarmed if a few tests FAIL."
- einfo "This could happen for several reasons:"
- einfo " - You don't already have a working configuration."
- einfo " - Your ethernet interface isn't properly configured."
- echo
+ emake docsdox
fi
}
src_install () {
# bug #317965
- emake -j1 DESTDIR="${D}" install || die "make install failed"
+ emake -j1 DESTDIR="${D}" install
if use perl ; then
fixlocalpod
@@ -164,34 +146,31 @@ src_install () {
rm -f "${D}"/usr/bin/mib2c "${D}"/usr/bin/snmpcheck "${D}"/usr/bin/tkmib
fi
- dodoc AGENT.txt ChangeLog FAQ INSTALL NEWS PORTING README* TODO || die
- newdoc EXAMPLE.conf.def EXAMPLE.conf || die
+ dodoc AGENT.txt ChangeLog FAQ INSTALL NEWS PORTING README* TODO
+ newdoc EXAMPLE.conf.def EXAMPLE.conf
- use doc && { dohtml docs/html/* || die ; }
+ use doc && dohtml docs/html/*
- keepdir /etc/snmp /var/lib/net-snmp
+ keepdir /var/lib/net-snmp
- newinitd "${FILESDIR}"/snmpd.init snmpd || die
- newconfd "${FILESDIR}"/snmpd.conf snmpd || die
+ newinitd "${FILESDIR}"/snmpd.init.2 snmpd
+ newconfd "${FILESDIR}"/snmpd.conf snmpd
- newinitd "${FILESDIR}"/snmptrapd.init snmptrapd || die
- newconfd "${FILESDIR}"/snmptrapd.conf snmptrapd || die
+ newinitd "${FILESDIR}"/snmptrapd.init.2 snmptrapd
+ newconfd "${FILESDIR}"/snmptrapd.conf snmptrapd
+
+ insinto /etc/snmp
+ newins "${S}"/EXAMPLE.conf snmpd.conf.example
# Remove everything not required for an agent.
# Keep only the snmpd, snmptrapd, MIBs, headers and libraries.
if use minimal; then
- elog "USE='minimal' is set. Removing excess/non-minimal components."
- rm -rf
- "${D}"/usr/bin/{encode_keychange,snmp{get,getnext,set,usm,walk,bulkwalk,table,trap,bulkget,translate,status,delta,test,df,vacm,netstat,inform,snmpcheck}}
- rm -rf "${D}"/usr/share/snmp/snmpconf-data "${D}"/usr/share/snmp/*.conf
- rm -rf "${D}"/usr/bin/{fixproc,traptoemail} "${D}"/usr/bin/snmpc{heck,onf}
- find "${D}" -name '*.pl' -exec rm -f '{}' \;
- use ipv6 || rm -rf "${D}"/usr/share/snmp/mibs/IPV6*
+ rm -rf \
+ "${D}"/usr/bin/{encode_keychange,snmp{get,getnext,set,usm,walk,bulkwalk,table,trap,bulkget,translate,status,delta,test,df,vacm,netstat,inform,check,conf},fixproc,traptoemail} \
+ "${D}"/usr/share/snmp/snmpconf-data \
+ "${D}"/usr/share/snmp/*.conf \
+ "${D}"/**/*.pl
fi
-
- # bug 113788, install example config
- insinto /etc/snmp
- newins "${S}"/EXAMPLE.conf snmpd.conf.example || die
}
pkg_postinst() {