summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-12-06 14:43:54 +0000
committerPeter Volkov <pva@gentoo.org>2008-12-06 14:43:54 +0000
commitd41eaf858bfdbc3eb420df53582f7b3d1df16c72 (patch)
tree3e9cc056c2342f57be4cb9e14bba34fc929fc6e8 /net-firewall
parentinherit toolchain-funcs (diff)
downloadgentoo-2-d41eaf858bfdbc3eb420df53582f7b3d1df16c72.tar.gz
gentoo-2-d41eaf858bfdbc3eb420df53582f7b3d1df16c72.tar.bz2
gentoo-2-d41eaf858bfdbc3eb420df53582f7b3d1df16c72.zip
Fixed build problem with 2.6.26, bug #246395.
(Portage version: 2.2_rc16/cvs/Linux 2.6.26-openvz.git-89451f9 i686)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/iptables/ChangeLog6
-rw-r--r--net-firewall/iptables/files/iptables-1.4.0-2.6.26-kernel.patch12
-rw-r--r--net-firewall/iptables/iptables-1.4.0-r1.ebuild3
3 files changed, 19 insertions, 2 deletions
diff --git a/net-firewall/iptables/ChangeLog b/net-firewall/iptables/ChangeLog
index 61328e59567e..540cfd540871 100644
--- a/net-firewall/iptables/ChangeLog
+++ b/net-firewall/iptables/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-firewall/iptables
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.182 2008/11/27 18:13:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.183 2008/12/06 14:43:54 pva Exp $
+
+ 06 Dec 2008; Peter Volkov <pva@gentoo.org>
+ +files/iptables-1.4.0-2.6.26-kernel.patch, iptables-1.4.0-r1.ebuild:
+ Fixed build problem with 2.6.26, bug #246395.
27 Nov 2008; Mike Frysinger <vapier@gentoo.org> iptables-1.4.2-r1.ebuild:
Drop linux-info eclass include #248066 by Laurence Withers.
diff --git a/net-firewall/iptables/files/iptables-1.4.0-2.6.26-kernel.patch b/net-firewall/iptables/files/iptables-1.4.0-2.6.26-kernel.patch
new file mode 100644
index 000000000000..1e0346856c99
--- /dev/null
+++ b/net-firewall/iptables/files/iptables-1.4.0-2.6.26-kernel.patch
@@ -0,0 +1,12 @@
+=== modified file 'extensions/libxt_sctp.c'
+--- extensions/libxt_sctp.c 2008-11-11 13:32:29 +0000
++++ extensions/libxt_sctp.c 2008-11-11 13:32:40 +0000
+@@ -13,6 +13,7 @@
+ #include <getopt.h>
+ #include <netdb.h>
+ #include <ctype.h>
++#include <stdbool.h>
+
+ #include <xtables.h>
+
+
diff --git a/net-firewall/iptables/iptables-1.4.0-r1.ebuild b/net-firewall/iptables/iptables-1.4.0-r1.ebuild
index 637b462fe820..afbe5a4ebbe6 100644
--- a/net-firewall/iptables/iptables-1.4.0-r1.ebuild
+++ b/net-firewall/iptables/iptables-1.4.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.4.0-r1.ebuild,v 1.13 2008/08/17 14:15:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.4.0-r1.ebuild,v 1.14 2008/12/06 14:43:54 pva Exp $
inherit eutils toolchain-funcs linux-info
@@ -67,6 +67,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-dev-files.patch
epatch "${FILESDIR}"/${P}-in6-glibc-2.8.patch #225505
+ epatch "${FILESDIR}"/${P}-2.6.26-kernel.patch #246395
# this provide's grsec's stealth match
EPATCH_OPTS="-p0" \