summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-05-27 01:24:18 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-05-27 01:24:18 +0000
commit1d712a95552f976bc7e17be9608a8f3d44520d7f (patch)
tree629053d1298de762c01fe3875fdf81c6b4bf697b /net-ftp/yafc
parent another gtk2 theme engine (diff)
downloadgentoo-2-1d712a95552f976bc7e17be9608a8f3d44520d7f.tar.gz
gentoo-2-1d712a95552f976bc7e17be9608a8f3d44520d7f.tar.bz2
gentoo-2-1d712a95552f976bc7e17be9608a8f3d44520d7f.zip
New Package. Fixes #2754
Diffstat (limited to 'net-ftp/yafc')
-rw-r--r--net-ftp/yafc/ChangeLog13
-rw-r--r--net-ftp/yafc/files/digest-yafc-0.7.2-r11
-rw-r--r--net-ftp/yafc/yafc-0.7.2-r1.ebuild27
3 files changed, 41 insertions, 0 deletions
diff --git a/net-ftp/yafc/ChangeLog b/net-ftp/yafc/ChangeLog
new file mode 100644
index 000000000000..87fd45ffbffd
--- /dev/null
+++ b/net-ftp/yafc/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for net-ftp/yafc
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/yafc/ChangeLog,v 1.1 2002/05/27 01:24:18 rphillips Exp $
+
+*yafc-0.7.2-r1 (26 May 2002)
+
+ 26 May 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/net-ftp/yafc/files/digest-yafc-0.7.2-r1 b/net-ftp/yafc/files/digest-yafc-0.7.2-r1
new file mode 100644
index 000000000000..eb052933f5ed
--- /dev/null
+++ b/net-ftp/yafc/files/digest-yafc-0.7.2-r1
@@ -0,0 +1 @@
+MD5 591d9075dd62bde501995dd034cac068 yafc-0.7.2.tar.bz2 236426
diff --git a/net-ftp/yafc/yafc-0.7.2-r1.ebuild b/net-ftp/yafc/yafc-0.7.2-r1.ebuild
new file mode 100644
index 000000000000..1ffd7852fe34
--- /dev/null
+++ b/net-ftp/yafc/yafc-0.7.2-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/yafc/yafc-0.7.2-r1.ebuild,v 1.1 2002/05/27 01:24:18 rphillips Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Console ftp client with a lot of nifty features"
+SRC_URI="ftp://ftp.sourceforge.net/pub/sourceforge/yafc/yafc-0.7.2.tar.bz2"
+HOMEPAGE="http://yafc.sourceforge.net/"
+LICENSE="GPL-2"
+DEPEND="readline? ( >=sys-libs/readline-4.1-r4 )"
+
+use readline || myconf="--without-readline"
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${myconf} || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+}
+