summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-10-10 15:31:40 +0000
committerJeroen Roovers <jer@gentoo.org>2014-10-10 15:31:40 +0000
commitd510bdf9748677ff06d12479ee6c377ffadbe6f1 (patch)
tree9d26741bdb6618dd3769afc1326330308cdd8780 /net-ftp
parentEAPI bump. Install doc/ even with USE=-doc so that gnulib-tool can use it. Mi... (diff)
downloadgentoo-2-d510bdf9748677ff06d12479ee6c377ffadbe6f1.tar.gz
gentoo-2-d510bdf9748677ff06d12479ee6c377ffadbe6f1.tar.bz2
gentoo-2-d510bdf9748677ff06d12479ee6c377ffadbe6f1.zip
Add live ebuild now that dev-libs/gnulib is fixed.
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/lftp/ChangeLog8
-rw-r--r--net-ftp/lftp/files/lftp-4.5.5-am_config_header.patch11
-rw-r--r--net-ftp/lftp/lftp-4.5.5.20141003.ebuild5
-rw-r--r--net-ftp/lftp/lftp-9999.ebuild88
4 files changed, 109 insertions, 3 deletions
diff --git a/net-ftp/lftp/ChangeLog b/net-ftp/lftp/ChangeLog
index fd2d7dca6612..648ad974ae63 100644
--- a/net-ftp/lftp/ChangeLog
+++ b/net-ftp/lftp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-ftp/lftp
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.486 2014/10/10 10:56:00 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.487 2014/10/10 15:31:40 jer Exp $
+
+*lftp-9999 (10 Oct 2014)
+
+ 10 Oct 2014; Jeroen Roovers <jer@gentoo.org> lftp-4.5.5.20141003.ebuild,
+ +lftp-9999.ebuild, +files/lftp-4.5.5-am_config_header.patch:
+ Add live ebuild now that dev-libs/gnulib is fixed.
10 Oct 2014; Agostino Sarubbo <ago@gentoo.org> lftp-4.5.5.ebuild:
Stable for x86, wrt bug #523654
diff --git a/net-ftp/lftp/files/lftp-4.5.5-am_config_header.patch b/net-ftp/lftp/files/lftp-4.5.5-am_config_header.patch
new file mode 100644
index 000000000000..28a9e80504a5
--- /dev/null
+++ b/net-ftp/lftp/files/lftp-4.5.5-am_config_header.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -5,7 +5,7 @@
+ AC_CONFIG_MACRO_DIR([m4])
+ AC_CONFIG_LIBOBJ_DIR([lib])
+ AC_CONFIG_SRCDIR([src/ftpclass.cc])
+-AM_CONFIG_HEADER([lib/config.h])
++AC_CONFIG_HEADERS([lib/config.h])
+ AM_INIT_AUTOMAKE
+
+ dnl This doesn't *require* GNU extensions; it merely enables them if
diff --git a/net-ftp/lftp/lftp-4.5.5.20141003.ebuild b/net-ftp/lftp/lftp-4.5.5.20141003.ebuild
index 48350bef1ead..15bebe99a848 100644
--- a/net-ftp/lftp/lftp-4.5.5.20141003.ebuild
+++ b/net-ftp/lftp/lftp-4.5.5.20141003.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-4.5.5.20141003.ebuild,v 1.1 2014/10/07 07:15:36 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-4.5.5.20141003.ebuild,v 1.2 2014/10/10 15:31:40 jer Exp $
EAPI=5
inherit autotools eutils libtool
@@ -58,7 +58,8 @@ src_prepare() {
epatch \
"${FILESDIR}"/${PN}-4.0.2.91-lafile.patch \
"${FILESDIR}"/${PN}-4.3.8-gets.patch \
- "${FILESDIR}"/${PN}-4.5.3-autopoint.patch
+ "${FILESDIR}"/${PN}-4.5.3-autopoint.patch \
+ "${FILESDIR}"/${PN}-4.5.5-nls-socks.patch
sed -i configure.ac -e 's|^AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' || die
eautoreconf
diff --git a/net-ftp/lftp/lftp-9999.ebuild b/net-ftp/lftp/lftp-9999.ebuild
new file mode 100644
index 000000000000..b1870be31e75
--- /dev/null
+++ b/net-ftp/lftp/lftp-9999.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-9999.ebuild,v 1.1 2014/10/10 15:31:40 jer Exp $
+
+EAPI=5
+inherit autotools eutils git-r3 libtool
+
+DESCRIPTION="A sophisticated ftp/sftp/http/https/torrent client and file transfer program"
+HOMEPAGE="http://lftp.yar.ru/"
+EGIT_REPO_URI="https://github.com/lavv17/lftp"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+
+IUSE="convert-mozilla-cookies +gnutls nls openssl socks5 +ssl verify-file"
+LFTP_LINGUAS=( cs de es fr it ja ko pl pt_BR ru uk zh_CN zh_HK zh_TW )
+IUSE+=" ${LFTP_LINGUAS[@]/#/linguas_}"
+
+REQUIRED_USE="
+ ssl? ( ^^ ( openssl gnutls ) )
+"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.1
+ >=sys-libs/readline-5.1
+ dev-libs/expat
+ sys-libs/zlib
+ convert-mozilla-cookies? ( dev-perl/DBI )
+ socks5? (
+ >=net-proxy/dante-1.1.12
+ virtual/pam
+ )
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.2.3 )
+ openssl? ( >=dev-libs/openssl-0.9.6 )
+ )
+ verify-file? (
+ dev-perl/string-crc32
+ virtual/perl-Digest-MD5
+ )
+"
+
+DEPEND="
+ ${RDEPEND}
+ dev-libs/gnulib
+ =sys-devel/libtool-2*
+ app-arch/xz-utils
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig
+"
+
+DOCS=(
+ BUGS ChangeLog FAQ FEATURES MIRRORS NEWS README README.debug-levels
+ README.dnssec README.modules THANKS TODO
+)
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-4.0.2.91-lafile.patch \
+ "${FILESDIR}"/${PN}-4.5.3-autopoint.patch \
+ "${FILESDIR}"/${PN}-4.5.5-am_config_header.patch
+
+ gnulib-tool --update || die
+
+ eautoreconf
+ elibtoolize # for Darwin bundles
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_with gnutls) \
+ $(use_with openssl openssl "${EPREFIX}"/usr) \
+ $(use_with socks5 socksdante "${EPREFIX}"/usr) \
+ --enable-packager-mode \
+ --sysconfdir="${EPREFIX}"/etc/${PN} \
+ --with-modules \
+ --without-included-regex
+}
+
+src_install() {
+ default
+ local script
+ for script in {convert-mozilla-cookies,verify-file}; do
+ use ${script} || { rm "${ED}"/usr/share/${PN}/${script} || die ;}
+ done
+}