summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2006-07-10 23:25:01 +0000
committerDaniel Black <dragonheart@gentoo.org>2006-07-10 23:25:01 +0000
commitceec642343cccd8f96e1d69f53ae88b9a2bf6f05 (patch)
tree87f9102ff20b1edfa4edde0f3be548b2be7681e8 /net-im
parentMark 0.30 stable on ia64 (diff)
downloadgentoo-2-ceec642343cccd8f96e1d69f53ae88b9a2bf6f05.tar.gz
gentoo-2-ceec642343cccd8f96e1d69f53ae88b9a2bf6f05.tar.bz2
gentoo-2-ceec642343cccd8f96e1d69f53ae88b9a2bf6f05.zip
version bump dedicated to Flameeyes
(Portage version: 2.1.1_pre2-r6)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/twinkle/ChangeLog8
-rw-r--r--net-im/twinkle/files/digest-twinkle-0.8.13
-rw-r--r--net-im/twinkle/twinkle-0.8.1.ebuild49
-rw-r--r--net-im/twinkle/twinkle-0.8.ebuild7
4 files changed, 64 insertions, 3 deletions
diff --git a/net-im/twinkle/ChangeLog b/net-im/twinkle/ChangeLog
index 025b62a47fe2..339ecac15067 100644
--- a/net-im/twinkle/ChangeLog
+++ b/net-im/twinkle/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/twinkle
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/twinkle/ChangeLog,v 1.15 2006/07/06 05:24:37 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/twinkle/ChangeLog,v 1.16 2006/07/10 23:25:01 dragonheart Exp $
+
+*twinkle-0.8.1 (10 Jul 2006)
+
+ 10 Jul 2006; Daniel Black <dragonheart@gentoo.org> twinkle-0.8.ebuild,
+ +twinkle-0.8.1.ebuild:
+ version bump dedicated to Flameeyes
*twinkle-0.8 (06 Jul 2006)
diff --git a/net-im/twinkle/files/digest-twinkle-0.8.1 b/net-im/twinkle/files/digest-twinkle-0.8.1
new file mode 100644
index 000000000000..c36f3c7b9f12
--- /dev/null
+++ b/net-im/twinkle/files/digest-twinkle-0.8.1
@@ -0,0 +1,3 @@
+MD5 245ffd3b4a6f968d8f80d42f6aad079c twinkle-0.8.1.tar.gz 982496
+RMD160 7637d322355bae3608f5fc7e8879f2720fa4520b twinkle-0.8.1.tar.gz 982496
+SHA256 a1d7df3f6e6ef758028f7f30982e434c513cce4ac4cd759d76dfd859a93bc3b3 twinkle-0.8.1.tar.gz 982496
diff --git a/net-im/twinkle/twinkle-0.8.1.ebuild b/net-im/twinkle/twinkle-0.8.1.ebuild
new file mode 100644
index 000000000000..33f8ea4bf8a4
--- /dev/null
+++ b/net-im/twinkle/twinkle-0.8.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/twinkle/twinkle-0.8.1.ebuild,v 1.1 2006/07/10 23:25:01 dragonheart Exp $
+
+inherit eutils qt3 autotools
+
+DESCRIPTION="a soft phone for your VOIP communcations using SIP"
+HOMEPAGE="http://www.twinklephone.com/"
+SRC_URI="http://www.xs4all.nl/~mfnboer/twinkle/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="arts speex ilbc"
+
+# Requires libqt-mt actually... Is that *always* built, or do we need to check?
+RDEPEND=">=net-libs/ccrtp-1.3.4
+ >=x11-libs/qt-3.3.4-r6
+ >=dev-cpp/commoncpp2-1.4.1
+ arts? ( kde-base/arts )
+ media-libs/libsndfile
+ media-libs/speex
+ dev-libs/boost
+ speex? ( media-libs/speex )
+ ilbc? ( dev-libs/ilbc-rfc3951 )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch "${FILESDIR}"/${PN}-0.4.1-badcflags.patch
+# epatch "${FILESDIR}"/${P}-autoconfspeex.patch
+# eautoreconf
+}
+
+src_compile() {
+ econf --disable-qt-check \
+ $(use_with ilbc) \
+ $(use_with arts) \
+ $(use_with speex) || die 'Error: conf failed'
+ emake || die "Error: emake failed!"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README THANKS
+}
diff --git a/net-im/twinkle/twinkle-0.8.ebuild b/net-im/twinkle/twinkle-0.8.ebuild
index c866c67f8617..6cb21889e4d7 100644
--- a/net-im/twinkle/twinkle-0.8.ebuild
+++ b/net-im/twinkle/twinkle-0.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/twinkle/twinkle-0.8.ebuild,v 1.1 2006/07/06 05:24:37 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/twinkle/twinkle-0.8.ebuild,v 1.2 2006/07/10 23:25:01 dragonheart Exp $
inherit eutils qt3 autotools
@@ -35,7 +35,10 @@ src_unpack() {
}
src_compile() {
- econf --with-ilbc $(use_with arts) $(use_with speex) || die 'Error: conf failed'
+ econf --disable-qt-check \
+ --with-ilbc \
+ $(use_with arts) \
+ $(use_with speex) || die 'Error: conf failed'
emake || die "Error: emake failed!"
}