summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-01-08 19:15:55 +0000
committerAron Griffis <agriffis@gentoo.org>2004-01-08 19:15:55 +0000
commit683626f3246d0a13b85a274e4a2d058ee4fa5eb5 (patch)
tree78973789d220199ce4698781f94953e244185ded /net-irc/ctrlproxy/ctrlproxy-2.6.ebuild
parentversion bump (diff)
downloadgentoo-2-683626f3246d0a13b85a274e4a2d058ee4fa5eb5.tar.gz
gentoo-2-683626f3246d0a13b85a274e4a2d058ee4fa5eb5.tar.bz2
gentoo-2-683626f3246d0a13b85a274e4a2d058ee4fa5eb5.zip
version bump
Diffstat (limited to 'net-irc/ctrlproxy/ctrlproxy-2.6.ebuild')
-rw-r--r--net-irc/ctrlproxy/ctrlproxy-2.6.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-irc/ctrlproxy/ctrlproxy-2.6.ebuild b/net-irc/ctrlproxy/ctrlproxy-2.6.ebuild
new file mode 100644
index 000000000000..41b194d4ebbf
--- /dev/null
+++ b/net-irc/ctrlproxy/ctrlproxy-2.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/ctrlproxy/ctrlproxy-2.6.ebuild,v 1.1 2004/01/08 19:15:47 agriffis Exp $
+
+IUSE="ssl"
+
+DESCRIPTION="IRC proxy with multiserver and multiclient support"
+HOMEPAGE="http://jelmer.vernstok.nl/${PN}/"
+SRC_URI="http://jelmer.vernstok.nl/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~x86"
+IUSE=""
+DEPEND="
+ >=dev-libs/glib-2
+ dev-libs/popt
+ dev-libs/libxml2
+ dev-libs/tdb
+ dev-libs/libpcre
+ ssl? ( dev-libs/openssl )"
+
+src_compile() {
+ use alpha && append-flags -fPIC
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make install \
+ DESTDIR=${D} \
+ man1dir=/usr/share/man/man1 \
+ man5dir=/usr/share/man/man5 || die
+ gzip ${D}/usr/share/doc/*/*
+ dodoc ctrlproxyrc.example
+}