summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-11-10 16:08:04 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-11-10 16:08:04 +0000
commit06f88045f91012b525b5ab31683e588b66afc536 (patch)
tree8e01075e490031beda724f5271d30e63eb0f2e14 /net-irc/miau
parentx86 stable (diff)
downloadgentoo-2-06f88045f91012b525b5ab31683e588b66afc536.tar.gz
gentoo-2-06f88045f91012b525b5ab31683e588b66afc536.tar.bz2
gentoo-2-06f88045f91012b525b5ab31683e588b66afc536.zip
Version bump
(Portage version: 2.1.3.19)
Diffstat (limited to 'net-irc/miau')
-rw-r--r--net-irc/miau/ChangeLog7
-rw-r--r--net-irc/miau/files/digest-miau-0.6.53
-rw-r--r--net-irc/miau/miau-0.6.5.ebuild69
3 files changed, 78 insertions, 1 deletions
diff --git a/net-irc/miau/ChangeLog b/net-irc/miau/ChangeLog
index 7ee05999c5a2..e74ac4848339 100644
--- a/net-irc/miau/ChangeLog
+++ b/net-irc/miau/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/miau
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/miau/ChangeLog,v 1.12 2007/05/28 18:10:22 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/miau/ChangeLog,v 1.13 2007/11/10 16:08:03 armin76 Exp $
+
+*miau-0.6.5 (10 Nov 2007)
+
+ 10 Nov 2007; Raúl Porcel <armin76@gentoo.org> +miau-0.6.5.ebuild:
+ Version bump
28 May 2007; Raúl Porcel <armin76@gentoo.org> -miau-0.6.2.ebuild,
miau-0.6.4.ebuild:
diff --git a/net-irc/miau/files/digest-miau-0.6.5 b/net-irc/miau/files/digest-miau-0.6.5
new file mode 100644
index 000000000000..4665aefd733c
--- /dev/null
+++ b/net-irc/miau/files/digest-miau-0.6.5
@@ -0,0 +1,3 @@
+MD5 cbce4182d66430a965a5fff26738ce3f miau-0.6.5.tar.bz2 205401
+RMD160 f47385cd5a75c90fa30a34ef795e40072cd131ba miau-0.6.5.tar.bz2 205401
+SHA256 deabee9db4884fcdf3142292cfb3c2e6d62bab0a2dbdda0e8ddf11d892a66a9a miau-0.6.5.tar.bz2 205401
diff --git a/net-irc/miau/miau-0.6.5.ebuild b/net-irc/miau/miau-0.6.5.ebuild
new file mode 100644
index 000000000000..4ca442f87b06
--- /dev/null
+++ b/net-irc/miau/miau-0.6.5.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/miau/miau-0.6.5.ebuild,v 1.1 2007/11/10 16:08:03 armin76 Exp $
+
+inherit eutils
+
+DESCRIPTION="Persistent IRC bouncer with multi-client support - a fork of muh"
+HOMEPAGE="http://miau.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug ipv6"
+
+DEPEND=""
+
+pkg_setup() {
+ if use ipv6; then
+ echo
+ ewarn "Enabling the ipv6 useflag will disable ipv4 entirely. Press"
+ ewarn "Ctrl+C now if you don't want this."
+ echo
+ ebeep 5
+ fi
+}
+
+src_compile() {
+ # --disable-debug seems to actually enabled it, using if use rather than
+ # use_enable to get around it.
+ if use debug; then
+ myconf="--enable-debug"
+ fi
+ econf \
+ --enable-dccbounce \
+ --enable-automode \
+ --enable-releasenick \
+ --enable-ctcp-replies \
+ --enable-mkpasswd \
+ --enable-uptime \
+ --enable-chanlog \
+ --enable-privlog \
+ --enable-onconnect \
+ --enable-empty-awaymsg \
+ $(use_enable ipv6) \
+ ${myconf} \
+ $(use_enable debug enduserdebug) \
+ $(use_enable debug pingstat) \
+ $(use_enable debug dumpstatus) \
+ || die "econf failed."
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed."
+ dodoc AUTHORS ChangeLog TODO README || die "dodoc failed."
+
+ mv "${D}/usr/share/doc/miau/examples/miaurc" \
+ "${D}/usr/share/doc/${PF}/miaurc.sample"
+ rm -rf "${D}/usr/share/doc/miau"
+}
+
+pkg_postinst() {
+ echo
+ elog "You'll need to configure miau before running it."
+ elog "Put your config in ~/.miau/miaurc"
+ elog "You can use the sample config is in /usr/share/doc/${PF}/miaurc.sample"
+ elog "For more information, see the documentation."
+ echo
+}