summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-05-31 07:32:01 +0000
committerPacho Ramos <pacho@gentoo.org>2014-05-31 07:32:01 +0000
commita900c4fbf1ffcabff18e7dd02a275b68553d8b53 (patch)
treec386f9b6b99e6cee575a509d6f9a7639580c0dd2 /net-libs/gnome-online-accounts
parentFix previous (diff)
downloadgentoo-2-a900c4fbf1ffcabff18e7dd02a275b68553d8b53.tar.gz
gentoo-2-a900c4fbf1ffcabff18e7dd02a275b68553d8b53.tar.bz2
gentoo-2-a900c4fbf1ffcabff18e7dd02a275b68553d8b53.zip
Version bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-libs/gnome-online-accounts')
-rw-r--r--net-libs/gnome-online-accounts/ChangeLog8
-rw-r--r--net-libs/gnome-online-accounts/gnome-online-accounts-3.12.2.ebuild76
2 files changed, 83 insertions, 1 deletions
diff --git a/net-libs/gnome-online-accounts/ChangeLog b/net-libs/gnome-online-accounts/ChangeLog
index b450d5999163..b60dec20e0fa 100644
--- a/net-libs/gnome-online-accounts/ChangeLog
+++ b/net-libs/gnome-online-accounts/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/gnome-online-accounts
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gnome-online-accounts/ChangeLog,v 1.39 2014/05/04 12:11:50 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnome-online-accounts/ChangeLog,v 1.40 2014/05/31 07:32:01 pacho Exp $
+
+*gnome-online-accounts-3.12.2 (31 May 2014)
+
+ 31 May 2014; Pacho Ramos <pacho@gentoo.org>
+ +gnome-online-accounts-3.12.2.ebuild:
+ Version bump
04 May 2014; Pacho Ramos <pacho@gentoo.org>
gnome-online-accounts-3.10.4.ebuild:
diff --git a/net-libs/gnome-online-accounts/gnome-online-accounts-3.12.2.ebuild b/net-libs/gnome-online-accounts/gnome-online-accounts-3.12.2.ebuild
new file mode 100644
index 000000000000..d91a1bc89731
--- /dev/null
+++ b/net-libs/gnome-online-accounts/gnome-online-accounts-3.12.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnome-online-accounts/gnome-online-accounts-3.12.2.ebuild,v 1.1 2014/05/31 07:32:01 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+
+inherit gnome2
+
+DESCRIPTION="GNOME framework for accessing online accounts"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeOnlineAccounts"
+
+LICENSE="LGPL-2+"
+SLOT="0/1"
+IUSE="gnome +introspection kerberos" # telepathy"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# pango used in goaeditablelabel
+# libsoup used in goaoauthprovider
+# goa kerberos provider is incompatible with app-crypt/heimdal, see
+# https://bugzilla.gnome.org/show_bug.cgi?id=692250
+# json-glib-0.16 needed for bug #485092
+RDEPEND="
+ >=dev-libs/glib-2.35:2
+ >=app-crypt/libsecret-0.5
+ >=dev-libs/json-glib-0.16
+ dev-libs/libxml2:2
+ >=net-libs/libsoup-2.42:2.4
+ net-libs/rest:0.7
+ net-libs/telepathy-glib
+ >=net-libs/webkit-gtk-2.1.90:3
+ >=x11-libs/gtk+-3.11.1:3
+ x11-libs/pango
+
+ introspection? ( >=dev-libs/gobject-introspection-0.6.2 )
+ kerberos? (
+ app-crypt/gcr:0=
+ app-crypt/mit-krb5 )
+"
+# telepathy? ( net-libs/telepathy-glib )
+# goa-daemon can launch gnome-control-center
+PDEPEND="gnome? ( >=gnome-base/gnome-control-center-3.2[gnome-online-accounts(+)] )"
+
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.3
+ >=dev-util/gdbus-codegen-2.30.0
+ >=dev-util/intltool-0.50
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+# Due to sub-configure
+QA_CONFIGURE_OPTIONS=".*"
+
+src_configure() {
+ # TODO: Give users a way to set the G/Y!/FB/Twitter/Windows Live secrets
+ # Twitter/Y! disabled per upstream recommendation, bug #497168
+ # telepathy optional support is really badly done, bug #494456
+ gnome2_src_configure \
+ --disable-static \
+ --disable-twitter \
+ --disable-yahoo \
+ --enable-documentation \
+ --enable-exchange \
+ --enable-facebook \
+ --enable-flickr \
+ --enable-imap-smtp \
+ --enable-owncloud \
+ --enable-pocket \
+ --enable-telepathy \
+ $(use_enable kerberos)
+ #$(use_enable telepathy)
+ # gudev & cheese from sub-configure is overriden
+ # by top level configure, and disabled so leave it like that
+}