summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2006-10-02 21:19:29 +0000
committerAron Griffis <agriffis@gentoo.org>2006-10-02 21:19:29 +0000
commitb68b9e6a99d679547870f0ac479abecfb96f1447 (patch)
treed52f7e4d19f145a8e708aab920539e8d4b1cbfd7 /net-mail/gnubiff
parentversion bump (bug #149845) (diff)
downloadgentoo-2-b68b9e6a99d679547870f0ac479abecfb96f1447.tar.gz
gentoo-2-b68b9e6a99d679547870f0ac479abecfb96f1447.tar.bz2
gentoo-2-b68b9e6a99d679547870f0ac479abecfb96f1447.zip
Bump to 2.2.1
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'net-mail/gnubiff')
-rw-r--r--net-mail/gnubiff/ChangeLog8
-rw-r--r--net-mail/gnubiff/files/digest-gnubiff-2.2.13
-rw-r--r--net-mail/gnubiff/gnubiff-2.1.9.ebuild4
-rw-r--r--net-mail/gnubiff/gnubiff-2.2.1.ebuild43
4 files changed, 55 insertions, 3 deletions
diff --git a/net-mail/gnubiff/ChangeLog b/net-mail/gnubiff/ChangeLog
index a08cc5666cb8..c9280cd2a75a 100644
--- a/net-mail/gnubiff/ChangeLog
+++ b/net-mail/gnubiff/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/gnubiff
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/gnubiff/ChangeLog,v 1.10 2006/03/21 11:31:58 dsd Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/gnubiff/ChangeLog,v 1.11 2006/10/02 21:19:29 agriffis Exp $
+
+*gnubiff-2.2.1 (02 Oct 2006)
+
+ 02 Oct 2006; Aron Griffis <agriffis@gentoo.org> gnubiff-2.1.9.ebuild,
+ +gnubiff-2.2.1.ebuild:
+ Bump to 2.2.1
21 Mar 2006; Daniel Drake <dsd@gentoo.org> gnubiff-2.1.3.ebuild,
gnubiff-2.1.9.ebuild:
diff --git a/net-mail/gnubiff/files/digest-gnubiff-2.2.1 b/net-mail/gnubiff/files/digest-gnubiff-2.2.1
new file mode 100644
index 000000000000..3d75cfd25f57
--- /dev/null
+++ b/net-mail/gnubiff/files/digest-gnubiff-2.2.1
@@ -0,0 +1,3 @@
+MD5 8d2ef679f42e7a593dc88b750d0cca4c gnubiff-2.2.1.tar.gz 804401
+RMD160 5f0a9cd01c384eab25ec96c6e74fe95c8e905ada gnubiff-2.2.1.tar.gz 804401
+SHA256 a83f1126926cbc4a558917db9b9ec9905d15a21bf465d6a56ee68ab22c37c99f gnubiff-2.2.1.tar.gz 804401
diff --git a/net-mail/gnubiff/gnubiff-2.1.9.ebuild b/net-mail/gnubiff/gnubiff-2.1.9.ebuild
index cf1ff7b8aec3..bb381889e79a 100644
--- a/net-mail/gnubiff/gnubiff-2.1.9.ebuild
+++ b/net-mail/gnubiff/gnubiff-2.1.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/gnubiff/gnubiff-2.1.9.ebuild,v 1.2 2006/03/21 11:31:58 dsd Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/gnubiff/gnubiff-2.1.9.ebuild,v 1.3 2006/10/02 21:19:29 agriffis Exp $
inherit eutils
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~x86"
-IUSE="gnome password"
+IUSE="gnome nls password"
RDEPEND=">=x11-libs/gtk+-2.4
>=gnome-base/libglade-2.3
diff --git a/net-mail/gnubiff/gnubiff-2.2.1.ebuild b/net-mail/gnubiff/gnubiff-2.2.1.ebuild
new file mode 100644
index 000000000000..603708a4316e
--- /dev/null
+++ b/net-mail/gnubiff/gnubiff-2.2.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/gnubiff/gnubiff-2.2.1.ebuild,v 1.1 2006/10/02 21:19:29 agriffis Exp $
+
+inherit eutils
+
+DESCRIPTION="A mail notification program"
+HOMEPAGE="http://gnubiff.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~x86"
+IUSE="debug fam gnome nls password"
+
+RDEPEND=">=x11-libs/gtk+-2.4
+ >=gnome-base/libglade-2.3
+ dev-libs/popt
+ gnome? (
+ >=gnome-base/libgnome-2.2
+ >=gnome-base/libgnomeui-2.2 )
+ password? ( dev-libs/openssl )
+ fam? ( virtual/fam )
+ || (
+ x11-proto/xproto
+ virtual/x11 )"
+DEPEND="${RDEPEND}
+ gnome? ( dev-util/pkgconfig )"
+
+src_compile() {
+ econf $(use_enable debug) \
+ $(use_enable gnome) \
+ $(use_enable nls) \
+ $(use_enable fam) \
+ $(use_with password) \
+ $(use_with password password-string ${RANDOM}${RANDOM}${RANDOM}${RANDOM}) \
+ ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc ABOUT-NLS AUTHORS ChangeLog NEWS README THANKS TODO
+}