summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2005-04-22 19:05:36 +0000
committerAlin Năstac <mrness@gentoo.org>2005-04-22 19:05:36 +0000
commit06d31fc68d51e423174c04ecdd33d616a46ba781 (patch)
treecca9f61547c1d457c9a7ec91475822ce8716e194 /net-news/amphetadesk/amphetadesk-0.93.1.ebuild
parentMoved ieee1394 local flag in global use.desc. (diff)
downloadgentoo-2-06d31fc68d51e423174c04ecdd33d616a46ba781.tar.gz
gentoo-2-06d31fc68d51e423174c04ecdd33d616a46ba781.tar.bz2
gentoo-2-06d31fc68d51e423174c04ecdd33d616a46ba781.zip
www-proxy/amphetadesk -> net-news/amphetadesk
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-news/amphetadesk/amphetadesk-0.93.1.ebuild')
-rw-r--r--net-news/amphetadesk/amphetadesk-0.93.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-news/amphetadesk/amphetadesk-0.93.1.ebuild b/net-news/amphetadesk/amphetadesk-0.93.1.ebuild
new file mode 100644
index 000000000000..b1ce1810ab67
--- /dev/null
+++ b/net-news/amphetadesk/amphetadesk-0.93.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-news/amphetadesk/amphetadesk-0.93.1.ebuild,v 1.1 2005/04/22 19:05:36 mrness Exp $
+
+DESCRIPTION="AmphetaDesk is a free syndicated news aggregator"
+HOMEPAGE="http://www.disobey.com/amphetadesk/"
+SRC_URI="mirror://sourceforge/sourceforge/amphetadesk/${PN}-src-v${PV}.tar.gz"
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="x86 ppc"
+IUSE=""
+DEPEND="dev-lang/perl
+ dev-perl/libwww-perl
+ dev-libs/expat
+ dev-perl/XML-Parser
+ dev-perl/Compress-Zlib"
+S=${WORKDIR}/${PN}-src-v${PV}
+
+
+src_install() {
+ dodir /usr/share/amphetadesk
+ cp ${S}/AmphetaDesk.pl ${D}/usr/share/amphetadesk/AmphetaDesk.pl
+ dodoc README.txt
+ cp -R ${S}/data ${D}/usr/share/amphetadesk
+ cp -R ${S}/docs ${D}/usr/share/amphetadesk
+ cp -R ${S}/lib ${D}/usr/share/amphetadesk
+ cp -R ${S}/templates ${D}/usr/share/amphetadesk
+ exeinto /etc/init.d; newexe ${FILESDIR}/amphetadesk.initd amphetadesk
+}
+
+pkg_postinst() {
+ # fixes bug #25066 thanks to kloeri
+ /etc/init.d/depscan.sh
+
+ einfo "AmphetaDesk should be started and stopped with the runscript located at "
+ einfo "'/etc/init.d/amphetadesk'. You can access AmphetaDesk after it has been"
+ einfo "started in your browser of choice on port 8888."
+ einfo ""
+ ewarn "If you start AmphetaDesk at boot with rc-update don't give it a browser"
+ ewarn "to start up when it loads (in the options page)"
+}
+